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About this Training Workbook

The scope of this workbook is to familiarize you with a number of intermediate-level features of SDL
Trados Studio 2009. It expands upon the knowledge that you acquired in the Getting Started training
course. This document provides practical examples of how to use following features:

Using the project wizard to create projects with multiple files

Fine-tuning format filter settings

Translating PDF documents

Performing automated quality checks

Adding custom fields to translation memories

Translating DTP files (Adobe FrameMaker and InDesign)

Creating AutoSuggest dictionaries

I R I I ™ I I I ™ ™ ™

Customizing keyboard shortcuts

The main focus of this training workbook is on practical life examples, for which training sample files are
available.

We recommend that you copy the sample files to your desktop, so that you can find them more easily,
C:\Documents and Settings\<User Name>\Desktop\Sample Files
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SDL plc Confidential. Copyright © 2009 SDL plc.



CREATING PROJECTS

This chapter provides an example of how to set up a new project
in SDL Trados Studio 2009. You will learn the following:

™

T

Specifying general project information, e.g. the project
name and due date

Selecting the project language pair
Adding source and reference documents
Adding TMs and termbases

Running the automatic project prepare task

Chapter
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Creating a New Project

Apart from opening single files for translation, SDL Trados Studio 2009 allows you to create projects,
which can contain multiple files and multiple target languages. Project creation provides a user-friendly
way of processing multiple files. For example, you can have multiple files analyzed and pre-translated
automatically.

The exercise in this chapter involves the following scenario: from your customer you have received three
Microsoft Word documents, one PowerPoint file and a reference document in PDF format. The source
documents are part of a software user guide. To create the sample project, follow the instructions below:

Project Details

1.

2.

5.

0]

After starting SDL Trados Studio 2009 click New Project on the Home screen.
This will open the first screen of the New Project wizard. Click Next to continue.

On the Project Details page enter a descriptive name for your project into the text field
Name, e.g. Spelling Checker Documentation.

Select the Due Date check box. By doing so you will enable a text field in which you can enter
the project due date. Click the arrow button next to the text field to open a calendar in which
you choose your due date, e.g. one week from your current date.

NOTE

Setting a due date is not mandatory, but it helps you keep track of timelines and dates when you need
to work with multiple projects.

New Project E] @\

Project Details

Please specify & project name and location, and optionally speciy a project description, number, customer and due date. “
Mame: Speling Checker Daocumentation
Description:
Location: C:hDocuments and SettingstZiadiMy DocumentshSOL Trados Studio\ProjectshS pelling Checker Documentation
Due Date: 15.05.2003 M| [ 12:00:00 =)
Customer, | cnones o=

Click Next to continue.

FOR MORE INFORMATION

Project Details Window

Project Languages

1.

2.

Now the Project Languages page is shown. From the Source Language dropdown list select English
(United States).

From the Target Language list select your preferred target language, e.g. German (Germany).
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NOTE
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A project can have only one source language, but several target languages. However, in this exercise
we will use only one language pair.

3.  Click Next to continue.

@ FOR MORE INFORMATION

Language Pairs

Project Files

1. Now the Project Files page is displayed. This is where you select the source files to translate. Click
the Add Folder button in the top-left corner.

2. Select the folder in which here your sample files are stored, e.g. C:\Documents and
Settings\<User Name>\Desktop\Sample Files\o1 - Project Creation\Documents.

3. The selected folder contains five sample documents: 3 DOC files, 1 PPT file, and 1 PDF file.

New Project Q @
Project Files -
Add project files o folders and verify that all flle types are comectly identified W
[ Add Files... ¢ add Folder... ¢ New Folder.. “f File Types...
L4 _SDFZ‘.‘.'"-- _;c__}f_er___l_l_)o__g_urinentatlun 2 | Mame Size Tupe Usage File Type Iden..
i ] {Source documents | 51
% brochure. pdf BEKB PDF Translatable PDF v1.000
@l] Configuring_Speling_Checke... 26KB MIC!OS% ‘Word..  Tranglatable word 2000-200
8] Language_Support.doc 20KB Microsoft Word..  Translatable Word 2000-200
] New_features.ppt 15 KB Microsoft Power..  Translatable PowerPoint XP-
B The_Check_Speling_comma 25KB  Microsoft Word Translatable Word 2000-200
= >
Translatable: 5 Feference: O
[ <Back | [ _Met> |[ Fnsh | [ Concel |

4. Allfiles contained in the selected folder have been identified as translatable documents. This
is indicated in the Usage column, which has been set to Translatable for each file.

5. Suppose that the PDF document that was given to you by your customer is only for
reference, i.e. it must not be translated. In this case you need to change the file usage.
Highlight the PDF file, and click the button Change File Usage.

6. In the Change File Usage dialog box select Reference, then click OK.

7. Confirm the message that says that the file usage has been changed successfully with OK,
then click Next to continue.

SDL TRADOS STUDIO 2009 INTERMEDIATE FOR TRANSLATORS
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@ FOR MORE INFORMATION

™M  About Project Files
™  Change File Usage

Translation Memories

1. On the Translation Memory and Automated Translation page you select the translation memories for
your project. Note that you can select more than one TM per language pair. When you select several
TMs, they are searched sequentially during translation.

2. On the left-hand side, click the project language pair, e.g. English (United States) -> German
(Germany), then drill down to Translation Memory and Automated Translation.

3.  To add the first TM click Add -> File-based Translation Memory.

4.  Select the first TM from your sample folder, e.g. C:\Documents and Settings\<User
Name>\Desktop\Sample Files\o1 - Project Creation\TMs. Select the TM for your language pair,

e.g. Software English-German.sdltm.

New Project E] @
Translation Memory and Automated Translation -
Select translation memories and automated translation servers for the language pairs selected in the project M
E 5 Al Language Pairs Translation Memory and Automated Translation
G:mp Engizh [Urided Stales Geman (Gemiand, 7 Select translation memories and automated tianslation servers and spacify
=1 Translation Memory and Automated Translation whether to include them in look-up, concordance search and whether to update
Search them:
Penalties
Fiters B Adl, - G Create -
Update Name Enabled | Loakup | Penal
p | Penalty | Concordance | Update
Autorlocalization
@ AuloSuggest Dictionariss
[ <Bask | [ _Hew> | [ &wsn | [ Cancel

5.  Repeat the above step for the second TM, e.g. General English - German.sdltm.

6. Imagine the following scenario: the Software TM is a memory that suits the requirements of

your project, as you are dealing with software documentation. The General TM might
contain useful hits too, but it should be considered a secondary TM. Moreover, the Software

TM must be updated during the translation process, but not the General TM.

7.  Therefore, make sure that the check box in the column Update is NOT selected for the
General TM. This means that this TM should only be searched, i.e. you can use this TM for
looking up segments and carrying out concordance searches. However, new translations will

not be stored in this TM.

8.  Click Next to continue.
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@ FOR MORE INFORMATION

™M  How to Add or Remove a Translation Memory

M  Translation Memory and Automated Translation

AutoSuggest Dictionaries

Next, we add an AutoSuggest dictionary. Remember that AutoSuggest dictionaries are separate databases
used for recognizing and suggesting segment fragments.

1. Click the icon AutoSuggest Dictionaries on the left-hand side of the dialog box.

2. Click the Add button in the lower right corner of the dialog box.

New Project E] | @
T Memory and A dT -
Select translation memories and automated tanslation servers for the language pairs selected in the project, W
|8 &1l Languane Pairs AutoSuggest Dictionaries
| Englsh [United Stales)sGeman (Gemany) This page lists the AutSuggest dictioraries. s the Add and Remaove buttons to add
#-§ | Tianslation Memory and Automated Translat e and remove AutoSuagest dictionaries. Use the Generate button to generate AutoSuggest
® AutoSuagest Dictionaries dictionaries,
Name
< Back ] [ MNext » ] I FEinish ] [ Cancel

3.  Browse to the folder where the sample AutoSuggest dictionaries are stored, e.g.
C:\Documents and Settings\<User Name>\Desktop\Sample Files\AutoSuggest Dictionaries.

4.  Select the AutoSuggest dictionary for your language pair, e.g. AutoSuggest_EN-US_DE-
DE.bpm by double-clicking the file.

5.  Click Next to continue.

Lﬁ] FOR MORE INFORMATION

™  About AutoSuggest Dictionaries

[ AutoSuggest Dictionaries

™M How to Add an AutoSuggest Dictionary File for a Language Pair

Termbases

1. On the Termbases page you can add one or more termbases to the project. To add the sample
termbase for this exercise, click the Add button.

2. In the Select Termbases dialog box click Browse, and select the path where the sample
termbase is stored, e.g. C:\Documents and Settings\<User Name>\Desktop\Sample Files\o1 -
Project Creation\Termbase. Then double-click the file Software.sdltb.

3.  Wait for the termbase to be loaded, then confirm with OK.
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An message box opens telling you that the termbase languages have been mapped to your
project languages. Click OK to close the message box.

In the Indexes list on the bottom of the dialog box you can verify whether the correct
termbase languages have been selected for your project. Then click Next to continue.

New Project [:} @

Temmbases s
Add termbases to the project and arder them. Set a default termbase and choose the index to use for each language. W

Termbases:

Temmbase Filter
Printer Termbase [defaul] 4 (Mot specified]

i

Indexes:

Project Language Index
E= Erglish (United States) English
B German (Germany] Geman

[ <Back || ﬂaan[ Finish | [ Cancel |

@ FOR MORE INFORMATION

™M Termbases

™  New Project Wizard > Termbases

Project Preparation

1.

In the dropdown list Task Sequence the default Prepare task is selected. This task will, among other
things, pre-translate all your source documents using the two TMs that you added in a previous
step. After the project has been created, you will only need to focus on the segments that have been
left untranslated.

FREELANCE

For freelance and standalone scenarios we recommend that you select the task sequence Prepare
without project TM from the dropdown list. That way you make sure that you later translate using the
main translation memories, i.e. no project translation memories are created.

Click Finish to start the automated project preparation.

This will display the Preparing Project page. SDL Trados Studio 2009 is now running a
number of automated tasks on the source documents, e.g. file analysis, pre-translation. Wait
for the progress bars to indicate that all processes are completed, then click Close to close
the New Project wizard.

@ FOR MORE INFORMATION

M How to Create a Project: Preparing Project

(M  Project Preparation

Click the Projects View button on the bottom of the Navigation pane. In this view you see the newly-created
project listed in the Projects view. For each project listed here, you can view essential information such as
the project name, the status (e.g. In Progress), the due date, and a timeline.
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E TIP

If you want to see where the project files are physically stored on your hard disk, right-click the project
and select Open Project Folder from the context menu. This will the folder in open Windows explorer
where all project files are stored, e.g. source and target documents, TMs.

In the next chapter you will learn how to translate the project files.

v o 04.05.2003 11.05.2003
Name Status Date Due Created At % e M DMOFSSHMDMDFS™ *

15.05,2009 12100

Batrh Tasks 3
Froject Settings...
Mark as Complete...

6T &g

Open Froject Folder ClrHAlt+0
Create Fr‘&ct Template...

{® Create Project Package...

G Remove fram List CrhF4

@ FOR MORE INFORMATION
[ Create a Project

M How to Create a Project
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TRANSLATING THE PROJECT
FILES

In this chapter you will learn how to process the pre-translated
files contained in our sample project. You learn how to use the
following features:

Viewing the Pre-translate Files report

Searching in multiple TMs

Merging and splitting segments

Finding and replacing strings

Navigating to particular segments

I I I

Filtering the display in the Editor

Chapter



Translating the Project Files

Viewing the Pre-translate Files Report

Before we translate the documents, let us have a quick look at one of the reports generated during the
automated project preparation. Click the Reports View button in the Navigation pane on the left-hand side
of the application window.

L/ Files

3 Reports

37 | Translation Memories

The Prepare task generates three reports for each target language: Translation Count, Pre-translate Files,
and Analyze Files. The Getting Started training course contains an example of an Analyze Files report. This
time, we take a look at the Pre-translate Files report by clicking the corresponding link in the Navigation
pane on the left-hand side.
DO —"
Group by languages
! Gemnan [Gemany)
T Translation Count
0P

ke

This report type provides an overview of how many segments have been automatically pre-translated using
the TMs you specified during project creation. Take a look at the Totals section, which provides pre-
translation statistics on all project source documents.

Totals

Total Type Segments Words Characters Percent Placeables

Files:4 Translated 21. 199 1063 71.58% 70
Updated ] ] 0 0.00% 0
Copy Source 0 0 0 0.00% 0
Unchanged 10 79 454 28.42% 44
Total 31 278 1517 100% 114

In the above example, all source documents combined contain 31 segments (278 words). 21 segments (199
words, i.e. 71.58%) have been translated using the project MTs. All in all, 10 segments (79 words, i.e.
28.42%) need to be translated manually.

@ FOR MORE INFORMATION

Pre-translate Report Layout

Source Document Overview

Switch to the Files View, which provides an overview of the files contained in your project.

i@l Projects

Jiles

P —)

In the Navigation pane, click the Documents folder below the project name. All project source documents
will be listed on the right-hand side. The file list provides, among other things, the total number of words
for each file as well as a progress bar, which visualizes the percentage of pre-translated content for each
file.

For example, 85% of the content in the first document (Configuring_Spelling_Checker.doc.sdIxliff) has been
pre-translated. To open the first file for translation in the Editor, double-click the file name.

| Files « | Mame Words | Stalue Fiogress Size Usage
T brochue pdr s B5KE Reference
[ G an (Germany) vl B I 85%
Froject folders ) Language_Suppor.doc sdiiff 25 Unspecified 15KB Transhatable
i Speling Checker Documentation 3] New_features.pptsdbif 19 InTranskat.. 3 18K Transkatable
1..1(’] daeuments [ B The_Cheok_Speling_comma 73 InTranshat 22KB Translatable

G My Tasks
1 Sent Tasks
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Display Filter

The first document contains a number of Context Matches (CMs). There are actually only two segments
for which no CM or 100% match has been found, and that are unconfirmed.

Configuring_Spelling_Checker.dos » Configuring_Speling_Checker.doc »

, Configuring the Spelling ‘M Die Rechtschreibpriifung .
Checker konfigurieren:
To configure the spelling  (-UE So konfigurieren Sie die
checker: Rechtschreibpriifung:
On the Tools menu, click Optionsto /& MEEM  Yahlen Sie im Menil Extras den L

3 display the Options dialog box Befehl Optionen aus, um das

Dialogfenster Optionen aufzurufen.

Suppose you would like to filter the display in the Editor, so that is only shows the segments that have not
been pre-translated:

D

Make sure the Display Filter toolbar is visible. If this is not the case, select the menu command View
-> Toolbars -> Display Filter.

From the Display dropdown list in the Display Filter toolbar select Unconfirmed Segments.

Display: | All segments + | Containing:

. |Segments with comments
b| (7] |uf Duplicate segments

- Fuzay matches T
Editor |100% pretranslated seqments Eelnalhecre Whoctmeielnts

All content i
- @ Conf{a) Sedierls lgd Project Settings... | §g 4

+1- Conf{lnconfimed seqments & Configuring the Spelling Checker

Now the Editor only displays the two untranslated segments. For the first of those two
segments, the TM provides a fuzzy match. Modify the suggested translation from the TM as
required and confirm with Ctrl+Enter.

= a0 sl £ & B

For the second untranslated segment (Close the Options dialog box.) no TM match is given.
However, the termbase has recognized the term dialog box. Remember how to insert the
target term from the termbase? Just press Shift+Ctrl+L to open a QuickPlace list with the

suggested term, and insert the target term (e.g. Dialogfeld) with Enter.

[ SchlieBen Sie das
Conliguring_Spel
3 Dialogfeld

After translating the segment, confirm it with Ctrl+Enter. Then select All Segments from the

Display dropdown list to show all segments of the current document.

FOR MORE INFORMATION

Display Filter Toolbar - Editor View

Find/Replace

Our sample termbase suggested a translation for the term dialog box (e.g. Dialogfeld). Note that the term
dialog box occurs in two more (pre-translated) segments, i.e. 3 and 4. However, in those two segments the
term was translated differently from the termbase (i.e. Dialogfenster). Imagine that the target term that is
used in segments 3 and 4 was correct in the past. However, in the meantime another target term (i.e. to
Dialogfeld) has been agreed upon and entered into the termbase, but not into the TM.

This is an example of how you can use the find/replace feature to replace the outdated target term with
the new target term. The changes made in the document through a find/replace operation can later be
easily reflected in the TM. To carry out a find/replace operation on the document take the following steps:
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1. Select the menu command Edit -> Replace, which will open the Find and Replace dialog box.

Find and Replace
Find Replace

Eind what:
Dialogfenster v

Replace with

Dialogfeld v
Loak in:

Current Dacurment v

(=] Find options
[ Match case
[ Match whole word
[ searchup

[ use

FindNeat,| | Replsce | | Replace Al

NOTE

Make sure that your the is placed somewhere inside the text. If the cursor is placed, e.g. in the
Translation Results window, the Edit -> Replace command is not available.

2.  Enter the term to be replaced into the Find what text field (i.e. Dialogfenster). Enter the new
target term into the Replace with text box (i.e. Dialogfeld). Then click the Find Next button.

3. This will highlight the first occurrence of the Find what string in the target column.

Wahlen Sie im Mend Extras den Befehl Optionen aus, um

das|Dialogfenster|Optionen aufzurufen

4.  Click the Replace button in the dialog box to replace the string. The next occurrence of the
Find what string will then be highlighted. Click the Replace button again. As you have
replaced all occurrences of the search string, a message appears telling you that no more
matches have been found. Click OK and then Close to close the Find and Replace dialog box.

NOTE

Note that since you edited segments 3 and 4 using a find/replace operation, these segments are now
in Draft status, and the recent changes have not yet been reflected in the TM.

@ FOR MORE INFORMATION

How to Find and Replace Text

Display Filtering for Strings

Suppose you would like to verify at all segments that contain the term dialog box in order to confirm
whether the target term for dialog box is now used consistently throughout the document. You can use the
Display Filter feature to only show segments that contain a particular string:

1. Enter dialog box into the Containing text field of the Display Filter toolbar, then press Enter.

Digplaw: | Al segments v | Contzining: dialog box| 3 InSource ~ g &F

2. This will display only the three segments that contain the term that you entered above. This
makes it easier to verify those particular target segments.

3. Once you have double-checked that the find/replace operation has been carried out correctly
in the target segments, confirm segments 3 and 4 with Ctrl+Enter, thereby updating your
T™.

4. To display all segments click the toolbar button Reset all filters.

57 InSource - Sg '
J () O [ & L] |Reset all filters
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Now that you have finished translating and editing the document, you can save the changes using the
menu command File -> Save, then close the document through File -> Close.

Go back to the Files View and double-click the second translatable document (Language_Support.doc.sdlxliff)
to open it in the Editor.

@ FOR MORE INFORMATION

Display Filter Toolbar - Editor View

Multiple TM Search

Click inside the first segment of the newly-opened document. Note that 99% matches are suggested for
segment 1 (Language Support). Both hits are shown in the Translation Results window.

Language Suppor; Sprachunterstiitzung

P
Language Support Unterstiitzte Sprachen

2 d

Spelling Checker Documentation_General English - German 05.05.2003 02:10:25

The two TM results are marked with a green + icon, which indicates that two different translation
solutions have been found for the same source segment. Whenever this is the case, a multiple translation
penalty of 1% is applied. This is why the TM results are not considered 100% matches. As a translator you
have to decide which translation best fits the current context.

On the bottom of the Translation Results window the name of the TM (i.e. Sofiware or General) in which
the match was found is displayed. Suppose you prefer the second match. To insert the second translation
solution, click the Select Next Match button in the toolbar of the Translation Results window and confirm

the segment with Ctrl+Enter.
fies Project Settings... | 1 f B &

@ FOR MORE INFORMATION

Translation Results Window

Changing the Segmentation

Splitting Segments

SDL Trados Studio 2009 segments source documents according to a set of pre-defined rules. For example,
exclamation marks, question marks, and colons are considered segment delimiters, while semicolon
characters or soft breaks are not used as delimiters. This is why segment 2 two contains two sentences,
which are separated by a semicolon:

The §be|lin§ Checker pravides support for foreign
2 languages;
Supplemental dictionaries are available on request

You can, however, change the segmentation on the fly by splitting segments. Suppose you would like to
split this segment along the semicolon character, as you prefer shorter segments:

1. Place your cursor behind the semicolon character in the source segment, then click the right mouse
button.

2. Select Split Segment from the context menu.

3.  Observe that segment 2 has been split into two segments: 2a and 2b. Translate and confirm
the both segments with Ctrl+Enter.
2 The Spelling Checker provides support for foreign

a languagesi
2 Supplemental dictionaries are available on request.
b
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[0] FOR MORE INFORMATION

How to Split Segments

Merging Segments

Now try the reverse operation: suppose you want to join segments 3 and 4. Segment 3 only contains a
single word, as the colon behind the word Note is considered a segment delimiter.

3 Mote:

4 Refer to the Online Help for more information.
1. Click both segment numbers while keeping the Shift key pressed.

2. Click the right mouse button, and select Merge Segments from the context menu.

3.  Note that the two segments have been merged into one. Translate and confirm the
(expanded) segment with Ctrl+Enter.

4.  Save the document (File -> Save) and close it (File -> Close).

@ FOR MORE INFORMATION

How to Merge Segments

Go back to the Files view, and double-click the file New_features.ppt.sdixliff to open it in the Editor. The third
file only contains a few segments that you need to translate and confirm. Afterwards, save and close the
file. Go back to the Files view, and double-click The_Check_Spelling_command.doc.sdliff-

The Go To Function

The last document contains only one untranslated segment. SDL Trados Studio 2009 offers an easy way
to navigate to segments of a particular category, e.g. to all untranslated segments. Suppose you have a
comprehensive document with only a few untranslated segments. In this case you can proceed as follows:

1. Select the menu command Edit -> Go To (default keyboard shortcut Ctrl+G).
2. This opens the Go To dialog box. Select Category from the list on the left-hand side.

3.  Make sure that the option Untranslated is checked, then click Next.

Go To x
Number ] Category
Select the segment categaries to go to
Status
Voo Untranslated [] Fuzzy Match
[] 100% Match [] Contest Match
[] Pertect Match [ Translated
[] Automated Translation
[ Brevious ] | Mext ’}J l LCloge ]
12,

4. This will lead you directly to the untranslated segment. You can close the Go To dialog with
the Close button, as there are no more untranslated segments left in the sample document.

5.  Note that the cursor is now placed inside the empty target cell. Use the menu command
Translation -> Lookup Translations to start a search in the selected TMs. A fuzzy match
translation will be inserted into the target cell. Edit the translation as required, and confirm
it with Ctrl+Enter.

From the Teols menu, chooss Spelling I Wahlen Sie im Menl Extras den
Checker or just click button Check Spelling Befehl Rechtschreibung, oder
=0 on the standard toolbar Klicken Sie auf die Schaltflache

Rechtschreibprifung, £ auf der
Standard-Werkzeugleiste|

6. Save the document with the menu command File -> Save.
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E TIP

By default SDL Trados Studio 2009 does not display tags that apply character formatting. In some
cases it may be useful to display the character formatting tags, e.g. if you need to have more control
over character formatting. To display character formatting tags click the toolbar button Toggles
display of formatting tags.
#8375 ez gz eleee
I

1
i|TDggIes display of formatting tags (only if semi-WYSIWYG formatting is enabled). (Ctr+Shift+H) ‘

When the formatting tags are displayed the segment looks as shown below:

Wahlen Sie im Menil EiExtras&f den Befehl E@pRechtschreibpriifung
. oder Klicken Sie auf die Schalifliache c@pRechtschreibprifung &3
0 auf der Standard-Werkzeugleiste

Character formatting tags (i.e. ¢f tags) occur in pairs, and enclose the string to which character
formatting is applied. When the tags are visible you can move them, for example, through drag &
drop.

@ FOR MORE INFORMATION

The Go To Function

Finalizing the Project

You have finished translating all source documents of your project. Now there are two things left to do:

M  Update the TM to make sure it includes the latest data from the translated documents
[  Generate the native format (i.e. DOC and PPT) from the SDLXLIFF documents.

To achieve both goals, take the following steps:

1. Switch to the Projects view.

‘ZR Home

u Projects e
— N

ol Prajects View

g Reports

2. Right-click your project and select Batch Tasks -> Finalize from the context menu.
Name: Status Date Due Created At Location W@ | 5
Batrh Tasks 4 Figalize

& Project Settings... Analyze Files

g MWark as Corplete.., Export files
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3.  This opens the Batch Processing dialog box. Note that the Finalize task performs exactly the
two required tasks, i.e. it updates the TMs and generates the target documents in their

respective native formats. Click Next to continue.

Batch Processing

Batch Tasks

b=
Specily a predefined task or task sequence to run, o create a custam task sequence. \?’Ué

=IO

Task Sequence: | Finalize;

il [Tk Semuerces. ]

Details
Description:

Eatch Tasks:

| Update Main Translation Memories
| Generste Target Translations

Update main translation memaries and generate target translations far files.

Cancel

4. On the next page click Finish.

5. Wait until both tasks are completed, then click Close.

() Update Main Translation Memaries  Completed
(2 Generale Target Translations Completed

Exporting the Target Files

Errors: 0, Warnings: 0
Errars: 0, Warnings: 0

Now that the target files have been generated in their native document formats, you will certainly want to
retrieve them, so that you can send them to your customer. The best way to do that is to export the files to

a location of your choice. To do this take the following steps:

1. Right-click the project name and select Batch Tasks -> Export files from the context menu.

2. Inthe Batch Processing dialog box click Next, which will lead you to the Files page, on which

the files to export are listed. Click Next again.

3. On the Settings page do the following: on the left-hand side of the page select All Language

Pairs -> Batch Processing -> Export Files.

4. On the right-hand side of the page click Browse and select a folder to which you want the

target files to be deployed, e.g. your desktop.

Batch Processing

S X

- Translation Memory and Auto

Fils wersion to saport
£ Batch Procsssing Tarael

Settings L=
Revigw the relevant settings for the selected tasks and click Finish to start executing the tasks \?’Ué
|4 File Types | -~ Expart Files
t‘; \Ifa"'manmp . Export files ta the following location:
snguage Pairs e
- Al Langusge Pairs C:Memp [ Erowse.,

Target version ||
Export Files g —
- Tembases
® & Engish [Urited States)-> German
< 2]
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5.  Click Finish, that wait for the task to complete, and click Close.

6. Open Windows Explorer and browse to the folder to which you exported the target files. Note
that the Export task creates sub-folders for each target language. For example, if your target
language is German, you will find the target files in the subfolder de-DE.

@ FOR MORE INFORMATION

Batch Processing > Export Files

Marking the Project as Complete
After finalizing a project it is recommended that you mark it as complete:

1. Right-click the project name in the Projects View, and select Mark as Complete from the context
menu.

2.  Confirm with Yes.

3.  Note that the Status column now shows Completed for the sample project (i.e. not In
Progress).

@ FOR MORE INFORMATION

How to Mark Project as Complete
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FILE TYPE SETTINGS

This chapter provides two examples of how file type settings
can be configured. You will learn how to:

™

™

Exclude speaker notes in Microsoft PowerPoint files from
translation

How to change soft break handling in Microsoft Word
documents

Chapter
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What are File Type Settings?

SDL Trados Studio 2009 supports numerous file formats, e.g. Microsoft Office, Adobe FrameMaker,
Adobe InDesign. SDL Trados Studio 2009 uses file format filters to extract translatable text from the
source documents. Each file format has its particularities. For example, Microsoft PowerPoint documents
can contain speaker notes, which sometimes may require translating, but sometimes need to stay
unchanged. Speaker notes are not available in other formats such as Microsoft Word.

By default, SDL Trados Studio 2009 exposes as much translatable text as possible. This also includes the
speaker notes in a PPTX file. Imagine the following: you need to translate a PPTX file that contains
speaker notes, but the speaker note content needs to stay unchanged.

Microsoft PowerPoint File Type Settings

-5

42

You will find a small sample document in your sample files folder, e.g. C:\Documents and Settings\<User
Name>\Desktop\Sample Files\oz - File Type Settings. Double-click the sample file New_features.pptx to open
it in Microsoft PowerPoint.

Take a look at the speaker note text on the bottom:
| L

Make sure your screen resolution is 1024x768 pixels while you are presenting.

As this is an internal note to the speaker, it does not need to be translated.

Close Microsoft PowerPoint, and take the following steps to exclude speaker notes from translation before
opening the file for translation:

1. Click the button Open Document in the toolbar of SDL Trados Studio 2009.

2. Select the file New_features.pptx from your sample files folder (C:\Documents and
Settings\<User Name>\Desktop\Sample Files\oz - File Type Settings).

3. Inthe Open Document dialog box make sure that the correct source/target language pair is
selected. The source language needs to be English (United States).

4.  Also make sure that the two TMs from the previous exercise are selected, e.g. Software
English-German.sdltm and General English - German.sdltm. If this is not the case, click Add ->
File-based Translation Memory and select the two TM files from your sample folder, e.g.
C:\Documents and Settings\<User Name>\Desktop\Sample Files\o1 - Project Creation\TMs.

5.  Click the Advanced button in the lower-left corner of the Open Document dialog box.

6. This opens the Project Template Settings - Default dialog box. Click File Types in the tree on
the left-hand side.

7. The File Types branch on the left-hand side lists a number of file formats, which are
supported by SDL Trados Studio 2009. Select Microsoft PowerPoint 2007 from the list.

8.  This will show links to various settings that you can configure for the selected format. Click
the Notes and shapes link to open the corresponding settings.

Microsoft PowerPoint 2007 [ ] Motes and shapes

Quicklnsert The processing of notes and shapes for translation can be configured below.
Hyperlinks and comments
Motes and shapes
Docurnent structure 1 3
Font mappirg Order of shapes: | Top left ta battom right by raw [ 5|
T ag verification ' )
Microzoft Excel 2000-2003

Microsoft Ewcel 2007

Openlffice

Include notes: Exclude notes 152
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9. Take alook at the settings on the right-hand side, in particular at the Include notes
dropdown list. The default setting for this setting is Notes after all slides. This means that
speaker notes (if any) are offered for translation after the content of each slide.

10. Change the dropdown list value to Exclude notes, then click OK.

1. Now you are back in the Open Document dialog box. Click OK again to open the document
in the Editor view.

12. Check whether the speaker note that you saw in the PPTX file is shown in the Editor. Since
you configured the file type setting to exclude speaker notes, this segment is not visible and
therefore not available for translation.

NOTE

The speaker note text will not be removed from the document. When you generate the translation in
the native file format, the speaker note will still be available in the original English version. The
speaker note content is just not exposed for editing or translation.

@ FOR MORE INFORMATION

Microsoft PowerPoint File Types

Microsoft Word File Type Settings

Let us take a look at another example: Sometimes you will find soft breaks in Microsoft Word documents.
Soft returns are - unlike hard returns - not considered segment delimiters. In your sample files folder, e.g.
C:\Documents and Settings\<User Name>\Desktop\Sample Files\oz - File Type Settings you will find the
sample document for this exercise, i.e. The_Check_Spelling_command.doc.

Open this file in SDL Trados Studio 2009. In the Open Document dialog box. Use the same source/target
language pair and TMs that you used in the previous exercise. At this point we are not going to change the
default file type settings. In the Editor view the document will look as shown below:

Getting Started
The Check Spelling command
2 To run the spelling checkers
Place your cursor at the point in your document where you would like
the spelling checker to begin.

Take a look at the first cell. You will note that it actually contains two segments. These two segments are
considered one segment, as they are only separated by a soft break. You can display the soft break character
by clicking the toolbar button Show Whitespace Characters.

(o

P F

= ¢[0@eo

Shiow Whitespace Characters

The segment will now look as follows:

Getting- Started !
The-Check-Spelling:command

Remember that in the previous chapter you learned how to split segments, which is what you could do in
this case. However, imagine that your document contains a lot of soft breaks, and you do not want to split
segments every time you encounter a soft break. Therefore, it would be preferable if we could 'tell’ SDL
Trados Studio 2009 to treat soft breaks like normal breaks (i.e. hard returns).

Close the current document through the menu command File -> Close. When you are prompted to save
the document, click No. We just wanted to take a quick look at the document to demonstrate how soft
breaks are handled by default.

Open the document again, but this time we will change the file type setting, so that soft breaks are treated
as segment delimiters.
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NOTE

You need to change the file type settings before opening and translating a document. Once you have
started editing a document, you cannot change the file type settings on the fly.

1. Open the sample document again. In the Open Document dialog box, make sure the correct
source/target language pair and the correct TMs are selected.

2. Click the Advanced button in the lower-left corner of the Open Document dialog box.

3. On the left-hand side of the Project Template Settings - Default dialog box select File Types,
and then Microsoft Word 2000-2003.

4. Then click the Other Settings link.

@ FOR MORE INFORMATION

Which file types are supported?

5. Inthe settings on the right-hand side of the dialog box check the option Treat soft returns as
structure tags.

® [E] Project Template | - Other settings
-5 Fie Types [ Extract comments text for translation
#-2 | SDLXLIFF
+ TRADOStag [ Extract document properties for ianslation
+ ﬁ’ SDL Edit [] Display complex scripts and Asian text font seltings
= Micrasoft Ward 2000-2003
_] Quicklnsert [ Process documents with non accepted o rejected changss
Order of text boxes
Noreranslatable stylss
Norhanslatable footnotes O F"DDESQﬂkaa'kS a5 tag pais

Norranslatable texts
Other settings

Font mapping

Tag verification

Frocess hyperinks: | &lwaps process hyperlinks v

6. Confirm the modified setting with OK. In the Open Document dialog box click OK again to
open the document in the Editor.

7.  Now that the document is open, you can see that the previously joined segments have been

split into two segments:
1 Getting-Started
2 The-Check-Spelling-command
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AUTOMATED QUALITY
ASSURANCE (QA)

This chapter provides examples of how to perform automated
quality checks on a bilingual SDLXLIFF file. You will learn the
following:

(M  What is Automated Quality Assurance (QA)?

@ Configuring QA settings

™M  Running QA checks

Chapter
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What is Automated Quality Assurance (QA)?

SDL Trados Studio 2009 provides functionality to check translations for potential problems such as
number and punctuation errors. The QA check can work in two ways:

(@ Inreal-time, i.e. upon confirming a translation, the target segment is instantly checked for a
number of specified QA criteria.

(M  In batch mode, i.e. a QA check is performed on the whole document after translation.

Configuring QA Options

SDL Trados Studio 2009 includes the QA Checker 3.0 component, which offers a wide variety of freely
configurable quality assurance options. In this chapter you will learn how to configure a number of
commonly used QA options.

1. Click Open Document in the application toolbar to open the sample document for this exercise. You
will find the document in your sample files folder, e.g. C:\Documents and Settings\<User
Name>\Desktop\Sample Files\o3 - QA Check.

2. The above folder contains partly pre-translated SDLXLIFF files. Select the document that
contains your preferred language pair, e.g. QA_Check_Sample.doc_en-US_de-DE.sdIxliff.

3.  Inthe Open Document dialog box click the Advanced button.

4. In the Project Template Settings - Default dialog box select Verification -> QA Checker 3.0 on
the right-hand side.

5.  Click Segment Verification and take a look at the options on the right-hand side of the dialog
box. The option Check for forgotten and empty translations is active by default. This setting
checks your document for segments that you neglected to translate.

#-£] Project Template Segment Yerification
%[5 File Types
=[5y Veification Check for forgatten and empty trareslations Error £

=+[@ 0OA Checker 30

Check for segments where:
[] Source and target are jdentical

Inconsistencies

Punctuation
Mumbers
‘wéord List

Regular Expressions
Trademark Check Check for target segments which are:

Length Verification [ Sharter by [%)

6. Click the link Inconsistencies, which will display another set of QA options on the right-hand
side of the dialog box. Activate the option Check for inconsistent translations. This will verify
whether repeated segments within a document have been translated differently, i.e.
inconsistently.

7. Also, activate Check for repeated words in target. This will point you to target segments with
accidentally repeated words, e.g. you you said that.

=-[Z 0OA Checker 3.0 LI lanore tags
Segments Varification @l Ireen
Segments to Exclude .
Inconsistencies [#1: Check for iepeated words in fagef | Waming v
Purctuation
lgnore numbers
Humbers L tgnore o [
word List [ lanore case

Fiegular Expressions

8.  For each verification option you find a dropdown list from which you can select the severity
level. Error points to critical mistakes, Warning indicates potentially serious mistakes, while
Note is used to flag less serious problems. The default level for repeated words is Warning.
Suppose you want to raise the level to Error, as you consider word repetitions very serious. To
do this select Error from the dropdown list next to the Check for repeated words in target
option.
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9. Click the Punctuation link to display another set of options related to possible punctuation
errors in your document.

10. Activate the option Check that source and target end with the same punctuation. When you
activate this setting, SDL Trados Studio 2009 will e.g. report segments that end with a
question mark in the source segment, but with an exclamation mark in the target segment.

1. A common type of error are redundant spaces, e.g. instead of inserting one space you
accidentally hit the space bar on your keyboard twice. To be sure, this is a cosmetic error, but
it can be hard to spot just by looking at a segment. To check your translations for this type of
error activate the option Check for multiple spaces.

Check that source and target end with the same punctuation | Wamning 4

[] Check for Spanish punctuation (¢! and 71

[ Check for unintentional spaces before:

Check for multiple spaces: [} Make i

[ Check for multiple dots

12. The last option we would like to take a look at in this exercise is the number verification.
Click the link Numbers, and then activate the option Check numbers on the right-hand side.

13. Click OK, and then again OK to open the document.

Interactive Verification
Let us see how the interactive QA check works:

1. Most of the document is already translated. Focus on translating segment 7, i.e. Connecting and
turning on the power.

2. At some point in the translation, insert a redundant space on purpose,
AnschliefienesundsEinschaltensdersStromversorgung.

3.  Press Ctrl+Enter to confirm the segment. Confirming the segment triggers the interactive
QA check in the background.

4. Between the source and the target segment you will see a white Note icon. This indicates
that something maybe wrong with your translation. Move the mouse pointer over the
symbol to display a tooltip with more information. In this case it will say that an extra blank
space was detected.

AnschlieBen-und:Einschalten der-

Translation Details:
Status: Translated
Origin: Interactive
Scare: 0%

IMessages: tcerm wechsel
Information: Extra blank spaces detected, p5 ]

5.  Go back up to segment 7, remove the extra blank space, and press Ctrl+Enter again.

6. The Note icon should now has been removed from segment 77, and you find yourself in
segment &: To connect and turn on the power, follow these steps:

7.  Translate segment &, but make a punctuation mistake on purpose: the English segment
ends with a colon. In your translation replace the colon with a full stop, Zum Anschliefien
und Einschalten der Stromversorgung wie folgt vorgehen.
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8.  After confirming the segment with Strg+Enter, a yellow Warning icon will appear next to
your translation. Move the mouse over the icon to display the tooltip, which will tell you that

an end punctuation difference has been detected.

AZum-Anschlieenund: Einschalten: der Stromversorgung wie:
Translation Details:
Status: Translated
Origin: Interactive

Score: 0% Em'\f\iechse\strumadapter'und'

(Ej? Ef ?;:Z;tgfﬂ EIQ 3 ,. o ‘Wechsaltromkabe! aripraart’
Score: 0% whiideten atweichern.
er ‘Steckdose.

Messages ! jeste
WWarning: End punctuation difference detected. flus-Taste deuchiet stati griin,

9. Go back to segment 8 and correct the end punctuation error. Then confirm the modified
translation with Ctrl+Enter, which will remove the Warning icon.

Batch Verification

In addition to the interactive verification, you can also perform a QA check on the entire document:

Select the menu command Tools -> Verify. This will run a QA check on the document using all QA
check options that you configured previously.

-

| Tools | Help

x Check Spelling... F7

| werify F8. ||
|

ie Qer%rate AutoSuggest Dictionary...
f{_, Upgrade Translation Memories...
\ & Plug-ins...
Wiew Log File. ..
: & COptions...

Manage User Profiles... ]

2. Issues that have been identified as potential problems will be listed above the document in
the Messages window. The Messages tab also states the number of issues found (4).

| Severly  Message Source

| 0 Murber is missing in target seament or is not properly localized. 04 Checker 3.0
iy Repeated word found: mit 04 Checker 3.0

| @ Segment is not translated. QA Checker 3.0

AN Sentence was hianslated inconsistently - compared to segment 1071 A Checker 3.0

Flaceables Sample Engiish-German - Translation Results | €3 ME“&ES (4] | Comments
0&_Check_Sample.doc_en-US_de-DE sdldlift [Translation]”

B la s smimms sl min i mim s = im s b il e

— ]Messagas “window [2 emors, 2 wamings, 0 nates) |

3.  Double-clicking a message will lead you directly to the segment the message refers to. For
example, double-click the first message, which points to a number error:

0 Murnber is migsing it target seament or is not properly localized, & Checker 3.0 0A_Check_Sample.doc_t
[%] Repeated word found: mit 04 Checker 3.0 04_Check_Sample doc:_¢
[%] Segment is not translated. G& Checker 3.0 04_Check_Sample.doc_¢
/iy Sentence was hianslsted inconsistently - compared to segment I3 1 04 Checker 3.0 0A_Check_Sample doc_e

Placsables Sample English-Geiman - Translation Restlts | Messages (4) | Comments

G&_Check_Sample.doc_en5_de-DE sdlsiff [Translation]”
wechsen 'und Papier einfligen kdnnen.
Allow -at-least -l cm clearance from the back ‘of the ‘photo: ) Lassen 'Sie' mindestens 21 cm*Abstand vonder-
S printer for ' the ‘Heiper 'ho-travel. Ruckseite des Eofodruckers, 'damit das Papier
herausfahren kann.

4. The number 12 is missing in the target segment. Note that the target segment is also flagged
with a red Error icon. Correct the number error in the translation and confirm it with
Ctrl+Enter. This will remove the red Error icon, and also reduce the number of mistakes
reported in the Messages window.

5. Insegment 12 a repeated word has been found (i.e. Das mit mit lhrem...). Remove the
repeated word and confirm the corrected translation.

6. QA Checker has also reported segment 16 (Section:), which has not been translated at all.
Translate the segment and confirm it.
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The last segment (16) has been found to contain an inconsistent translation. Move the
mouse pointer over the yellow Warning icon. A tooltip will tell you that the same source
segment was found at the beginning of the document (segment 1), where it was translated
differently. In this example, Getting Started was translated with Erste Schritte (segment 1).
However, in segment 17 a different translation was used, e.g. Einstieg.

Modify segment 17, so that it is consistent with segment 1. You can then save the document
(File -> Save) and close it (File -> Close).

FOR MORE INFORMATION

How to Specify Settings for the QA Checker
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TRANSLATION MEMORY FIELDS

This chapter provides an example of how to use translation
memory (TM) fields. You will learn the following:

™

™
™
™

What are TM fields?
Defining TM fields
Applying field values to segments

Filtering for translation units with particular fields values

Chapter
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What are TM Fields?

A TM stores source segments and their translation as so-called translation units (TUs). For each TU the
TM automatically stores information such as the name of the user who translated a segment and when.

Apart from that you can also store additional information in user-defined fields. Example: if you want to
know for which customer a particular segment was translated, you can add a Client field to your TM. This
allows you to track the client for whom a particular segment was translated. This can be useful when, for

example, client A requires different translations than client B, e.g. for stylistic reasons.

In the following exercises you are going to translate three short sample documents for the fictitious clients
A, B, and C. Use the sample files stored in, e.g. C:\Documents and Settings\<User Name>\|Desktop|Sample

Files\o4 - TM Fields.

@ FOR MORE INFORMATION

About Translation Memory Fields

Defining TM Fields

1.

2.

First, open the document file_info_client_A.doc.

In the Open Document dialog box, make sure that English (United States) is selected as the
source language.

Then select your preferred target language, e.g. German (Germany).

Make sure that no TMs from previous exercises are selected. If this is the case, remove them
with the button Remove.

Click Create -> New File-based Translation Memory to create a new TM for this exercise.

In the New Translation Memory dialog box enter the name for your TM into the text field
Name, e.g. TM Fields Sample English-German, then click Next.

Now you will see the page Fields and Settings. Suppose you want to be able to track for which
customer a particular segment was translated. Go to the Fields section of the dialog box and
enter the name of your field into the Name column, e.g. Client.

Click the cell below the Type column header to specify the type for your new field. Suppose
that you want to associate your field with a list of pre-defined clients. Therefore select List as
the field type.

Click the cell below the Picklist column header. This opens an empty list in which you enter
your clients: Client A, Client B, and Client C. After entering the first client press Enter to add
a new line.

Eiglds

MName Type Picklist Allow Multiple YV alues

Client  List Client & Clisnt B Client C [+ | O
s
Client B
Cliert C %
Gt
oK Cancel
-

10. After you have entered all three clients click OK to close the list.

1.

Make sure to select the option Allow Multiple Values. When you do this, one TU can be
associated with more than one client.
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12. Let us take another step: suppose you also want to store a project id with each TU. Go
to the row below the newly-added Client field and enter Project id in the Name column.

13.  As Type select Text. This means that Project id is a free text field, i.e. it is not associated
with a pre-defined list of values. This makes sense, as you might only have a limited
number of clients, but maybe thousands of different project ids in the course of a
business year.

14. Make sure to select the option Allow Multiple Values for the Project id field too.

New Translation Memory
Fields and Settings 'z_
Specily fieds and setings fr ths new Uanslation memory —

Fields

Mame Type Picklist Allaw Multiple Values Add
Client List Client & Client B Client C
Projectid Test

Sellings
Recognize dates Recognize aoronyms
Recogrize fimes Recognize varishles

ez oo (@ R oo

[ < Back H Next > ll EImShR{J [ Cancel ]

15.  Click Finish and Close, when the progress bar indicates that the TM has been created.

@ FOR MORE INFORMATION

Translation Memory Settings Dialog Box: Fields and Settings

Applying Fields to TUs

In the previous steps you have defined the TM fields. Now you will learn how to apply field values to
the TUs you add to the TM while translating the first sample document:

1. You should now be back in the Open Document dialog box. Click the Advanced button.

2. Inthe Project Template Settings - Default dialog box click Language Pairs and then drill
down to your current language pair, e.g. English (United States) -> German (Germany).
Drill further down to Translation Memory and Automated Translation -> Update.
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3.  On the right-hand side of the dialog box, you will see the two fields that you defined
previously. Click the cell Value next to the Client field to open the list of pre-defined values.
Select Client A from the list by clicking the check box next to it.

Field e
Client 2
Project id Clieni &

Chilient &

[] Client C

4. Go to the next row to enter a Project id value. Remember that this is a free text field, therefore
no pre-defined values are available. Click inside the Value column next to the Project id field.
This will enter a field in which you enter the project id 2009_oo1. Then click OK to confirm.

Field Walug

Clierit Clignt &

Project id 2003_001 -
2009_001 I

5.  Close the Project Template Settings - Default with OK. In the Open Document dialog box click
OK again to open the sample document in the Editor. Note that every segment you translate
and store in the TM from now on will be associated with these two field values.

6. Translate and confirm all segments in the document. When you get to segment 4, you will
get a high fuzzy match from the TM, as it is very similar to segment 3:

fil_info_client_# doc [Translation er-U35-de-DE]*

file_info,_client_A.dos , file_info._client_A.doc
1 Client A ] Kunde A
. Viewing File Information o Datei-Informationen
abrufen
3 Select the name of the folder i Wahlen Sie den Namen des
Ordners aus
4 Select the name of the file. { Wahlen Sie den Namen der
Datei aus.

7.  Take alook at the Translation Results window. Note the information displayed next to the
target segment from the TM. It shows the field values associated with this TU. As
mentioned previously, the selected field values are stored with each translation that you

create.

Select the name of the file,

Select the name of the aldsiil. Wizhlen ie den Namen [T preject id
~ des Ordners aus. 2009_0D01
1 Client
Client &

8.  Modify the suggested translation so that it fits the current context, and confirm it with
Ctrl+Enter.
9. Translate the last segment, and confirm it too. Save the file with the menu command File ->

Save, then close the file with File -> Close.

@ FOR MORE INFORMATION

Translation Memory and Automated Translation > Update

Filtering TUs

Apart from adding field values to TUs, you can also use TM fields to specify filters. There are two types of
filters available:

6-4 SDL TRADOS STUDIO 2009 INTERMEDIATE FOR TRANSLATORS
SDL plc Confidential. Copyright © 2009 SDL plc.


http://producthelp.sdl.com/SDL%20Trados%20Studio/client_en/Ref/O-T/TM/Translation_Memory_Update.htm

Translation Memory Fields @
I

Filter penalties are used to 'penalize’ segments from the TM with field values that do not
match your filter.

Hard filters, on the other hand, hide any translations from the TM that do not match a
specified filter.

The following exercises provide examples of both filter types.

Filter Penalties

In the previous section you learned how to apply field values to TUs. Now we use field values to filter
for particular TUs. Suppose you now need to translate a document for Client B:

1.

2.

Open the sample document file_info_client_B.doc.
In the Open Document dialog box click the Advanced button.

In the Project Template Settings - Default dialog box select Update again. Note that the
field values from the previous document are still selected (i.e. Client A and Project id
2009_001). Deselect the value Client A by unchecking the box next to it. Then check the
value Client B.

Replace the project id from the previous document. To do this click inside the previous
project id value (i.e. 2009_001). This opens a field in which you can modify the project
id by double-clicking and then editing it, i.e. change it to 2009_o002. Note that every
translation that you create from now on will be associated with this new set of values.

In addition to applying field values, let us also define a filter. Click the link Filters to
display the filter options on the right-hand side of the dialog box.

In the section Filter Penalties click the Add button.

Eilter Penalties

37 The following fiters will cause filter penalties to be applied for non-matching translation units:
¥

Mame Penalty Condition
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8.

10.

1.

12.

This opens the Add Filter dialog box. Enter a name for your filter into the Name text field.
This can be any name, e.g. ClientFilter. Then click the Add button.

Add Filter M=
Mame: |ClientFilter Penalty: 1 =
NaT Condition AND/OR
[ Use parentheses in this filker Add...
Condition R
I
[ 0K l [ Caneel I I Help ]

This opens the Add Condition dialog box. Select Client B from the Value dropdown list, then
click OK.

Add Condition
Field | Client [v]
Operator | Equalto vl

Valie
Efent B v

l [1].4 !}J l Cancel ] [ Help ]

Click OK again to close the Add Filter dialog box. Your filter should now look as shown
below. Click OK to close the Project Settings Template - Default dialog box, and then click OK
again to open the document in the Editor.

Filker Penalties

37 © The fallowing fiters will cause fiter penalties to be applied for nan-matching trarslation units:

H
Name Penalty Condition
CligrtFilker 1 Cligrt = "Client B"

Start translating the document, which is very similar to the one from the previous exercise.
When you get to segment 2 you will get a high fuzzy match (99%), although this segment is
100% identical to a segment that you translated in the previous document. The TM match
has been reduced to a 99% match, because it does not match our filter. Take a look at the TU
in the Translation Results window:

Wiewing File Information | DatetInformationen abrufen Project id
. Z009_001

1 Client
Score: 99 S

Filter mismatch penalty (ClientFilter) (-1%)

The filter searches for TUs with the value Client B, but the TM match is associated with
Client A. Move the mouse pointer over the filter icon in the Translation Results window. A
tooltip will be displayed, informing you that a penalty of 1% was deducted, as the TU from
the TM does not match your filter.

Suppose that for this segment it does not matter that the translation was done for a different
client, i.e. the translation created for Client A is also valid for Client B. Confirm the segment
with Ctrl+Enter and do the same for segments 3 and 4.
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16.
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Now that you have accepted the translations, you might wonder what has happened to
the field values associated with this TU. Use the Up key on your keyboard to move back
to segment 4. Take a look at the information in the Translation Results window. Note
that for this TU both client and project id values have been stored, i.e. 2009_001,
2009_002 and Client A, Client B.

Use the Down key to move to segment 5. Suppose that this time you cannot just accept
the translation suggested by the TM, as Client B requires a different translation.
Example: for Client A you wrote Ein Informationsfenster offnet sich. For Client B you need
to write: Es dffnet sich ein Informationsfeld. Overwrite the suggested translation with an
alternative target segment.

Before you commit the new translation to the TM consider the following: if you
confirm the translation with Ctrl+Enter you will overwrite the previous translation.
Suppose that you want to keep BOTH solutions in the TM. To do this select the menu
command Translation -> Add as New Translation.

NOTE

If you do not use this command, the new translation will overwrite the old one.

Take a look at the Translation Results window: note that this time two different TUs
have been stored, one for Client A / Project id 2009_oo1 and another one for Client B /
Project id 2009_002. Now you have two different TUs for two different clients.

An information windaw opes. m Ein Informationsfenster oifnet sich. LI Project id
2003_002
lient
client B
An information window opens. Es offnet sich ein Informationsfenster. Project id
< | 2009_001
2 r lient
Client A

il

NOTE

From this point forward both TUs will be suggested when a similar or identical source segment
comes up next time. The TU with the matching field values will be preferred and offered first,
while the TU that does not match the filter will be penalized and only offered as a secondary
solution.

NOTE

You can use the menu command Translation -> Add as New Translation whenever you want to
store a separate TU with an alternative translation for the same source segment, regardless of
whether you use TM field values or not. Alternative translations might also be required when
you are translating for the same client, project, etc. Example: the same source segment needs
to be translated differently, because one time it occurs in a paragraph, the next time an
alternative translation is required, because the segment comes up in a footnote.

You can now save the file with File -> Close and then close it with File -> Close.
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@ FOR MORE INFORMATION

™M  Filters

™M Translation Memory and Automated Translation > Filters

Hard Filtering

In the previous exercise you learned how to define a filter penalty to 'penalize’ TUs that did not match your
filter. Hard filtering is used if you do not want any non-matching TUs to be shown in the first place:

1.

2.

Open file_info_client_C.doc from your sample files folder.
In the Open Document dialog box click the Advanced button.

In the Project Settings Template - Default dialog box click the Update link, and set the field
values as follows: Client: Client C, Project id: 2009_003.

Click the Filters link, and remove the penalty filter you defined in the previous exercise. To
do this, highlight the filter name (i.e. ClientFilter) and click the Delete button.

MName Penalty Condition
{ ChentFilter 1 Client = "Chent B

Go down to the Hard Filter section, and click the Edit button.

In the Filter dialog box click the Add button.

Filter =1
MHOT Candition ANDJOR
[] Use parentheses in this filker Add
Condition k
[ ok J[ cancel | [ Hep |

In the Add Condition dialog box select Client C from the Value dropdown list, then click OK.

Add Condition
Field Client -
DOperator | Equalto [
Vil
Client & [v]
Clent &

Client B
[ClientC N |
g
0K, I [ Cancel ] [ Help ]
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Click the OK button to close the Filter dialog box, and click OK again to close the
Project Template Settings - Default dialog box.

Finally, in the Open Document dialog box click OK to open the document.

Note that when you go through the segments of this third sample document, the TM
will not suggest any matches, although it should contain suitable translations, as you
translated two very similar documents previously. This is because the hard filter hides
any TUs that do not match your filter.
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DTP FORMATS

This chapter provides examples of how to translate DTP
formats with SDL Trados Studio 2009. You will learn the
following:

™

4 W [

Examples of DTP formats that can be processed with
SDL Trados Studio 2009

Opening a project package that contains DTP files
How to process translations that have been rejected
How to preview DTP files in their native applications

How to create a return package
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What are DTP Formats?

DTP stands for Desktop Publishing. There are various DTP systems available on the market. In this
chapter we will provide examples of how to translate two of the most common DTP formats, i.e.

™
™

Adobe FrameMaker
Adobe InDesign

Translating DTP Files

72

The following exercise describes a scenario in which you receive a project package with two pre-translated
DTP sample files (Adobe FrameMaker and Adobe InDesign CS3). Make sure that you have copied all
sample files to your desktop, i.e. you should find the sample project package in the following location:
C:\Documents and Settings\<User Name>\Desktop\Sample Files\o5 - DTP

Opening the Sample Project Package

1.

(D

Click the toolbar button Open Package and select the package file with your preferred source/target
language pair, e.g. DTP Sample Project English-German.sdlppx.

In the Open Package dialog box, click Finish to extract and import the package content.

In the Browse for Folder dialog box select an empty folder to extract the project package files
or use the Make New Folder button to create a new (empty) folder.

NOTE

For detailed information on the package import process please refer to the Getting Started training
workbook for SDL Trados Studio 2009.

After the package content has been imported into your SDL Trados Studio 2009
environment, switch to the Files view. This will show you the two pre-translated SDLXLIFF
files. One was generated from an Adobe InDesign document (New_features.inx.sdlxliff), the
other one from an Adobe FrameMaker document (Spell_check_options.mifsdlxliff).

NOTE

In order to process Adobe FrameMaker and InDesign documents in SDL Trados Studio 2009, the
source documents need to be available in the applicable interchange format: MIF for Adobe
FrameMaker, INX or IDML for Adobe InDesign. These exchange formats can be generated from the
native applications.

FOR MORE INFORMATION

™M How to Open a Package

™M  Importing Packages

Translating the InDesign File

1.

2.

In the Files view, double-click New_features.inx.sdlxliff to open it in the Editor.

The document has been pre-translated to a large extent. (Only the last segment is
untranslated.)
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Note that segment 3 is highlighted, which means it contains a comment. Also, the
translation status icon between the source and the target segment indicates that this
translation has been rejected. Move the mouse pointer over the segment to view the full

comment text in a tooltip.

] Die aktuellste Quality Assurance Checlker-Funktion sorgt fiir eme s
automitisierte Qualitatssicherung
f@ﬂCUmment[ZladJ 11,05.2009 16:33:31]: This franslation is too long-winded, Please shorten it

fo

The person who created the project package (i.e. the project manager) added a comment
telling you that the suggested translation is too long, and asks you to shorten it. In DTP files
(e.g. product brochures) length can be an issue. If a translation is too long, it might not fit
into the assigned textbox. Shorten the segment to say, e.g. Bessere Qualititssicherung mit dem
neuesten QA Checker and confirm the edited translation with Ctrl+Enter.

Add a comment of your own: right-click your modified translation, and select Edit Comment
from the context menu.

In the Edit Comment dialog box click the Add button.
In the Add Comment dialog box enter a comment text, e.g. | hope this is short enough.

Click OK. Note that in the Edit Comments dialog box two comments are now listed, i.e. the
original comment from the project manager, and the comment that you just added yourself.
Click OK to close the Edit Comments dialog box, then confirm your translation with
Ctrl+Enter.

Translate the last segment, e.g. say Integrierte Terminologiepriifung.

Review if your translation is correct. Also use the Tools -> Verify command to check for any
tag errors. Then save the document with File -> Save.

Finally close the document with File -> Close.

FOR MORE INFORMATION

Edit Comments

FOR MORE INFORMATION
Adobe InDesign CS2-CS4 INX > Settings

Translating the FrameMaker File

1.

Switch back to the Files view, and double-click the file Spell_check_options.mif.sdIxliff to open it in the
Editor.

This file has also been pre-translated to a large extent. It contains a number of confirmed
100% matches and context matches. Suppose you only want to see the untranslated
segments. This is where the Display Filter feature comes in handy: select Unconfirmed
segments from the Display dropdown list to show only untranslated segments and segments
with fuzzy matches.

Segment 3 is a high fuzzy match, as the only thing missing in the suggested translation is
the index tag. Insert the tag at the corresponding position in the target segment using the
shortcut key Ctrl+,. Then confirm the segment with Ctrl+Enter.

The following segment (dialog box) contains the actual index mark text. Take a look at the
Document Structure Information column on the right-hand side. It shows IE+ for this
segment, which means Index Entry. Translate this segment and confirm it with Ctrl+Enter.
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6]

Proceed exactly the same with segments 6 and 7 as well as with 10 and 11. Finally, translate
and confirm the last segment (15).

For DTP files it is particularly important to run a tag verification on the document. Missing
tags can easily prevent you or the project manager from generating the target document in
its native file format. Run the tag verification through Tools -> Verify.

FOR MORE INFORMATION

How to Verify the Translation

NOTE

For detailed information on reporting and correcting tag errors please refer to the Getting Started
training workbook for SDL Trados Studio 2009.

Provided that Adobe FrameMaker is available on your system you can preview your
translation in the native application through File -> View In -> Adobe FrameMaker as Target.

Save the file with File -> Save, then close the file with File -> Close.

FOR MORE INFORMATION
Adobe FrameMaker File Type

Creating the Return Package

You can now deliver the translated files in a return package. Switch to the Projects view, right-click the
current project, and select Create Return Package from the context menu.

NOTE

An example of how to create and deliver return packages can be found in the Getting Started training
workbook for SDL Trados Studio 2009.

NOTE

The person who receives the return package (e.g. the project manager) will usually convert the files
back to their native format (i.e. Adobe FrameMaker and InDesign). However, you can also generate
the original file format from each SDLXLIFF file through File -> Save Target As. You can then view the
translation in the corresponding application provided you have Adobe FrameMaker and InDesign
installed.

FOR MORE INFORMATION

Overview: Create a Return Package

7-4 SDLTRADOS STUDIO 2009 INTERMEDIATE FOR TRANSLATORS
SDL plc Confidential. Copyright © 2009 SDL plc.


http://producthelp.sdl.com/SDL%20Trados%20Studio/client_en/Edit_View/Translating/Verify_the_Translation.htm
http://producthelp.sdl.com/SDL%20Trados%20Studio/client_en/File_Types/Adobe_Framemaker.htm
http://producthelp.sdl.com/SDL%20Trados%20Studio/client_en/Ref/A-G/CreateRePack/O_CRPack.htm

GENERATING AUTOSUGGEST
DICTIONARIES

This chapter provides an example of how to generate an
AutoSuggest dictionary.
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How to Generate an AutoSuggest Dictionary

8-2

AutoSuggest dictionaries allow for segment fragment matching. Using AutoSuggest dictionaries SDL
Trados Studio 2009 can intelligently suggest segment fragments that fit the current context while you are

typing.

[sihlen Sie die dnwendung
[sihlen Sie die Option S

[wahlen Sie die zu entfemende Anwendung
[Wahlen Sie Benutzerdefiniet
[wiahlen

AutoSuggest dictionaries are created from existing translation memories. The TM input files can be in one
of the following formats:

O sdltm
™M  *tmx (Translation Memory Exchange)
M  *tmx.gz (compressed TMX format)

To create an AutoSuggest dictionary from an existing TMX file, take the steps below:

E FREELANCE

AutoSuggest dictionaries can only be created with the Professional Edition of SDL Trados Studio
2009. With the Freelance Edition you can use AutoSuggest dictionaries during translation or editing,
but you cannot create them.

1. Select the menu command Tools -> Generate AutoSuggest Dictionary.

I_UE;E-E Help
Chedk Spelling... F7
Werify Fa

®  Generate AutoSuggest Dictionary. ..
!;. Upgrade TFRanslation Memories...
& Plug-ins...

Wieww Log File...
aw  Options, ..

Manage User Profiles...

2. This opens the New AutoSuggest Dictionary dialog box. Click the Browse button.

3. In the Open File-based Translation Memory dialog box, make sure that the file type TMX
Translation Memories (*.tmx;*.tmx.gz) is selected in the Files of Type dropdown list.

4. Browse for the sample TMX file from which the AutoSuggest dictionary is to be created, e.g.
C:\Documents and Settings\<User Name>\Desktop\Sample Files\o6 - Generating AutoSuggest
Dictionaries\Sample EN-GB_DE-DE.tmx.

NOTE

The sample file is an English-German TM in TMX format containing approx. 40,000 TUs.
5.  Click Next and wait for the TMX file to load.

6. On the next page make sure the correct source and target language pair (i.e. English - >
German) is selected. Then click Next.

7. On the page AutoSuggest Dictionary Creation Memory Usage the total number of units to
process is displayed. The sample TMX file contains approx. 40,000 units. You may decide to
reduce the number of units to process. Reducing the number of units to process may be
helpful when processing very large TMs, which could help you avoid out of memory issues.
However, for our sample input file this is not required, so you can just click Next to
continue.
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8.  On the following page click Browse and select the location in which the AutoSuggest
dictionary is to be created. Select a location that you can find easily, e.g. C:\Documents and
Settings\<User Name>\Desktop|Sample Files. Then click Finish.

9. Depending on the size of the TMX file, generation of the AutoSuggest dictionary will take
some time.

NOTE

The AutoSuggest dictionary can only be generated, if your input TM contains 25,000 translation units
or more. TMs with less units do not provide a basis for reliable segment fragment extraction.

10. When the generation process is complete, click Close. Open Windows Explorer to view the
newly-created AutoSuggest dictionary file, e.g. Sample EN-GB_DE-DE.bpm.

@ FOR MORE INFORMATION

™M  About AutoSuggest Dictionaries

M AutoSuggest Options

™M  New AutoSuggest Dictionary Wizard
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CUSTOMIZING KEYBOARD
SHORTCUTS

This chapter provides examples of how to customize keyboard
shortcuts in SDL Trados Studio 2009.
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How to Customize Keyboard Shortcuts

For maximum productivity all functions in SDL Trados Studio 2009 can be accessed through keyboard
shortcuts. The application allows you to define your preferred shortcuts.

Example: The default keyboard shortcut for the function Copy Source to Target (i.e. the button that copies
the source segment into the target cell) is Alt+Ins or Strg+Ins. Imagine that you use this function
frequently, but you are working with a notebook on which the Ins key is hard to reach, too small, or simply
does not exist at all.

To re-define the shortcut for this function, follow the steps below:

1.

6.

Select the menu command Tools -> Options.
In the Options dialog box click and expand Keyboard Shortcuts.

Keyboard shortcuts specific to a particular view are listed under the corresponding heading.
The Copy Source to Target functionality is available in the Editor view, i.e. you can find the
corresponding shortcut more easily if you click the Editor link.

Locate the Copy Source to Target action, and click inside the Shortcut column next to the
name of the action, where you will find the default shortcut, i.e. Alt+Ins, Strg+Ins.

Now press your new, preferred shortcut combination, i.e. Ctrl+Alt+l. This will replace the
default keyboard shortcut.

Options Q@
#- 5y, Editor Kepboard Shortcuts - Editor
& AuloSuggest This page allows youto change the keyboard shottcuts associsted with common commands
# [23 File Types
*- 55 Verlication In the shortcuts column for the command that you would like to change, press the kep
% [ Language Pais combination that you would like ta uss with the command. I the command is already in use:
@ Colors within the same scope, the row will turn red and you will need to enter a different keyboard
== Keyboard Shateuts shentiy
AllViews Action Sharteut &
Editor Clear Draft Segments Alt+Shift+Del
Editor > Quicklnsert Toaolbar Clear Selected Tag Formatting Chl+Space
Editar > Th 'Window Clear Tag Formatting Chl+&lt+Space
Files Clear Target Segment Al+Del
e Close CiieFd
Hepots Close Al CilsShiftsF4
- Translation Memories e naris
#- | Translation Memories View (SR o o £3
Concardance Search
Confirm and Move to Next Segment Cl+él+Enter
Confirm and Move to Nest Unconfimed...  Cti+Enter
Confirmation Statistics
Copy &l Source to Target Al+Shift+ ng
Copy Source to Tagst [trl+ilt+l
Delete &l Messages i ~
o) (o) ]
IR

Click OK to confirm and to close the Options dialog box.

Check whether your customized keyboard shortcut works. Open the sample.doc file located in your sample
files folder, e.g. C:\Documents and Settings\<User Name>\Desktop\Sample Files\oy - Customizing Keyboard
Shortcuts, and use the Copy Source to Target function with your customized keyboard shortcut.

@ FOR MORE INFORMATION

How to View and Edit Keyboard Shortcuts
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OPTIONAL TOPIC -
TRANSLATING PDF DOCUMENTS

This chapter provides an example of how to process PDF files
in SDL Trados Studio 2009.
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How to Translate PDF Documents

SDL Trados Studio 2009 allows you to open and translate PDF documents. Your sample files folder
contains a sample PDF document,

C:\Documents and Settings\<User Name>\Desktop\Sample Files\08 - PDF\Configuring_Spelling_Checker.pdf-

Note that this sample document is the PDF version of a Microsoft Word file that you translated in a previous
exercise. To translate this file take the following steps:

1. Open the PDF sample file by clicking Open Document on the Home screen.

2. In the Open Document dialog box make sure that the source language is set to English
(United States). It is recommended that you use the same target language as the one from 2
(i.e. the chapter on project creation), e.g. German (Germany).

3. Ifa TM is not yet selected, click Add -> File-based Translation Memory to select the Software
TM, which you used in chapter 2, C:\Documents and Settings\<User Name>\Desktop\Sample
Files\o1 - Project Creation\TMs\Software English-German.sdltm.

4. Click OK to close the Open Document dialog box.

5.  This is what the PDF document looks like in the Editor:

Canfiguing_Speling_ Checker pdf [Translation en5-de-DET"
ConfiguingSpeling. Cheoker.adfy ] Configuing_Speling_ Checkerpdf
, Configuring the Spelling Checker =M Die Rechtschreibpriifung
konfigurieren:
. To configure the spelling checker: /olEEM So konfigurieren Sie die
Rechtschreibpriifung:
31 { 1

Onthe Tools menu, click Options to display the § | Wahlen Sie im Menl Extras den Befehl
4 Options dialog box Optionen aus, um das Fenster
Optionen aufzurufen.
52 { 2
In the Qptions dialog box, click the Spelling & { | Klicken Sie im Dialogfeld Optionen auf
& Grammar tab den Reiter Rechtschreibung und
Grammatik
73

6. When you translate the document, you will get a number of context matches and high fuzzy
matches, as you already translated a Microsoft Word document with almost identical
content.

NOTE

For the Microsoft Word document you got more context and 100% matches than for the PDF version.
A number of segments that were 100% matches in the Word document are now reduced to high
fuzzy matches. This can be - among other things- due to the fact that numbers from numbered lists
have been extracted as normal text. This is not the case when you process the format the PDF was
created from, e.g. Microsoft Word, Adobe FrameMaker.

7.  Finish translating the text, then save the document as SDLXLIFF through File -> Save.
8.  Save the document as target through File -> Save Target As.

9. Inthe File name text field of the Save Target As dialog box, specify the name of the target file,
e.g. Configuring_Spelling_Checker_de.doc.

NOTE

When you open and translate a PDF document in SDL Trados Studio 2009, it is converted to
Microsoft Word format in the background. This is why when saving the file as target, the output
format is Microsoft Word (DOC), not PDF. You can, of course, convert the target file into PDF, for
example, using Adobe Acrobat. Usually, some DTP work is required before you convert the target file
into PDF. The extent of the DTP work depends on the quality and layout of the original PDF file.
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@ FOR MORE INFORMATION

™ PDEF File Type
(M  PDF Settings
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OPTIONAL TOPIC -
PLACEABLES AND AUTO-
SUBSTITUTION

This chapter provides examples of how numbers, dates and
times are automatically localized by SDL Trados Studio 2009.
You will learn the following:

M  How Auto-substitution works

™M  How to fine-tune Auto-substitution settings

Chapter



@ Optional Topic - Placeables and Auto-Substitution
[

What are Placeables and Auto-Substitution?

As you learned in the Getting Started training, placeables are elements within a source segment that are
not translated, but "placed’ into the target segment, for example:

numbers

dates

™

™

M  tags
(™ measurements
M  acronyms

Numbers are replaced automatically by the application. Example: suppose you have already translated the
segment You owe me 100 dollars. At a later stage you come across the segment You owe me 270 dollars. The
second segment is considered an exact match, and the number will be automatically replaced by SDL
Trados Studio 2009. However, sometimes it is not enough to just replace the number, because your target
language will often require a different format for numbers, dates, etc. This means that the number needs
to be localized accordingly. For example, while English uses a decimal point (e.g. 5.0), German uses a
decimal comma (e.g. 5,0). SDL Trados Studio 2009 automatically adapts the number or date format. This
process is called Auto-substitution.

Handling Placeables

The following exercise provides a number of examples of how Auto-substitution works:

Opening the Document and Configuring
1. Click the toolbar button Open Document.

2. In the Open Document dialog box browse for the path where the sample file is located, e.g.
C:\Documents and Settings\<User Name>\Desktop\Sample Files\o9 - Auto-substitution. The
sample file is called Placeables_sample.doc. Double-click the file to open it.

3. Make sure that English (United States) is selected in the Source Language dropdown list.
4. From the Target Language dropdown list select your preferred target language.

5. Remove any TMs selected from previous exercises. You can do this by highlighting the
TM(s) in the list and then by clicking Remove.

6. Create a new (empty) TM by clicking Create -> New File-based Translation Memory.

Open Document

Source Languags: =] English (United States] w | [auto-detected)
Target Language: | German (Gemmany] + | [optionall
Translation Memory and Automated Translation

Select translation memories and automated translation servers and specify whether to include them in look-up,
concordance seaich and whether to update them:

ogpadd - LaCreats -

Mame MNew Elle-based Translation Memary.., \‘r:kup Penalty | Concordance | Update

B §erver—haSJ&Trams\at\m Mernary...

Do ot show this dislog again i the languag pair setiings for the dacument ars known

ok | [ concel | [ Hel
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This opens the dialog box New Translation Memory. Enter the name of the TM into the
Name field, e.g. Placeables Sample English-German.

New Translation Memory

3

General

P
Specify name, location, source language and target language for this new translation memaory. R =
Create From:
Name: Flaceables S ample English-German
Description
Copyright:
Location: C:\Documents and SettingsilsertDesktopiSample Files\02 - P\aceah‘: v Browse..

Source Language: = English [United States]

TaigetLanguage: ™™ Geman (Germany)

Enable character-based concordance search

Meat > H Firfsh I [ Cancel ]

Click Finish.

When the TM creation is completed click Close.

Configuring the Auto-Substitution Settings

SDL Trados Studio 2009 automatically localizes placeables such as dates and numbers. You can fine-tune
the auto-substitution feature. Example: you have a preferred date format for the target language, e.g.
06.05.2009 or 2009-05-06.

To adjust the date format for auto-substitution take the following steps:

1.

2.

Click the Advanced button in the lower-left corner of the Open Document dialog box.

This opens the Project Template Settings - Default dialog box. In the tree structure on the
left-hand side select Language Pairs and then your language pair, e.g. English (United
States)-> German (Germany). From there drill down to Auto-substitution.

Then click Dates and Times.

On the right-hand side of the dialog box you see the default settings for short and long
date/time formats to be used in the target language. Example: the default short date format
for German is dd. MM.yyyy (e.g. 06.05.2009). Suppose you prefer a shorter date format, e.g.
6.5.09. In this case select d.M.yy from the Short date dropdown list.

Now click OK to confirm. During translation, SDL Trados Studio 2009 converts any short
date formats from the source document into the selected short date format for the target
language, i.e. d. M.yy.

In the Open Document dialog box click OK to open the document in the Editor.

FOR MORE INFORMATION

Translation Memory and Automated Translation > Auto-Substitution

Translation with Auto-Substitution

Now that the document has been opened, start by translating the first segment, i.e. the | will arrive on
06/04/2009. Note that the date in the source segment is highlighted with a blue underline. This
means that the date has been identified as a placeable. Start entering the translation, and stop just
before entering the date, e.g. Ich komme an am...
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2. Instead of typing the date manually, press Ctrl+,. This will open a QuickPlace list with the
suggested target date format (e.g. 6.5.09). Press Enter to insert the auto-substituted date into
your translation. Then press Ctrl+Enter to confirm.

NOTE

You learned this keyboard shortcut in a previous exercise when you were required to insert tags.
Dates and numbers can be inserted into your translation just like tags.

3.  The second segment has been recognized as a 100% match. The only difference between
segment 1 and 2 is the date, which has been automatically adjusted by SDL Trados Studio
2009. Press Ctrl+Enter to confirm.

1 [will armive on 06/04/2009. o Ich komme an am 4.6.09
2 | will arrive on 04/23/2008, & Ich komme an am 23 .4.09

4. Note that in the next segment (My book is 2.5 inches thick.) 2.5 inches is highlighted with a blue
underline, i.e. the measurement has also been recognized as a placeable. Proceed like
before, i.e. start translating the segment, and insert the placeable with Ctrl+, and then press
Enter. Note that the measurement will be automatically adjusted are required by your target
language (e.g. for German 2,5 instead of 2.5).

5.  When you press Ctrl+Enter to confirm, the next segment (My book is 4 inches thick.) will also
be identified as a 100% match, and 2.5 will be automatically replaced with 4.

6. The next segment contains a number of placeables: Today, the DAX was down 11.98 points (=
0.55%) to 4,312. When you press Ctrl+, the QuickPlace list will contain 4 entries. Using the
Up/Down keys on your keyboard you can move to the next or previous list item. Observe that
when you highlight an entry in the placeables QuickPlace list, the corresponding placeable

string in the source segment is highlighted.

Today, the DAX was down 11.98 points (= I Heute figl der|
0.55%)t0 4,312 DAx

11.98
0.55%
4312

7. Translate the segment into your target language and leverage the suggestions from the
placeables QuickPlace list. Note that the word DAX is considered a placeable as well, as it is

an acronym, i.e. a fully capitalized word. Also observe that the number formats are adjusted
automatically, e.g. the grouping character used in 4,312 is converted into 4.312 for German.

8. Translate the segment while leveraging the suggestions from the QuickPlace list and
confirm your translation with Ctrl+Enter.
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OPTIONAL TOPIC - AUTO-
PROPAGATION SETTINGS

This chapter provides examples of how you can fine-tune the
Auto-propagation feature. You will learn how to:

M  Make SDL Trados Studio 2009 prompt you before auto-
propagating a translation

™M  Set conditions for auto-propagating translations

Chapter
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What is Auto-propagation?

In the Getting Started training course you saw an example of how the Auto-propagate feature works. Auto-
propagation is very helpful for handling repeated segments in a source document. If you translate the first
occurrence of a repeated segment, your translation will be auto-propagated to all other occurrences. If you
decide to modify one occurrence of the segment, you can have all other occurrences adapted automatically.
That way you can make sure effectively that all occurrences of the same segment are translated
consistently, without having to rely on time-consuming find/replace operations.

However, sometimes it may be necessary to translate different occurrences of same source segment
within a document in different ways. This is why you can change the behavior of the Auto-propagate
feature through various options.

For this exercise, please open the following sample document in SDL Trados Studio 2009: C:|Documents
and Settings\<User Name>\Desktop\Sample Files\10 - Auto-propagate\auto-propagate_sample.doc.

NOTE

You can keep the TM from the previous exercise (Auto-localization) selected, or even use no TM at
all.

[0] FOR MORE INFORMATION

Overview: Auto-propagation

Auto-propagation with Default Settings
Let us have a look at how Auto-propagation works by default:

1. When the document has been opened, translate the first segment and confirm your translation with
Ctrl+Enter. (For example: Auto-propagate - Example 1 =
Auto-propagate - Beispiel 1).

2. After confirming the translation your target segment is propagated to segments 5 and 9. As
segments 5 and g only contain different numbers, these segments are regarded as
repetitions, and the numbers will be replaced automatically.

3. Translate segment 2, (e.g. This is a phrase. = Dies ist eine Phrase.) and confirm with Ctrl+Enter.
4. Again, your translation is auto-propagated, this time to segments 3 and 4.

5.  Godown to segment 4, which is the last occurrence of this segment, and change it (e.g. from
Dies ist eine Phrase. to Dies ist ein Satz.). After modifying the segment, confirm with
Ctrl+Enter.

6. Note that the previous segment (3) has been modified accordingly, but not segment 2. The
difference between segment 3 and 2 is the fact that you confirmed segment 2, while
segment 3 was unconfirmed.

By default, Auto-propagation behaves as follows:
M  When you translate and confirm a segment, your translation is propagated to other occurrences of
the same segment within the document.

M  When you change any occurrence of the segment, all repeated occurrences will be updated
accordingly.

(M By default, translations that have been propagated are marked as 100% matches, but remain
unconfirmed.

(M By default, Auto-propagation does not update confirmed segments when another occurrence of the
same segment is modified.
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Configuring Auto-propagation Settings

You can change the Auto-propagation behavior by taking the following steps:

10.

11.

Select the menu command Tools -> Options.
In the tree on the left-hand side select Editor -> Auto-propagation.

This will show the Auto-propagation options on the right-hand side of the dialog box. Under
General you can configure whether Auto-propagation should be enabled or not. By default,
this feature is enabled. Moreover, you can decide to auto-propagate to repetitions, even if
they are confirmed or to have auto-propagated translations confirmed automatically. Leave
the General options unchanged.

General
[Enable Auto-propagation
[ Auto-propagate to repetitions that are corfimed

[] Confitm repetitions that have besn auto-propagated

Have a look at the section Prompt User. Here, you can decide whether SDL Trados Studio
2009 should prompt you before auto-propagating translations to repetitions. The prompt is
not enabled by default, so click the radio button Always to enable the prompt.

Prampt User
After confiming a segment that has repetitions, the user will be prompted:

O Always
) Conditionally wher:

(@) Hlever - always auto-propagate translations witholt prampting User

Click OK to confirm the new setting.

Translate segment 6 (e.g. This is a short sentence. = Dies ist ein kurzer Satz.), and confirm with
Ctrl+Enter.

This time a message box opens and prompts you to confirm whether you want this
translation to be auto-propagated to segment 7. Click Yes to apply your translation to
segment 7.

Now you will be prompted to confirm whether the translation should be auto-propagated to
segment &. This time click No, which will close the prompt. Confirm segment 77 with
Ctrl+Enter.

Go to segment 8, which has remained untranslated, enter an alternative translation, (e.g.
Dies ist ein kleiner Satz.) and confirm with Ctrl+Enter.

Before you take on the remaining segments, make another change to the Auto-propagation
options: select the menu command Tools -> Options again and go to Editor -> Auto-
propagate.

This time, select the radio button Conditionally when and then check Repetition has been
translated differently.

Frompt User
Afiter confiming a segment that has repetitions, the user wil be prompted
O Ahways
© Condiionally when;
Fiepetition has been translated differently

[[] Repetition has na translation

() Never - sluaps auto-propagate hanslations without prompting ussr
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12. Confirm the settings change with OK, and translate segment 10 (e.g. Click here to open the
dialog box. -> Klicken Sie hier, um das Dialogfeld zu 6ffnen.).

13. Do not confirm segment 10 yet, but go down to segment 12 and translate this (identical)
segment differently, e.g. Hier klicken, um das Dialogfenster zu Gffnen. Then confirm with
Ctrl+Enter.

14. The translation from segment 12 will be auto-propagated to segment 11 (i.e. no prompt).
However, you will be prompted whether you want to auto-propagate the translation from
segment 12 to segment 10. The reason is that you have configured Auto-propagation to
prompt you when a repeated occurrence has a different translation. Click No to leave the
translation from segment 10 unchanged.

@ FOR MORE INFORMATION

™  Options Dialog Box: Editor > Auto-propagation

™  Repetitions Found
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ADVANCED TOPICS - OVERVIEW

This chapter provides a quick overview of the topics covered in
the training course SDL Trados Studio 2009 Advanced for
Translators.
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13



@ Advanced Topics - Overview
[

SDL Trados Studio 2009 Advanced for Translators - Overview

The Advanced training course covers the following topics:

™

W W

I I ™ I I I ™ B ™ ™

Filling translation memories through alignment of legacy documents
Translation memory maintenance, e.g. global search/replace operations in TMs
Running batch tasks on a TM

Filtering a TM, e.g. looking up all TUs related to the subject Hardware or all TUs that contain a
particular expression

Importing and exporting translation memories

Creating and using language resource templates

Editor options

Spelling check options

Using AutoText and AutoSuggest

Translating HTML files

Translating structured formats (XML)

Creating and configuring new file type definitions for custom XML documents

Terminology verification
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SDL is the leader in Global Information Management (GIM) solutions that
empower organizations to accelerate the delivery of high-quality multilingual
content to global markets. Its enterprise software and services integrate with
existing business systems to manage the delivery of global information from

authoring to publication and throughout the distributed
translation supply chain.

Global industry leaders rely on SDL to provide enterprise software or hosted
services for their GIM processes, including ABN-Amro, Best Western, Bosch,
Canon, Chrysler, CNH, Hewlett-Packard, Microsoft, Philips, SAP, Sony,
Sun Microsystems and Virgin Atlantic.

SDL has implemented more than 500 enterprise GIM solutions,
has deployed over 170,000 software licenses across the GIM ecosystem
and provides access to on-demand translation portals for 10 million
customers per month. Over 1,000 service professionals deliver consulting,
implementation and language services through its global
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