COCHLEAR IMPLANT SIMULATION

version 2.0

Copyright:
Ángel de la Torre Vega
Marta Bastarrica Martí
Rafael de la Torre Vega
Manuel Sainz Quevedo
Grenade (Espagne), Décembre 2004
Tous droits réservés.

Description et utilisation du programme :

1.- Conditions requises de hardware et software

2.- Installation du software

3.- Qu'est-ce que ``Cochlear Implant Simulation'' ?

4.- Perception du son à travers un implant cochléaire

5.- Comment s’utilise ``Cochlear Implant Simulation'' ?

6.- Comment a-t-on fait ``Cochlear Implant Simulation'' ?

7.- Qu'est-ce que n'est pas ``Cochlear Implant Simulation''

8.- Historique des versions

9.- Les auteurs


Cochlear Implant Simulation - ver 2.0 - Conditions requises

Conditions requises de hardware et software

Conditions minimales requises de hardware

  • Processeur : Compatible Pentium.
  • Mémoire vive : 16 MB de mémoire vive.
  • Espace dans le disque dur : 1 MB d'espace libre dans le disque dur.
  • Résolution de l'écran : 800 x 600 pixels.
  • Carte son : Carte son compatible avec Windows, nécessaire pour écouter les résultats des simulations et pour enregistrer de nouveaux signaux.

Hardware recommandé

  • Processeur : Pentium III ou supérieur.
  • Mémoire vive : 128 MB de mémoire vive.
  • Espace dans le disque dur : 5 MB d'espace libre dans le disque.
  • Résolution de l'écran : 1024 x 768 pixels.
  • Carte son : Carte son compatible avec Windows.
  • Microphone et casque

Conditions minimales requises du software

Pour exécuter ``Cochlear Implant Simulation'', on doit disposer d'un système d'exploitation Windows de 32 bits. En particulier, on peut l'exécuter sur les systèmes d'exploitation suivants :

  • Microsoft Windows 95
  • Microsoft Windows 98
  • Microsoft Windows NT
  • Microsoft Windows 2000
  • Microsoft Windows XP


Cochlear Implant Simulation - ver 2.0 - Installation

Installation du software

Le logiciel ``Cochlear Implant Simulation'' peut se télécharger de la page web http://www.ugr.es/~atv/web_ci_SIM/fr/ci_sim_fr.htm. Comme on verra plus tard, le programme ``Cochlear Implant Simulation'' n'a pas réellement besoin d'une installation. Il suffit de copier les fichiers d'application et d'aide dans un dossier local.

Pour cela, deux choix sont possibles :

  1. Télécharger et copier dans un dossier local les fichiers ci_sim.exe et ci_sim.chm.
  2. Télécharger dans un dossier local le fichier ci_sim.zip, et le décomprimer dans un dossier local.

Une fois les deux fichiers copiés, le programme peut être activé en double cliquant sur l'icône ci_sim.exe.


Cochlear Implant Simulation - ver 2.0 - Qu'est-ce que c'est ?

Qu'est-ce que ``Cochlear Implant Simulation'' ?

``Cochlear Implant Simulation'' est une application software qui permet de simuler comment un individu porteur d'un implant cochléaire perçoit le son. L'application permet :

  • La lecture d'un fichier audio en format ``wav'' ou bien l'enregistrement d'un signal audio à travers le microphone de l'ordinateur.
  • La configuration des paramètres avec lesquels se réalise la simulation. En modifiant ces paramètres, on peut représenter différentes situations par rapport à la perception du son par un individu porteur d'implant cochléaire.
  • L'obtention d'un nouveau signal audio, à partir du signal original (qui provient d'un fichier ``wav'' ou qui est acquis à travers du microphone) synthétisé en accord avec les paramètres de simulation établis. Ce nouveau signal représente comment serait perçu le son original par un individu implanté.
  • La reproduction et l'enregistrement du signal original et du/des signal/aux audio synthétisé/és.

L'application software peut être exécutée sur un ordinateur de type PC avec Windows comme système d'exploitation. L'application ``Cochlear Implant Simulation'' version 2.0 a été développée à l'Université de Grenade en Espagne, et terminée en décembre 2004.


Cochlear Implant Simulation - ver 2.0 - Perception du son avec un I.C.

Perception du son à travers un implant cochléaire

Qu'est-ce qu'un implant cochléaire ?

Un implant cochléaire est un système électronique qui s'utilise pour permettre l'audition à des individus qui sont atteints d'hypoacousies sévères ou profondes. Le système composé de deux éléments, un processeur externe et un élément interne qui est implanté sur le patient au cours d'une intervention chirurgicale. L'élément implanté comporte un faisceau d'électrodes qui est placé à l'intérieur de la cochlée, permettant la stimulation du nerf auditif par l'intermédiaire de stimulation électrique.

Le fonctionnement basique d'un implant cochléaire est le suivant : Le processeur dispose d'un microphone qui recueille le son. Le processeur analyse le son et détermine le niveau de stimulation qui doit se présenter au niveau de chaque électrode pour chaque instant. La configuration de la stimulation est transmise à la partie interne du système par onde radio et la partie interne génère les stimulations électriques qui sont présentées sur chacune des électrodes intra-cochléaires de l'implant. Les impulsions sur chaque électrode produisent l'activation des fibres nerveuses du nerf auditif. Cette activité est transmise jusqu'au cortex cérébral produisant une sensation d'audition chez l'individu implanté.

Actuellement, l'implant cochléaire constitue l'unique solution efficace dans la plupart des hypoacousies sévères et profondes pour lesquelles l'audiophone ne suffit pas. Ce traitement possède suffisamment d'expérience (il y a environ 50.000 patients implantés dans le monde) et son efficacité est certaine. Ainsi, le pourcentage de patients implantés capables de suivre des conversations téléphoniques grâce à l'implant cochléaire est considérable (c'est-à-dire des patients capables de comprendre la voix à partir de l'audition que fournit l'implant, sans aucune aide visuelle et avec un niveau modéré de bruit).

Comment un patient porteur d'implant cochléaire perçoit le son ?

Connaître avec précision comment est perçu le son à travers un implant cochléaire est extrêmement difficile, de part la grande quantité de facteurs impliqués :

  • Facteurs technologiques : caractéristiques techniques du système de l'implant cochléaire (taux de stimulation, disposition et nombre d'électrodes de l'implant, mode de stimulation), traitement du signal réalisé depuis l'enregistrement du son jusqu'à la génération des stimulus, stratégie de codification, mode de stimulation, etc.
  • Facteurs chirurgicaux : emplacement du faisceau portant les électrodes, profondeur d'insertion du faisceau, etc.
  • Facteurs physiologiques : taux de survie neuronale, période réfractaire, rang dynamique de stimulation électrique, résolution en intensité, etc., et la variation de ces paramètres pour chaque position cochléaire.
  • Autres facteurs : adaptation de la programmation et du processeur au patient, durée de l'hypoacousie, moment d'acquisition de l'hypoacousie par rapport au développement auditif et linguistique, expérience auditive précédent l'hypoacousie, évolution de l'hypoacousie, traitement de l'hypoacousie précédent l'implant, capacité et disposition par rapport à l'apprentissage et à l'entraînement auditif, etc.

On sait que tous ces facteurs affectent d'une certaine manière la façon de percevoir le son chez l'individu porteur d'implant, mais il est difficile d'évaluer comment influence chacun par rapport aux autres ou lequel va influencer majoritairement la qualité avec laquelle sera perçu le son. Pour connaître comment un individu porteur d'implant cochléaire perçoit le son, on dispose de différentes possibilités :

  • Témoignage de patients : L'information fournie par les patients sur la qualité du son perçu est d'un grand intérêt pour comprendre comment l'implant affecte la qualité de l'audition. Cette information a l'inconvénient d'être très subjective et d'être influencée par l'expérience auditive du patient, préalable et ultérieure à l'implantation.
  • Observation indirecte : A travers des tests conçus pour évaluer des aspects déterminés de la qualité de l'audition des patients implantés, on peut obtenir des informations supplémentaires spécifiques.
  • Analyse des transformations du signal audio : En appliquant des techniques de traitement du signal, on peut simuler les transformations que subit le signal audio de son acquisition jusqu'à l'activation des terminaisons nerveuses, représentant ainsi la perte de l'information liée au processus d'analyse (due au traitement, l'implant et la stratégie de codage) et à l'interaction entre les électrodes et les terminaisons nerveuses.

Objectif du projet ``Cochlear Implant Simulation''

L'objectif du projet ``Cochlear Implant Simulation'' a été d'associer l'expérience retenue à travers les témoignages des patients et l'observation de leurs capacités avec l'étude du fonctionnement de leurs systèmes d'implants cochléaires et de la physiologie de l'audition pour développer un système qui simule la perception du son à travers l'implant cochléaire. Le système de simulation prétend vérifier les caractéristiques suivantes :

  • Représenter les principaux facteurs qui déterminent la qualité avec laquelle le son est perçu par l'intermédiaire de l'implant cochléaire.
  • Permettre la réalisation des simulations sur des fichiers audio, pour permettre aux individus normo-entendent d'apprécier comment serait perçu le son pour un individu porteur d'implant.
  • Développer une plate-forme de simulation générique qui permet de réaliser des simulations en accord avec les caractéristiques des différents modèles d'implants cochléaires disponibles sur le marché, et également avec les caractéristiques des systèmes fictifs non existants sur le marché.
  • Développer le système de simulation dans un environnement facile d'utilisation ayant pour objectif de permettre son utilisation aux différents acteurs intervenant dans le traitement des hypoacousies avec des implants cochléaires (familiaux du patient, professeurs, orthophonistes, rééducateurs, psychologues, programmeurs, spécialistes ORL, etc.).


Cochlear Implant Simulation - ver 2.0 - Comment s'utilise-t-il ?

Comment s’utilise « Cochlear Implant Simulation » ?

Utilisation de l’application

Le programme « Cochlear Implant Simulation » comprends essentiellement quatre tâches : (1) Préparation du signal audio à traiter ; (2) Configuration des paramètres de simulation ; (3) Synthèse du signal traité ; (4) stockage du résultat. Il est décrit à la suite comment se réalise chacune des fonctions.

Préparer le signal à traiter

Le signal audio d’entrée (le signal que recueille le microphone du système d’implant cochléaire) se prépare soit en ouvrant un fichier audio, en format « wav », soit en l’enregistrant par le microphone de l’ordinateur.

Pour lire un fichier « wav » on peut cliquer sur l’icône « Ouvrir » de l’application. Il peut aussi se faire en sélectionnant « Ouvrir » sur le menu « Fichier » ou bien en appuyant sur la combinaison des touches « Ctrl + O ». Dans tous les cas, il apparaît une fenêtre de dialogue qui permet de naviguer à travers du système de fichiers et d’identifier les fichiers audio avec extension « wav ». Une fois le fichier à traiter identifié, il est lu par le programme soit en double-cliquant, soit en le sélectionnant et en cliquant sur le bouton « Ouvrir ». Une fois lu, le fichier sélectionné apparaîtra dans la liste « WAVs Non Traités ».

Pour enregistrer un signal audio, il suffit de cliquer sur le bouton d’enregistrement (bouton rouge de la partie inférieure de la fenêtre du programme). L’enregistrement peut s’arrêter en appuyant sur le bouton gris de la partie inférieure de la fenêtre. Le programme enregistrera à partir de l’entrée du microphone de l’ordinateur ou de l’entrée sélectionnée dans le « Contrôle d’enregistrement » de Windows (pour accéder, double-cliquer sur le haut-parleur de la barre des tâches et sélectionner « Enregistrement » dans le panneau « Propriétés » du menu « Options »). Le programme attribuera un nom de fichier au signal enregistré. Le fichier correspondant au signal enregistré apparaîtra dans la liste « WAVs Non Traités ».

En appuyant sur le bouton vert de la partie inférieure de la fenêtre, le fichier sélectionné se reproduit (soit enregistré par le microphone, soit lu depuis le système de fichiers). On l’écoutera à la sortie audio de l’ordinateur (haut-parleurs ou écouteurs).

Configurer les paramètres de simulation

La configuration des paramètres de simulation se réalise à travers de la « fenêtre de configuration » qui s’active en cliquant sur l’icône « Configurer ». Elle s’active aussi soit en sélectionnant « Configurer les Paramètres » dans le menu « Options », soit en appuyant sur la combinaison des touches « Ctrl + P ».

Dans la « fenêtre de configuration » on peut modifier les différents paramètres intervenant dans la simulation. Les paramètres dont la configuration demande une valeur numérique (taux, fMin, fMax, etc.) peuvent s’établir en déplaçant la barre correspondante ou bien en introduisant une valeur numérique dans la fenêtre correspondante. Les paramètres qui demandent une option binaire (Détection de l’Enveloppe, Synchronisation, etc.) sont sélectionnés en marquant l’option correspondante. Plus tard, on décrira ce que signifie chacun des paramètres de configuration.

Le logiciel permet aussi la lecture et l’écriture des fichiers de configuration. Ces fichiers ont l’extension « *.par ». Pour lire ou écrire ces fichiers on doit cliquer respectivement sur « Lire les Paramètres » ou « Enregistrer les Paramètres », dans le menu « Options ».

Réaliser la simulation

Pour synthétiser le signal audio comme il sera perçu au travers de l’implant cochléaire en accord avec la configuration établie, on doit sélectionner le fichier original et ensuite cliquer sur le bouton « Commencer la Simulation » situé sur la partie inférieure de la fenêtre. Pendant un certain temps (qui dépend de la vitesse de l’ordinateur utilisé) le signal sera traité, temps après lequel un nouveau fichier apparaîtra dans la liste « WAVs Traités ».

Les fichiers audio résultants de la simulation sont associés aux paramètres utilisés pour la simulation. Ces paramètres peuvent être montrés en cliquant sur l’icône « + » qui figure à coté de chaque fichier.

Une fois la simulation terminée, on peut sélectionner le fichier et en cliquant sur le bouton de reproduction (bouton vert dans la partie inférieure), on peut écouter le résultat de la simulation (le signal synthétisé) par la sortie audio de l’ordinateur.

Stocker les résultats

Le signal synthétisé a un nom de fichier qui est attribué automatiquement à partir du nom du fichier audio original. Ce signal peut être sauvegarder comme fichier « wav » soit en cliquant sur l’icône « Sauvegarder », soit en selectionant l’option « Sauvegarder » ou « Sauvegarder Sous » dans le menu « Fichier ». Les actions « Sauvegarder » et « Sauvegarder Sous » sont aussi activées respectivement par la combinaison de touches « Ctrl + S » et « Ctrl + Shift + S ».

Si on veut qu’un des fichiers audio disparaisse de la liste « WAVs Traités » ou « WAVs Non Traités », on devra sélectionner le fichier et ensuite cliquer sur l’icône « Fermer » ou bien sur l’option « Fermer » du menu « Fichier ». S’il n’a pas été sauvegardé au préalable, un message d’avertissement apparaît pour que le signal synthétisé ne se perde pas accidentellement.

Autres caractéristiques du programme

L’aide s’active soit en cliquant sur le bouton « Aide », soit en sélectionnant « Contenu » dans le menu « Aide », soit en appuyant sur la touche « F1 ».

Pour quitter l’application on peut appuyer sur la combinaison « Ctrl + Q » ou sélectionner « Quitter » dans le menu « Fichier ».

Fonctionnement des différentes options

  • Boutons :
    • Ouvrir : Il montre une fenêtre pour la sélection et la lecture des fichiers « wav » depuis le système de fichiers.
    • Sauvegarder : Il garde le fichier « wav » sélectionné dans le système de fichiers.
    • Fermer : Il ferme le fichier « wav » sélectionné, en montrant un avertissement au cas où il ne serait pas sauvegardé.
    • Configurer : Il montre une fenêtre de configuration des paramètres de simulation.
    • Aide : Il montre la fenêtre d’aide.
    • Bouton vert (Reproduire) : Il reproduit le fichier « wav » sélectionné (soit non traité, soit traité) permettant qu’il soit écouté par la sortie audio de l’ordinateur.
    • Bouton gris (Arrêter) : Il arrête l’enregistrement.
    • Bouton rouge (Enregistrer) : Il commence l’enregistrement par le microphone.
    • Commencer la Simulation : Il synthétise comment le signal audio serait perçu à travers l’implant cochléaire en accord avec la configuration établie, en utilisant comme signal audio original celui sélectionné.
  • Menu Fichier :
    • Ouvrir : Cette option montre une fenêtre pour sélectionner et lire un fichier « wav » depuis le système de fichiers.
    • Sauvegarder : Cette option sauvegarde dans le disque le fichier « wav » sélectionné.
    • Sauvegarder Sous : Cette option sauvegarde dans le disque le fichier « wav » sélectionné en sélectionnant le nom et le dossier où il sera sauvegardé. Une fenêtre de dialogue est ouverte pour sauvegarder le fichier.
    • Fermer : Cette option ferme le fichier « wav » sélectionné. Le programme demande une confirmation s’il n’est pas sauvegardé.
    • Quitter : Cette option ferme l’application.
  • Menu Options :
    • Configuration des Paramètres : Cette option ouvre la fenêtre de configuration des paramètres de simulation.
    • Lire les Paramètres : Cette option permet de lire un fichier de configuration des paramètres de simulation.
    • Sauvegarder les Paramètres : Cette option permet de sauvegarder les paramètres de simulation dans un fichier.
  • Menu Aide :
    • Contenu : Cette option ouvre la fenêtre d’aide.
    • A Propos : Cette option montre des informations sur la réalisation du logiciel « Cochlear Implant Simulation ».

Configuration des paramètres de simulation

Les paramètres de simulation vont modeler différentes situations par rapport à la façon dont le patient implanté perçoit le son. Les paramètres qui peuvent être modifiés sont les suivants :

  • fStimulation : Fréquence de stimulation pour chaque électrode, exprimé en nombre d’impulsions par seconde (pps soit pulses per second en anglais).
  • fMin : limite inférieure du rang spectral traité par le système d’implant cochléaire, exprimé en Hz.
  • fMax : limite supérieure du rang spectral traité par le système d’implant cochléaire, exprimé en Hz.
  • longueur-ic : Longueur du faisceau d’électrodes de l’implant cochléaire en mm.
  • n-canaux-ic : Nombre de canaux de l’implant cochléaire.
  • n-insérés-ic : Nombre de canaux qui ont été insérés dans la cochlée au cours de l’intervention chirurgicale.
  • n-of-m : Nombre d’électrodes qui sont activées dans chaque cycle de traitement parmi les m canaux allumés.
  • interaction : Coefficient d’interaction entre les canaux, en mm.
  • fréquence de coupure : Dans le cas de Stimulation Electro-Acoustique (EAS), c’est la fréquence de coupure qui détermine le rang de fréquences traité par l’audiophone et par l’implant cochléaire.
  • Détection de l’Enveloppe : Procédé utilisé pour la détection de l’enveloppe du signal dans la stratégie du codage. On peut sélectionner Hilbert+FIR (banque de filtres à réponse impulsionnelle finie et détection de l’enveloppe basée sur la transformée de Hilbert) ou Rect-LP+IIR (banque de filtres à réponse impulsionnelle infinie et détection de l’enveloppe basée sur un redresseur et un filtre passe-bas).
  • Synchronisation : Ce paramètre modèle la capacité de synchronisation de l’activité nerveuse produite par l’impulsion présentée.
  • Stimulation Electro-Acoustique : Celle-ci permet de simuler l’audition d’un patient chez qui on combine la stimulation électrique de l’implant cochléaire avec la stimulation acoustique de l’audiophone.
  • Déplacement de Fréquences : Si on active cette option, la synthèse est réalisée en tenant compte de la fréquence correspondante à la position de chaque électrode de l’implant, en accord avec la théorie tonotopique.

fStimulation

Ce paramètre représente la fréquence de stimulation pour chaque canal de l’implant cochléaire, c’est-à-dire le nombre d’impulsions par seconde qui sont présentées dans chaque électrode de l’implant. Pendant le réglage du processeur, il est recommandé de fixer ce paramètre à une valeur supérieure à 1000 pps (impulsions par seconde), puisque le temps de repolarisation des terminaisons nerveuses est de l’ordre de 2 ms et que des valeurs de fréquence de stimulation inférieures à 800 pps produiraient une synchronisation (indésirable) de l’activité neuronale avec les impulsions, au lieu de la synchronisation (désirable) de l’activité neuronale avec le signal audio. La valeur attribuée à ce paramètre influence fortement la résolution temporelle avec laquelle le signal audio est perçu, ainsi que la qualité du signal perçue de façon importante, en particulier pour ces patients avec une bonne capacité de synchronisation. Dans le programme « Cochlear Implant Simulation », ce paramètre peut se changer entre 10 y 10000 impulsions par seconde.

fMin et fMax

Ces sont les limites inférieure et supérieure du rang spectral traité par le système d’implant cochléaire, exprimées en Hz. fMin et fMax sont utilisées pour construire la banque de filtres. Dans la simulation (de la même façon que dans un système d’implant cochléaire), les composants de fréquences inférieures à fMin ou supérieures à fMax ne sont pas traitées. Tenant compte du rang spectral de la voix, il est recommandé que fMin soit inférieure à 350 Hz et fMax supérieure à 4000 Hz. Dans le programme « Cochlear Implant Simulation » fMin peut prendre des valeurs entre 20 Hz et 5000 Hz, pendant que fMax peut être entre 500 et 10000 Hz, à condition que fMin soit inférieur à fMax.

longueur-ic et n-canaux-ic

Ces deux paramètres caractérisent la géométrie de l’implant cochléaire. La longueur de l’implant cochléaire, exprimée en mm, plus le nombre de canaux de l’implant cochléaire, sont utilisés pour déterminer la distance entre des électrodes consécutives et la position de chaque électrode le long de la cochlée. De cette façon, on peut modeler l’effet d’interaction entre les canaux (qui va dépendre de la dispersion du champ de courant autour de chaque électrode et de la distance entre des électrodes consécutives). Ces paramètres permettent aussi de modeler le déplacement de fréquences, associé à la stimulation avec un implant cochléaire, qui va dépendre de la différence entre la fréquence centrale du filtre associé à chaque électrode et la fréquence associée tonotopiquement à la position de l’électrode.

Dans le programme « Cochlear Implant Simulation », la longueur de l’implant cochléaire peut prendre des valeurs entre 1 mm et 30 mm, alors que le nombre de canaux de l’implant cochléaire peut changer entre 1 et 50.

n-insérées-ic

Ce paramètre représente le nombre des électrodes insérées pendant l’opération chirurgicale. On suppose que l’implant cochléaire va être correctement réglé et que ce paramètre sera le nombre des canaux actifs de l’implant cochléaire. De cette façon, dans la pratique, ce paramètre est utilisé pour définir le nombre de bandes de fréquence dans lesquelles on va diviser le rang spectral défini par fMin et fMax. Le nombre de bandes de fréquence va conditionner, d’abord, la résolution spectrale tonotopique, de façon à ce que plus grand il soit, meilleure soit la qualité dont le son est perçu. Cependant, la résolution spectrale tonotopique est aussi fortement affectée par l’interaction entre les canaux, dû au fait que le courant inséré par les électrodes ne soit pas interné et qu’il se disperse dans une région relativement étendue. De cette façon, pour un grand nombre de bandes, la résolution spectrale tonotopique sera plus limitée par l’interaction entre les canaux que par le nombre des bandes.

Le nombre des électrodes insérées dans l’implant cochléaire est aussi utilisé pour déterminer la position de chacune des électrodes le long de la cochlée, ainsi que la fréquence caractéristique du point où se trouve chacune des électrodes, dans le but de modeler l’effet de déplacement de fréquences. Le nombre des électrodes insérées doit être mineur ou égal au nombre de canaux de l’implant cochléaire.

n-of-m

Ce paramètre est le nombre de canaux qui sont activés dans chaque cycle de stimulation par les stratégies de codage n-of-m. Quand le processeur utilise une stratégie de type CIS, ce paramètre doit être égal au nombre d’électrodes insérées (la valeur maximum qui permet le programme).

Lorsqu’on utilise une stratégie n-of-m, dans chaque cycle de stimulation (en accord avec la fréquence de stimulation établie par le paramètre fStimulation), on compare l’énergie des différents canaux et uniquement les n canaux avec le plus d’énergie sont sélectionnés pour la stimulation alors que le reste des canaux ne sont pas utilisés (l’énergie des canaux non utilisés se fixe à une valeur nulle). Lorsque n est égal à m (stratégie CIS) tous les canaux sont sélectionnés dans chaque cycle de stimulation.

Plus n est petit par rapport à m, plus la qualité du signal synthétisé est mauvaise, du fait que l’information soit supprimée (en annulant les canaux d’énergie inférieure). Les stratégies n-of-m sont utilisées pour permettre que la fréquence de stimulation ne soit pas excessivement réduite chez les implants ayant un grand nombre d’électrodes.

interaction

Ce paramètre est utilisé pour modeler l’interaction entre les canaux. L’interaction entre les canaux est modelée comme un transfert d’énergie d’un canal déterminé dans le bloc d’analyse vers les canaux adjacents dans le bloc de synthèse. Pour une électrode déterminée, « k », une partie du courant généré au cours de la stimulation va stimuler les terminaisons nerveuses proches à cette électrode, mais il y aura aussi une stimulation des terminaisons nerveuses proches aux électrodes « k+1 », « k-1 », « k+2 », « k-2 », etc. Dans la pratique, ceci réduit la résolution spectrale tonotopique. Plus les électrodes sont proches entre elles, plus l’interaction entre les canaux est importante. De cette façon, l’interaction (ou le transfert de courant) est plus grande entre l’électrode « k » et l’électrode « k+1 » que entre l’électrode « k » et celle « k+2 ».

Dans ce programme, on suppose que l’interaction est fonction de la distance entre les électrodes et qu’elle suit une fonction exponentielle caractérisée par un coefficient d’interaction. De cette façon, la contribution de l’électrode « A » aux terminaisons nerveuses associées à l’électrode « B » est calculée de la manière suivante :

Intensité(A)*exp(-Distance(A-B)/Coefficient.Interaction)

L’intensité observée sur les terminaisons nerveuses associées au niveau de l’électrode « B » sera l’addition des contributions de toutes les électrodes adjacentes. Lorsque la distance entre les électrodes est faible par rapport au coefficient d’interaction, il y a une forte interaction entre les différents canaux, ce qui rend difficile la discrimination entre le stimulus provenant de deux électrodes adjacentes (et qui limite la résolution spectrale tonotopique). Dans certaines études, on a estimé qu’une valeur raisonnable du coefficient d’interaction serait environ 2 ou 3 mm.

Fréquence de coupure

Ce paramètre est mis en application seulement si on a sélectionné la Stimulation Electro-Acoustique (EAS soit Electric-Acoustic Stimulation en anglais). La Stimulation Electro-Acoustique consiste en l’association d’un audiophone et d’un implant cochléaire. La fréquence de coupure détermine le rang de fréquences qui est traité par l’audiophone (des fréquences inférieures à la fréquence de coupure) et le rang spectral traité par l’implant (depuis la fréquence de coupure jusqu’à fMax). Dans ce cas, la banque de filtres pour l’implant cochléaire est conçue en utilisant ce rang spectral. Ce paramètre peut prendre des valeurs entre 20 Hz et 5000 Hz.

Détection de l’Enveloppe

Dans la plupart des systèmes d’implant cochléaire, la banque de filtres utilise des filtres à réponse impulsionnelle infinie (IIR) et la détection de l’enveloppe est réalisée par un redressement et un filtrage passe-bas à la sortie de chaque filtre de la banque. Pour simuler cette situation, on doit sélectionner Rect-LP+IIR. D’autres systèmes d’implant cochléaire utilisent pour chaque canal un couple de filtres à réponse impulsionnelle finie (FIR) (ce qu’évite la distorsion de phase des filtres IIR) et obtiennent l’enveloppe grâce à la transformée de Hilbert (ce qui fournit une meilleure représentation de l’évolution temporelle de l’enveloppe). Pour simuler ce cas, on doit sélectionner Hilbert+FIR.

Synchronisation

Ce paramètre sert à modeler la capacité de synchronisation de l’activité nerveuse avec le stimulus présenté. Il peut prendre des valeurs entre 0.0 et 1.0, 0.0 correspondant à une mauvaise capacité de synchronisation et 1.0 à une bonne capacité de synchronisation. En choisissant « bonne synchronisation », on représente une situation où la lésion du nerf auditif n’est pas excessive et où il est possible pour le patient d’obtenir l’information temporelle à partir de la configuration de stimulation. En choisissant « mauvaise synchronisation », on représente une situation où la lésion du nerf auditif est plus importante, ce qui provoque la perte de la plupart de l’information temporelle. Les deux situations sont modelées par le processus de synthèse en utilisant comme signal d’excitation pour la synthèse un bruit blanc gaussien (cas de mauvaise synchronisation) ou bien une séquence de pulses situés sur chaque maximum local de l’enveloppe pour chaque canal (cas de bonne synchronisation). Dans cette dernière situation, on représente le fait que la plupart des décharges se produisent quand l’énergie atteint un maximum dans le signal audio. Les deux signaux d’excitation sont combinés en fonction du paramètre de synchronisation en représentant des situations intermédiaires entre une « mauvaise synchronisation » et une « bonne synchronisation ».

Stimulation Electro-Acoustique

La Stimulation Electro-Acoustique (EAS) combine la stimulation électrique (par l’implant cochléaire) avec la stimulation acoustique (par l’audiophone). Cette technique est utile chez les patients qui conservent des restes auditifs dans les fréquences graves. Lorsqu’on sélectionne ce paramètre dans la simulation, on sépare le rang spectral correspondant à la partie de stimulation acoustique (jusqu'à la fréquence de coupure) et la partie de stimulation électrique (depuis la fréquence de coupure jusqu’à fMax). Le signal synthétisé dans ce cas est l’addition du signal de la partie correspondante à la stimulation acoustique et du signal qui résulte de la simulation du fonctionnement de l’implant cochléaire dans le rang spectral défini entre la fréquence de coupure et fMax.

Déplacement de Fréquences

En activant cette option, le programme utilise pour la synthèse une banque de filtres de fréquences différentes à celles utilisées par le processeur. Les fréquences utilisées pour la synthèse sont déterminées en accord avec la théorie tonotopique, en tenant compte de la position de chaque électrode le long de la cochlée.


Cochlear Implant Simulation - ver 2.0 - ¿Cómo se ha hecho?

Comment a-t-on fait « Cochlear Implant Simulation » ?

Le programme « Cochlear Implant Simulation » a été développé en partant d’un modèle qui représente les principales étapes du processus par lequel un patient muni d’un implant cochléaire perçoit le son. Dans ce modèle on considère des aspects techniques ainsi que physiologiques qui conditionnent la perception du son. Le processus est partagé en deux blocs principaux : un bloc d’analyse et un bloc de synthèse.

Modèle d’analyse-synthèse

Le bloc d’analyse représente le processus que suit le signal audio depuis son acquisition par le microphone jusqu’à sa transformation en impulsions électriques, fournies par les différentes électrodes de l’implant, et qui donnent lieu aux potentiels d’action sur le nerf auditif.

La première partie du bloc considère exclusivement le traitement du signal fait par le système d’implant cochléaire, et permet de représenter la perte d’information associée à la configuration de l’implant et la stratégie de codage. La deuxième partie du bloc d’analyse représente l’interaction entre le faisceau d’électrodes et les terminaisons nerveuses et décrit comment la configuration de l’activité des électrodes de l’implant est transformée en configuration d’activité sur le nerf auditif.

Le bloc de synthèse fournit un signal audio à partir de la configuration de l’activité du nerf auditif obtenue dans le bloc d’analyse. Le signal audio est synthétisé à partir de la configuration de l’activité de chaque bande de fréquence (associée à chaque région de la cochlée). De cette façon, l’information perdue au cours du processus d’analyse donne lieu à une perte de qualité dans le signal synthétisé. La figure 1 représente le diagramme des blocs considéré pour la simulation.

Figure 1: Diagramme des blocs du programme ``Cochlear Implant Simulation".

Ce modèle permet de considérer les principaux aspects qui influent sur la perception fournie par l’implant tels que la stratégie de codage, la conception de la banque de filtres, la fréquence de stimulation, le nombre de canaux, les dimensions de l’implant cochléaire, l’emplacement du faisceau d’électrodes, l’interaction entre les électrodes de l’implant et les terminaisons nerveuses, etc. Les signaux synthétisés compte tenu de ce modèle représente la perte d’information propre de la stimulation par l’implant et permettent, de cette façon, aux individus normo-entendents d’écouter le son tel qu’il serait perçu par un patient porteur d’implant cochléaire.

Comment a-t-on représenté chaque effet

Traitement du signal dans l’implant

La figure 2 montre le diagramme de blocs d’un système d’implant cochléaire conventionnel. Le signal est acquis par le microphone du processeur, puis amplifié et passé par une banque de filtres qui le sépare en différentes bandes de fréquence. La sortie de chaque filtre passe par un détecteur d’enveloppe. De cette façon, pour chaque canal, on estime l’énergie du signal sur chaque bande de fréquence et à chaque instant. Le bloc d’adaptation de rang dynamique sert à transformer le rang dynamique acoustique de chaque canal, en rang dynamique électrique exigé par chaque électrode du patient. Cette transformation du rang dynamique est spécifique au patient et différente pour chacune des électrodes. Finalement, selon la fréquence de stimulation, le processeur génère des impulsions de stimulation qui représentent le niveau de courant qu’on doit fournir sur chaque électrode à chaque instant. Dans les stratégies de codage pulsées (comme les stratégies CIS ou n-of-m), les impulsions de stimulation sont générées de façon à ce que, à chaque instant, il y ait uniquement une électrode active dans le but d’éviter le phénomène nommé « l’addition de champs ». Une fois la configuration de stimulation établie dans le processeur, celle-ci est alors transmise à l’implant cochléaire puis les impulsions de courant sont générées par les électrodes de l’implant.

Figure 2: Diagramme de blocs d'un système d'implant cochléaire.

Le programme « Cochlear Implant Simulation » traite le son en reproduisant l’analyse du signal réalisée par le processeur de l’implant cochléaire, en accord avec l’ensemble des paramètres de simulation établis. Cette analyse fournit la configuration d’activité sur les électrodes de l’implant cochléaire qui serait obtenue à la présentation du signal audio au microphone.

A partir de la configuration d’activité sur les électrodes, et en accord avec le modèle d’interaction entre les électrodes et les terminaisons nerveuses, on détermine la configuration de l’activité neurale des groupes de terminaisons nerveuses associés à chaque portion cochléaire. Finalement, on synthétise le signal audio en partant de cette configuration d’activité neuronale, tout en tenant compte de la capacité de synchronisation de l’activité neuronale et des fréquences caractéristiques des portions cochléaires stimulées.

La fréquence de stimulation

La fréquence de stimulation représente le nombre d’impulsions par seconde qui sont présentés sur chacune des électrodes de l’implant cochléaire. Ce paramètre limite la résolution temporelle de l’implant cochléaire, c’est-à-dire, la capacité de percevoir des changements rapides des caractéristiques du signal audio. Plus la fréquence de stimulation est petite, plus la qualité du son perçu est mauvaise.

La résolution temporelle avec laquelle le patient perçoit le son est limitée, non seulement par la fréquence de stimulation, mais par la période réfractaire des neurones du nerf auditif. Le temps nécessaire pour la repolarisation des neurones après une décharge est d’environ 2 ms. C’est pour cela qu’il est préférable de régler la fréquence de stimulation au-dessus de 1000 impulsions par seconde.

Dans le programme « Cochlear Implant Simulation », la fréquence de stimulation est représentée en sous-échantillonnant les enveloppes à la fréquence de stimulation. Il faut tenir compte de l’existence de stratégies de stimulation où l’on utilise une fréquence d’actualisation de l’enveloppe inférieure à la fréquence de stimulation. Dans ce cas, la valeur assignée au paramètre « fréquence de stimulation » correspond à la fréquence (taux) d’actualisation de l’enveloppe, puisque ce paramètre représente la perte de résolution temporelle.

Il faut prendre en compte que, pour des fréquences de stimulation excessivement basses (en dessous de 800 ou 700 pps), en plus de la perte de résolution temporelle, se produit un effet de synchronisation de l’activité neuronale avec les impulsions de stimulation, ce qui réduit encore plus la qualité de perception chez le patient implanté. Cet effet n’a pas été modelé dans le programme « Cochlear Implant Simulation » ainsi, dans le cas de fréquences de stimulation très basses, la qualité du signal perçu dans la situation réelle est plus mauvaise que celle fournie par la simulation.

La banque de filtres d’analyse

La banque de filtres utilisée pour l’analyse est composée de filtres équidistants sur une échelle logarithmique de fréquence dans le rang défini par fMin et fMax. Les bandes passantes des filtres sont égales sur l’échelle logarithmique de fréquence, de façon à ce que les bandes correspondantes à des fréquences plus basses soient plus étroites et que celles correspondantes à des fréquences plus hautes soient plus larges.

Chaque canal de l’implant cochléaire possède un filtre passe-bande. Le nombre de canaux est déterminé par le paramètre « n-insérés-ic ». Plus le nombre de canaux est grand, plus la résolution spectrale tonotopique est grande. Dans le cas où l’option « Hilber+FIR » est sélectionné, les filtres sont conçus comme des filtres à réponse impulsionnelle finie (FIR) à 100 coefficients. Dans le cas où l’option « Rect-LP+IIR » est sélectionné, on utilise des filtres à réponse impulsionnelle infinie (IIR) de type Butterworth de 6e ordre. Les filtres FIR ont l’inconvénient d’avoir besoin d’une plus grande quantité de calculs. D’autre part, les filtres IIR ont les inconvénients de causer une distorsion de phase et de pouvoir donner une réponse instable, particulièrement dans le cas de petites bandes passantes.

Détection de l’enveloppe

La détection de l’enveloppe est réalisée grâce à un redressement et un filtrage passe-bande (option « Rect-LP+IIR ») ou bien grâce à la transformée de Hilbert (option « Hilbert+FIR »). Cette dernière option fournit une enveloppe qui représente de façon optimale l’évolution temporelle de l’énergie dans la bande de fréquence du filtre, mais elle a l’inconvénient de demander l’utilisation de deux filtres FIR en quadrature de phase, avec l’augmentation du nombre de calculs correspondants.

Stratégies CIS et n-of-m

Le paramètre « n-of-m » permet de sélectionner des stratégies CIS (lorsque n est égal à m, c’est-à-dire, au nombre de canaux insérés) ou des stratégies n-of-m (lorsque n est inférieur à m).

Les stratégies n-of-m fonctionnent en activant, dans chaque cycle de traitement, uniquement les n canaux qui présentent le plus d’énergie parmi les m disponibles. Le but des stratégies n-of-m est de permettre un accroissement de la fréquence de stimulation grâce à la réduction du nombre de canaux activés dans chaque cycle, ce qui réduit la durée totale du cycle de traitement. Cet accroissement de la fréquence de stimulation est fait au dépend d’une réduction de la qualité, puisque l’information correspondante aux canaux non sélectionnés est perdue.

Pour simuler l’effet des stratégies n-of-m, dans chaque cycle de traitement, on compare les enveloppes correspondantes aux différents canaux puis on sélectionne les n les plus énergétiques et on annule les enveloppes du reste des canaux. De cette façon, l’information correspondante aux canaux non sélectionnés est éliminée du signal synthétisé.

Interaction entre les canaux

L’interaction entre les canaux est modelée par l’interface électrodes – terminaisons nerveuses. Dans des travaux préalables, on a estimé la distribution de densité de courant dans un système électrique semblable à la cochlée stimulée par un implant cochléaire. On a trouvé que le courant émis sur une électrode se disperse sur une surface relativement étendue, que ce soit dans le cas de stimulation monopolaire comme de stimulation bipolaire.

Quand on stimule sur une électrode, il serait souhaitable que seulement les fibres nerveuses les plus proches de l’électrode soient activées. Cependant, les pulses présentés sur une électrode activent ces fibres mais aussi d’autres plus éloignées. De façon analogue, un groupe de fibres va être activé principalement par l’électrode la plus proche, mais il va aussi s’activer lorsqu’il y aura des stimulus sur des électrodes plus éloignées. Ce phénomène peut être modelé grâce à une matrice de mélange entre les canaux de l’implant et les « canaux du nerf auditif », en définissant chacun de ces canaux comme le groupe de neurones voisins à une électrode. De cette façon, les différents canaux de l’implant contribuent à chaque « canal du nerf auditif », et la contribution dépend de la distance qui sépare chaque électrode de la partie cochléaire considérée. Dans ce modèle, on a supposé que la contribution diminue de façon exponentielle avec la distance, et on définit le coefficient d’interaction comme la constante de cette baisse exponentielle. Les études sur la distribution du champ de courant dans la cochlée suggèrent qu’une valeur appropriée pour cette constante est d’environ 2 ou 3 mm.

Pour déterminer la matrice de mélange qui donne lieu à l’interaction entre les canaux, on tient compte de la d entre les différentes électrodes de l’implant. Pour cela, on considère les dimensions de l’implant et le nombre d’électrodes qu’il possède. Plus les électrodes sont proches entre elles ou bien plus le coefficient d’interaction est grand, plus l’interaction entre les canaux est grande, ce qui a pour conséquence une perte de résolution spectrale tonotopique. Dans ce cas, la résolution spectrale fournie par l’implant ne va pas être limitée par le nombre d’électrodes mais par l’interaction entre les canaux. On peut apprécier que, pour des petites valeurs du coefficient d’interaction, la qualité du signal synthétisé augmente suivant le nombre d’électrodes considérées dans la simulation. Cependant, pour de plus grandes valeurs du coefficient d’interaction, la résolution spectrale ne s’améliore plus si la distance entre les électrodes adjacentes est inférieure au coefficient d’interaction.

Synthèse du signal

Le bloc de synthèse du signal correspond au diagramme montré sur la figure 3. La synthèse part de la configuration d’activité après avoir modelé l’interaction entre les canaux. L’enveloppe de chaque canal représente l’énergie qu’il y a pour chacune des bandes de fréquence et à chaque instant. C’est pour cela que l’on utilise un signal d’excitation (d’abord, avec une distribution d’énergie uniforme sur la fréquence et sur le temps) pour synthétiser le signal audio. Cette excitation est filtrée avec une banque de filtres puis le signal filtré est multiplié par l’enveloppe. Après ces opérations, la sortie de chaque canal est un signal limité dans la bande définie par le canal dont l’énergie évolue dans le temps suivant l’enveloppe considérée. Finalement, on additionne les contributions provenant des différents canaux en obtenant un signal audio qui comprend les contributions dans tout le rang spectral traité.

Figure 3: Diagramme du bloc de synthèse du signal du programme ``Cochlear Implant Simulation".

Le signal d’excitation considéré peut être un bruit blanc gaussien puisque cette excitation présente un spectre plat et une distribution d’énergie uniforme dans le temps. Cependant, les signaux synthétisés en utilisant un bruit blanc présentent une très mauvaise qualité due au fait que la phase du signal synthétisé soit aléatoire, car l’excitation utilisée pour chaque canal est aussi aléatoire. Le résultat est un signal audio qui perd la structure temporelle et, en particulier, il perd le ton fondamental qui ne peut pas être résolu dans le domaine temporel. Plusieurs expériences ont mis en évidence que la plupart des patients perçoivent avec une meilleure qualité par rapport à celle obtenue en synthétisant de cette façon. Pour cela, on propose une méthode alternative de synthèse. Celle-ci consiste à utiliser comme signal d’excitation un ensemble de pulses. Les pulses sont situés dans les instants où l’enveloppe a un maximum local. Un pulse isolé ou un ensemble de pulses ont un spectre plat. Pour éviter que l’énergie du signal synthétisé soit conditionnée par les pulses (elle doit dépendre des enveloppes mais non des excitations du bloc de synthèse) le signal d’excitation est normalisé pour qu’il ait une distribution d’énergie la plus uniforme possible dans le temps. Dans cette méthode de synthèse, l’excitation présentée pour chaque bande est indépendante du reste des bandes et elle est calculée à partir des maximums locaux des enveloppes considérées dans la bande correspondante.

L’utilisation d’une excitation de type bruit blanc gaussien représente comment perçoit un patient implanté qui n’a pas une bonne résolution temporelle à cause d’une lésion du nerf auditif. Cette situation fait que l’activité neurale ne soit pas synchronisée avec le stimulus auditif et que le ton fondamental ne reste pas représenté dans la configuration de l’activité neurale. Cette façon de percevoir le son se présente chez les patients avec pertes auditives plus prolongées ou lorsque le taux de survie neuronale est plus bas, c’est-à-dire, quand les lésions cochléaires sont plus étendues.

L’utilisation d’une excitation de type train de pulses représente comment on perçoit le son chez un patient implanté avec une bonne capacité de synchronisation de l’activité neurale. Dans ce cas, la configuration d’activité du nerf auditif peut suivre l’évolution de l’enveloppe, produisant la plupart des décharges aux instants où l’enveloppe a un maximum d’énergie. De cette façon, le ton fondamental peut être perçu à partir de la configuration temporelle de l’activité du nerf auditif.

Dans un cas réel, il est à prévoir que le patient aura une perception avec une qualité intermédiaire entre les deux situations, plus proche de la situation de « mauvaise synchronisation » quand les lésions cochléaires sont plus importantes, et plus proche à une « bonne synchronisation » quand le nerf auditif se trouve dans un meilleur état. Afin de modeler cet effet, le logiciel « Cochlear Implant Simulation » calcule les deux signaux d’excitation (bruit blanc gaussien et train de pulses) et les combine en fonction du paramètre de synchronisation.

La banque de filtres de synthèse

La banque de filtres utilisée pour la synthèse est constituée de filtres passe-bande de type FIR, dans le but de ne pas introduire de distorsions de phase inutiles dans le traitement de synthèse. Si l’option « Déplacement de Fréquences » n’est pas sélectionnée, les fréquences centrales et les fréquences de coupure des filtres concordent avec celles de la banque de filtres utilisés pour le bloc d’analyse. Si cette option est sélectionnée, les fréquences et les bandes passantes des filtres de synthèse sont déterminées en tenant compte de la position de chaque électrode et la fréquence caractéristique correspondantes à cette position selon la théorie tonotopique. Pour cela, on tient compte aussi bien des dimensions du faisceau d’électrodes que du nombre d’électrodes et de la profondeur d’insertion du faisceau.

Stimulation Electro-Acoustique

Pour simuler la perception dans le cas de Stimulation Electro-Acoustique (EAS ou Electro-Acoustic Stimulation en anglais) on sépare le spectre en une partie basse (correspondant à la stimulation acoustique) et une partie haute (correspondant à la stimulation électrique). Pour séparer les deux parties, on tient compte du paramètre « fréquence de coupure ». La partie de stimulation acoustique est obtenue en filtrant passe-bas le signal original avec un filtre conçu avec cette fréquence de coupure. La partie de stimulation électrique est obtenue en traitant le signal en accord avec la configuration de l’implant cochléaire et en utilisant comme rang de fréquences celui déterminé par la fréquence de coupure et par fMax. Le signal synthétisé est obtenu en additionnant la partie de stimulation acoustique et la partie de stimulation électrique.

Validation du procédé

Pour valider la méthode de simulation mise en œuvre dans le programme « Cochlear Implant Simulation », on a effectué des tests en présentant des phrases à plusieurs patients porteurs d’implant cochléaire. Dans ces tests, on a présenté différentes phrases, synthétisées mais aussi originales. On demandait au patient d’évaluer la qualité dont les phrases synthétisées et originales étaient perçues.

Pour réaliser la validation, l’hypothèse de départ est que la simulation comme le système d’implant cochléaire donnent lieu à une perte de qualité de l’audition. Dans les tests, le patient implanté va percevoir une phrase traitée par le programme de simulation puis celle-ci traitée par le propre système d’implant cochléaire dont il est porteur (dans le cas de phrases synthétisées), ou bien une phrase uniquement traitée par le système d’implant cochléaire (dans le cas de la phrase originale).

Quand la simulation est réalisée avec une configuration qui fournit une qualité meilleure que les paramètres du système d’implant cochléaire, la qualité de la phrase synthétisée ne va pas être conditionnée par les paramètres de simulation. Dans ce cas, en accord avec l’hypothèse de départ, le patient devrait indiquer que la qualité de la phrase synthétisée est semblable à celle de la phrase originale. Quand on réalise la simulation avec une configuration qui fournit une qualité plus mauvaise que les paramètres du système d’implant cochléaire, la qualité de la phrase synthétisée sera conditionnée par les paramètres de simulation. Dans ce cas, le patient devrait indiquer que la phrase synthétisée a une plus mauvaise qualité que l’originale.

De cette façon, on fixe tous les paramètres de simulation aux valeurs détenues par le le système d’implant cochléaire du patient, sauf un parmi eux, que l’on fait varier depuis une bonne valeur (laquelle fournit une meilleure qualité) à une autre plus mauvaise (laquelle fournit une qualité pire) et puis on représente graphiquement la qualité par rapport à ce paramètre : la qualité tend à être bonne (semblable pour la phrase originale et synthétisée) et vers les mauvaises valeurs présente une chute (la phrase synthétisée est perçue clairement plus mauvaise que la phrase originale). Cette courbe devrait présenter un coude juste au moment où la valeur du paramètre de simulation concorde avec la valeur du paramètre de son système d’implant cochléaire. Si cet effet est vérifié, on peut conclure que la simulation modèle de façon adéquate l’effet de ce paramètre sur la qualité de l’audition.

Méthode de validation

On a réalisé plusieurs tests de validation sur 7 patients porteurs d’implant cochléaire. Tous ont été implantés au service d’ORL de l’Hôpital La Paz de Madrid avec un dispositif Combi40+ fabriqué par MED-EL. Les tests de validation ont été centrés sur 3 paramètres de simulation : la fréquence de stimulation, le nombre de canaux et le coefficient d’interaction entre les canaux. Pour chacun d’entre eux, on a synthétisé des phrases avec différentes valeurs du paramètre à étudier et on a présenté au patient aussi bien les phrases originales que celles synthétisées, et on lui a demandé d’évaluer la qualité dont il perçoit chacune des phrases dans une échelle entre 0 (très mauvaise qualité) et 10 (qualité optimale).

Pour l’analyse de résultats, la note indiquant la qualité des phrases a été normalisée en la divisant par la note attribuée à la phrase originale correspondante. De cette façon, si une phrase synthétisée a une note de 1, on doit interpréter que le patient la perçoit avec la même qualité que la phrase originale. Pour chaque paramètre étudié, on a représenté la note normalisée par rapport au paramètre considéré. On a réalisé un ajustement polynomial (de 3e ordre) sur un critère d’erreur quadratique minimale sur ces données, obtenant ainsi la fonction qui s’ajuste le mieux aux données et les intervalles de confiance de 95 % correspondants.

Résultats

Dans la figure 4, on montre les valeurs des notes de qualité normalisée par rapport à la fréquence de stimulation considérée dans la simulation. On montre aussi l’ajustement de ces données. Chaque point du graphique représente l’évaluation par un patient d’une phrase synthétisée. On montre l’ajustement polynomial sur un critère de minimum d’erreur quadratique et l’intervalle de confiance de 95 % correspondant. On peut observer que, pour de très hautes fréquences de stimulation, les patients n’aperçoivent pas de perte de qualité dans les phrases synthétisées et, à mesure que la fréquence est plus petite, la qualité diminue, obtenant ainsi de très basses notes pour des fréquences au-dessous de 700 pps. On observe l’effet de coude dans le graphique correspondant à chaque patient. En plus, on s’aperçoit que la fréquence où se trouve le coude est différente pour chaque patient, celle-ci étant plus grande lorsque la fréquence utilisée par le processeur est plus grande. Ce résultat valide le procédé de simulation par rapport à la fréquence de stimulation.

Figure 4: Ajustement de la note de qualité normalisée par rapport à la fréquence de stimulation.

Pour vérifier l’influence de la fréquence de stimulation de la simulation par rapport à celle programmée dans le processeur du patient, on a réalisé un ajustement, en utilisant comme variable indépendante la fréquence de stimulation utilisée pour la simulation et la fréquence utilisée dans le processeur. Les résultats de cet ajustement sont montrés dans la figure 5. Dans ce cas, on aperçoit que le coude est placé autour d’une valeur de fréquence de stimulation normalisée proche à l’unité, c’est-à-dire, quand la fréquence de stimulation de la simulation se rapproche de celle programmée dans l’implant du patient.

Figure 5: Ajustement de la note de qualité normalisée par rapport à la fréquence de stimulation normalisée.

La figure 6 montre l’ajustement entre la note de qualité normalisée et le nombre de canaux utilisés dans la simulation. Les patients disposaient d’ajustements du processeur avec un nombre d’électrodes actives situé entre 9 électrodes et 12 électrodes (2 patients avec 9 électrodes actives, 1 avec 10 électrodes, 1 avec 11 électrodes et 3 avec 12 électrodes).

Dans ces courbes graphiques, on observe l’effet de coude où la qualité ressemble à celle de la phrase originale pour un grand nombre de canaux pour la simulation, et on observe une dégradation rapide quand le nombre de canaux utilisé pour la simulation est inférieur à 8. Il est intéressant que le coude ne soit pas autour du nombre de canaux qu’utilise le patient mais vers 8 canaux. Ceci met en évidence que la résolution spectrale tonotopique que ces patients jouissent n’est pas conditionnée par le nombre d’électrodes mais par un autre phénomène. La résolution spectrale tonotopique dont ils perçoivent le son est celle équivalente à environ 8 canaux, malgré le fait de disposer d’un plus grand nombre de canaux actifs dans leurs implants respectifs. La cause probable de cette limitation de la résolution spectrale tonotopique est l’interaction entre les canaux.

Figure 6: Ajustement de la note de qualité normalisée par rapport au nombre de canaux.

Pour évaluer l’effet d’interaction entre les canaux, on a réalisé des tests en modifiant dans la simulation le coefficient d’interaction entre les canaux. Les résultats sont montrés dans la figure 7. On observe que, quand on synthétise le signal avec un petit coefficient d’interaction, la qualité de la phrase synthétisée est semblable à celle de la phrase originale mais, à mesure que ce coefficient d’interaction augmente, la qualité se dégrade de façon importante. Le coude dans ces courbes est placé vers 1 ou 2 mm, ce qu’on peut interpréter comme suit : l’interaction entre les électrodes et les terminaisons nerveuses peut être modelée par le coefficient d’interaction entre les canaux en donnant à ce coefficient une valeur proche à 1 ou 2 mm. Cette valeur est consistante avec les observations et les études théoriques préalables concernant la distribution de la densité de courant dans le système électrique implant cochléaire – cochlée.

Figure 7: Ajustement de la note de qualité normalisée par rapport au coefficient d'interaction.

Remerciements

Les auteurs remercient l’équipe d’ORL de l’Hôpital La Paz de Madrid de la collaboration rendue et remercient aussi les patients qui ont participé aux tests de validation de leur participation.


Cochlear Implant Simulation - ver 2.0 - ¿Qué no es?

Qu’est-ce que n’est pas « Cochlear Implant Simulation » ?

L’objectif du programme « Cochlear Implant Simulation » est de simuler la perception de l’audition à travers un implant cochléaire. Cette simulation est basée sur un ensemble de réflexions et de modèles. On peut affirmer que les signaux synthétisés par ce programme représentent de façon adéquate la perception à travers l’implant cochléaire dans la mesure où les modèles représentent de façon adéquate la réalité et que les paramètres sélectionnés s’adaptent à ceux de la situation qu’on prétend simuler. Les résultats de la validation confirment l’adéquation des signaux synthétisés comme une approximation de la perception par l’implant cochléaire. Cependant, il est impossible d’établir de façon définitive et manifeste qu’un signal audio représente exactement la perception à travers l’implant cochléaire. Dans ce sens, on doit considérer les résultats de la simulation avec une certaine prudence.

Les aspects non considérés dans la simulation et qui peuvent influencer la perception font que les signaux synthétisés ne représentent pas de façon précise la perception par l’implant. Parmi les aspects non modelés dans le programme développé, on peut énumérer les suivants :

  • La programmation du processeur. Dans la simulation, on a supposé que le processeur est parfaitement réglé aux besoins du patient implanté, c’est-à-dire qu’il n’y a pas de perte d’information à cause d’un réglage incorrect du processeur.
  • La résolution en intensité. Dans la simulation, on ne modèle pas la résolution en intensité limitée des fibres nerveuses. La perte de qualité associée à une résolution en intensité limitée n’est pas représentée, ce qui est spécialement important chez un patient avec un taux de survie neuronale bas.
  • Variation des paramètres physiologiques le long de la cochlée. Un modèle adéquat et précis de l’interaction électrode – nerf auditif devrait considérer que le coefficient d’interaction peut être différent pour différentes portions cochléaires. Il devrait aussi tenir compte de la période réfractaire des neurones, du taux de survie neuronale et de la résolution en intensité des neurones ainsi que de la variation de ces paramètres le long de la cochlée.
  • Modelage des cochlées non normales, c’est-à-dire, les cas de cochlées ossifiées et de malformations cochléaires. Dans la simulation, on a supposé que l’implant est placé dans une cochlée perméable et que les électrodes sont situées de façon à ce que la première électrode du faisceau (la plus éloignée de l’implant) soit placée dans la portion la plus apicale de la cochlée, et la dernière dans la portion la plus basale, ce qui permet de déterminer la fréquence caractéristique correspondante à la position où est placée chaque électrode selon la théorie tonotopique. Le placement des électrodes dans les cas de cochlées ossifiées (quand la trajectoire de l’implant ne suit pas la rampe tympanique ou quand on utilise un modèle d’implant cochléaire avec un faisceau d’électrodes bifurqué) ou dans le cas de malformations cochléaires (comme cavités communes) est difficile de modeler, et on ne l’a pas considéré dans le programme développé.

Un autre aspect important à prendre en compte est que, pour la simulation, on a déterminé quelle serait la configuration d’activité pour synthétiser le signal audio. Cependant, on n’a ni modelé comment cette activité se propage le long des voies auditives ni quel est le traitement du signal qui a lieu sur les potentiels d’action en passant par le tronc cérébral. Modeler cet aspect peut être très compliqué, dû aux connaissances limitées du rôle du tronc cérébral dans l’audition. Dans le cas de patients possédant une expérience auditive, on peut supposer que le traitement du signal dans le tronc est « normal » (semblable à celui des individus normo-entendant), mais dans le cas d’absence d’expérience auditive, le manque de maturité des voies auditives donne lieu à une perte d’information non considérée dans le programme de simulation. Le développement des aptitudes auditives par le patient implanté (ou le traitement du signal ou de l’information au niveau cortical) n’est pas non plus facile à modeler (il n’a pas été modelé) et il influe aussi sur la façon de percevoir le son à travers l’implant cochléaire.

Tous ces aspects doivent être pris en compte quand on affirme que, en quelque sorte, les signaux synthétisés représentent la perception du son à travers l’implant cochléaire. Il est prévu d’inclure certains des effets et des facteurs décrits préalablement dans de futures versions du programme « Cochlear Implant Simulation ».


Cochlear Implant Simulation - ver 2.0 - Historique des versions

Historique des versions

Version 2.0

  • Améliorations
    • Le paramètre de Synchronisation à été modifié de façon à admettre maintenant des valeurs continues entre 0.0 (qui correspond à une mauvaise synchronisation) et 1.0 (qui correspond à une bonne synchronisation).
    • Le format du fichier de paramètres a été modifié pour supporter l'amélioration précédente. Les anciens fichiers de paramètres peuvent être ouverts avec la version 2.0 (compatibilité ascendante).
    • La documentation du programme a été révisée et actualisée.
  • Corrections
    • On a corrigé un bug dans la conversion interne de la fréquence d'échantillonnage des fichiers audio. Dans certaines conditions, ce bug pouvait produire un déplacement de fréquences anormal dans le signal synthétisé.
    • On a corrigé un bug dans la gestion de la mémoire. Dans la nouvelle version, le programme utilise la mémoire de façon optimale.

Version 1.0

Première version publiée du programme ``Cochlear Implant Simulation'', terminée le 21 juin 2004.


Cochlear Implant Simulation - ver 2.0 - Los autores

Les auteurs

Le logiciel « Cochlear Implant Simulation » version 2.0 a été développé par une équipe pluridisciplinaire composée par :

  • Ángel de la Torre Vega : Departamento de Electrónica y Tecnología de Computadores de l’Université de Grenade, Espagne.
  • Marta Bastarrica Martí : Departamento de Electrónica y Tecnología de Computadores de l’Université de Grenade, Espagne.
  • Rafael de la Torre Vega : Escuela Técnica Superior de Ingeniería Informática de l’Université de Grenade, Espagne.
  • Manuel Sainz Quevedo : Departamento de Cirugía y sus Especialidades de l’Université de Grenade, Espagne. Chef du Service ORL de l’Hospital Universitario S. Cecilio de Grenade, Espagne.

Pour le développement de l’interface graphique, on a utilisé la librairie wxWidgets version 2.4.2 (http://www.wxwidgets.org). Pour programmer la lecture et l’écriture de fichiers wav, on a utilisé les fichier wave.cpp, wave.h, rifffile.cpp et rifffile.cpp dont le copyright appartient à Timothy J. Weber (http://www.lightlink.com/tjweber).

La version 2.0 a été terminé en décembre 2004 à l’Université de Grenade, Espagne.

Copyright :
Ángel de la Torre Vega
Marta Bastarrica Martí
Rafael de la Torre Vega
Manuel Sainz Quevedo
Grenade (Espagne), Décembre 2004
Tous droits réservés

Les auteurs permettent la distribution, copie et utilisation non commerciale de ce programme. Lorsqu'on distribue ou copie le programme, il faudra inclure aussi bien le fichier exécutable que le fichier d'aide. Il est interdit de modifier le programme, le fichier d'aide ou sa documentation, la distribution de versions modifiées et faire usage d'ingénierie inverse sur le logiciel, sans autorisation formelle de(s) l'auteur(s) des droits.

Les auteurs distribuent ce programme sans aucun type de garantie tant que la distribution est gratuite. Les auteurs ne se responsabilisent d’aucun dommage, direct ou indirect, résultant de son utilisation.