COCHLEAR IMPLANT SIMULATION

versión 2.0

Copyright:
Ángel de la Torre Vega
Marta Bastarrica Martí
Rafael de la Torre Vega
Manuel Sainz Quevedo
Granada, Diciembre de 2004
Todos los derechos reservados.

Descripción y utilización del programa:

1.- Requisitos mínimos de hardware y de software

2.- Instalación del software

3.- ¿Qué es “Cochlear Implant Simulation”?

4.- Percepción del sonido a través de un implante coclear

5.- ¿Cómo se usa “Cochlear Implant Simulation”?

6.- ¿Cómo se ha hecho “Cochlear Implant Simulation”?

7.- ¿Qué no es “Cochlear Implant Simulation”?

8.- Historial de versiones

9.- Los autores


Requisitos de hardware y de software

Requisitos mínimos de hardware

  • Procesador: Compatible Pentium.
  • Memoria RAM: 16 MB de RAM.
  • Espacio en disco: 1 MB de espacio libre en disco.
  • Resolución de pantalla: 800 x 600 pixels.
  • Tarjeta de sonido: Tarjeta de sonido compatible con Windows, necesaria para escuchar los resultados de las simulaciones y para grabar nuevas señales.

Hardware recomendado

  • Procesador: Pentium III o superior.
  • Memoria RAM: 128 MB de RAM.
  • Espacio en disco: 5 MB de espacio libre en disco.
  • Resolución de pantalla: 1024 x 768 pixels.
  • Tarjeta de sonido: Tarjeta de sonido compatible con Windows.
  • Micrófono y auriculares

Requisitos mínimos de software

Para ejecutar "Cochlear Implant Simulation" se debe disponer de un sistema operativo Windows de 32 bits. En particular se puede ejecutar sobre los siguientes sistemas operativos:

  • Microsoft Windows 95
  • Microsoft Windows 98
  • Microsoft Windows NT
  • Microsoft Windows 2000
  • Microsoft Windows XP


Instalación del software

El software "Cochlear Implant Simulation" se puede descargar de la página web http://www.ugr.es/~atv/web_ci_SIM/es/ci_sim.htm. Como se verá a continuación, el programa "Cochlear Implant Simulation" realmente no requiere instalación. Basta con copiar los archivos ejecutable y de ayuda en una carpeta local.

Para ello, hay dos posibles opciones:

  1. Descargar y copiar en una carpeta local los ficheros ci_sim.exe y ci_sim.chm
  2. Descargar en una carpeta local el fichero ci_sim.zip, y descomprimirlo en una carpeta local.

Una vez copiado el archivo ejecutable, el programa puede ser activado haciendo doble click sobre el icono ci_sim.exe.


Pagina nueva 1

¿Qué es ``Cochlear Implant Simulation''?

``Cochlear Implant Simulation'' es una aplicación software que permite simular cómo percibe el sonido un sujeto que ha recibido un implante coclear. La aplicación permite:

  • La lectura de un fichero de audio en formato ``wav'' o bien la grabación de una señal de audio a través del micrófono del ordenador.
  • La configuración de los parámetros con que se realiza la simulación. Modificando estos parámetros se pueden modelar diferentes situaciones con respecto a la percepción del sonido por un sujeto portador de implante coclear.
  • La obtención de una nueva señal de audio, a partir de la señal original (procedente de un fichero ``wav'' o adquirida a través del micrófono) sintetizada de acuerdo con los parámetros de simulación establecidos. Esta nueva señal representa cómo sería percibido el sonido original por el sujeto implantado.
  • La reproducción y almacenamiento de la señal original y la/s señal/es de audio sintetizada/s.

La aplicación software puede ser ejecutada en un ordenador de tipo PC con sistema operativo Windows. La aplicación ``Cochlear Implant Simulation'' versión 2.0 se ha desarrollado en la Universidad de Granada, habiendo finalizado el desarrollo de esta versión en Diciembre de 2004.


Percepción del sonido a través de un implante coclear

¿Qué es un implante coclear?

Un implante coclear es un sistema electrónico que se utiliza para permitir la audición en sujetos que sufren hipoacusias severas o profundas. El sistema consta de dos elementos, un procesador externo y un elemento interno que es implantado en el paciente mediante una intervención quirúrgica. El elemento implantado tiene una guía de electrodos que es alojada en el interior de la cóclea, haciendo posible la estimulación del nervio auditivo mediante estímulos eléctricos.

El funcionamiento básico del implante coclear es el siguiente: El procesador dispone de un micrófono que recoge el sonido. El procesador analiza el sonido determinando el nivel de estimulación que debe presentarse en cada electrodo para cada instante de tiempo. El patrón de estimulación es transmitido a la parte interna del sistema mediante una transmisión radio y la parte interna genera los estímulos eléctricos que son presentados en cada uno de los electrodos intracocleares del implante. Los pulsos en cada electrodo producen la activación de las fibras nerviosas del nervio auditivo, y dicha actividad es transmitida hasta la corteza cerebral, proporcionando al sujeto implantado una sensación de audición.

En la actualidad, el implante coclear constituye la única solución eficaz en la mayor parte de las hipoacusias severas y profundas en las que el audífono resulta insuficiente. Este tratamiento cuenta con suficiente experiencia (hay alrededor de 50.000 pacientes implantados en todo el mundo) y su eficacia está fuera de toda duda. Así, es considerable el porcentaje de pacientes implantados capaces de mantener conversaciones telefónicas gracias al implante coclear (es decir, capaces de comprender la voz a partir de la audición que proporciona el implante, sin ningún apoyo visual y con niveles moderados de ruido).

¿Cómo oye el sonido un paciente con un implante coclear?

Conocer con precisión cómo se percibe el sonido a través del implante coclear es extremadamente complicado, debido a la gran cantidad de factores involucrados:

  • Factores tecnológicos: características técnicas del sistema de implante coclear (tasa de estimulación, disposición y número de electrodos del implante, modo de estimulación), procesamiento de señal realizado desde la adquisición hasta la generación de estímulos, estrategia de codificación, etc.
  • Factores quirúrgicos: colocación de la guía porta-electrodos, profundidad de inserción de la guía, etc.
  • Factores fisiológicos: índice de supervivencia neuronal, periodo refractario, rango dinámico de estimulación eléctrica, resolución en intensidad, etc., y variación de estos parámetros para cada porción coclear.
  • Otros factores: adecuada programación y adaptación del procesador al paciente, duración de la hipoacusia, momento de instauración de la hipoacusia en relación con el desarrollo auditivo y lingüístico, experiencia auditiva previa a la hipoacusia, evolución de la hipoacusia, tratamiento de la hipoacusia previa al implante, capacidad y disposición con respecto al aprendizaje y al entrenamiento auditivo, etc.

Se sabe que todos estos factores afectan de alguna manera en el modo de percibir el sonido en un sujeto implantado, pero resulta difícil valorar cómo influye cada uno en relación al resto o cuál va a condicionar en mayor medida la calidad con que es percibido el sonido. Para conocer cómo percibe el sonido un sujeto portador de implante coclear disponemos de distintas posibilidades:

  • Testimonio de pacientes. La información que proporcionan los pacientes con respecto a la calidad con que perciben el sonido es de gran interés para entender cómo afecta el implante a la calidad de la audición. Esta información tiene el inconveniente de ser muy subjetiva y de verse afectada por la experiencia auditiva del paciente previa y posterior al momento de la implantación.
  • Observación indirecta. A través de tests diseñados para evaluar determinados aspectos de la calidad de audición de los pacientes implantados, puede obtenerse información adicional específica.
  • Análisis de las transformaciones de la señal de audio. Aplicando técnicas de Procesamiento de Señal pueden simularse las transformaciones que sufre la señal de audio desde su adquisición hasta la activación de las terminaciones nerviosas, representando así la pérdida de información asociada al proceso de análisis (debida al procesador, el implante y la estrategia de codificación) y a la interacción entre los electrodos y las terminaciones nerviosas.

Objetivo del proyecto ``Cochlear Implant Simulation''

El objetivo del proyecto ``Cochlear Implant Simulation'' ha sido combinar la experiencia acumulada a través de testimonios de pacientes y observación de sus habilidades con el estudio del funcionamiento de los sistemas de implante coclear y de la fisiología de la audición para desarrollar un sistema que simule la percepción del sonido a través del implante coclear. El sistema de simulación pretende verificar las siguientes características:

  • Representar los principales factores que condicionan la calidad con que es percibido el sonido a través del implante coclear.
  • Permitir la realización de simulaciones con ficheros de audio, para permitir a sujetos normo-oyentes apreciar cómo sería percibido el sonido por un sujeto implantado.
  • Desarrollar una plataforma de simulación genérica que permita realizar las simulaciones de acuerdo con las características de los distintos modelos de implante coclear disponibles en el mercado, e incluso con características de sistemas ficticios no existentes en el mercado.
  • Desarrollar el sistema de simulación en un entorno fácil de usar con objeto de permitir su utilización a los distintos agentes involucrados en el tratamiento de las hipoacusias con implante coclear (familiares del paciente, profesores, logopedas, rehabilitadores, psicólogos, programadores, especialistas ORL, etc.).


Pagina nueva 1

¿Cómo se usa ``Cochlear Implant Simulation''?

Uso de la aplicación

El programa ``Cochlear Implant Simulation'' incluye básicamente 4 tareas: (1) Preparación la señal de audio a procesar; (2) configuración de los parámetros de simulación; (3) síntesis de la señal procesada; (4) almacenamiento del resultado. A continuación se describe cómo se realiza cada una de las funciones.

Preparando la señal a procesar

La señal de audio de entrada (la señal que recogería el micrófono del sistema de implante coclear) se prepara bien abriendo un fichero de audio, en formato ``wav'' o bien grabándola a través de cualquier fuente conectada a la tarjeta de sonido tal como un micrófono, por ejemplo (Nota: para grabar sonido es preciso configurar el mezclador de la tarjeta de sonido).

Para leer un fichero ``wav'' se puede hacer click en el icono ``Abrir'' de la aplicación. También puede hacerse seleccionando ``Abrir'' en la barra de menú ``Archivo'' o bien mediante la secuencia de teclas ``Ctrl+O''. En cualquiera de los casos aparece un diálogo que permite navegar por el sistema de ficheros e identificar los ficheros de audio con extensión ``wav''. Una vez identificado el fichero a procesar, es leído el programa mediante doble click o bien seleccionándolo y haciendo click en el botón de ``Abrir''. Una vez leído, el fichero seleccionado aparecerá dentro del listado ``WAVs no procesados''.

Para grabar una señal de audio basta con hacer click en el botón de grabación (botón rojo de la parte inferior ventana del programa). La grabación se puede detener pulsando el botón gris de la parte inferior de la ventana. El programa grabará desde la entrada de micrófono del ordenador y asignará un nombre de fichero a la señal grabada. El fichero correspondiente a la señal grabada aparecerá dentro del listado ``WAVs no procesados''.

Pulsando el botón verde de la parta inferior del programa se reproduce el fichero seleccionado (ya sea grabado o leído desde el sistema de ficheros). Se oirá por la salida de audio del ordenador.

Configurando los parámetros de simulación

La configuración de los parámetros de simulación se realiza a través de la ``ventana de configuración'' que se activa haciendo click en el icono ``Configurar''. También se activa seleccionando ``Configurar Parámetros'' en la barra de menú ``Preferencias'' o bien seleccionando la secuencia de teclas ``Ctrl+P''.

En la ``ventana de configuración'' se pueden modificar los distintos parámetros involucrados en la simulación. Los parámetros cuya configuración requiere un valor numérico (tasa, fMin, fMax, etc.) se pueden establecer desplazando la barra correspondiente o bien introduciendo el valor numérico en la ventana correspondiente. Los parámetros que requieren una opción binaria (Detección de envolvente, Sincronización, etc.) son seleccionados marcando la opción correspondiente. Más adelante se describe el significado de cada uno de los parámetros de configuración.

El software permite también la lectura y escritura de ficheros de configuración. Estos ficheros tienen extensión ``*.par''. Para leer o escribir estos ficheros debe hacerse click en ``Leer Parámetros'' o ``Guardar Parámetros'', respectivamente, en la barra de menú ``Preferencias''.

Realizando la simulación

Para sintetizar la señal de audio tal y como sería percibida a través del implante coclear de acuerdo con la configuración establecida, debe marcarse el fichero original y a continuación hacer click sobre el botón ``Empezar Simulación'' situado en la parte inferior de la ventana. Durante un tiempo (que dependerá de la velocidad del ordenador utilizado) se procesará la señal, tras el cual aparecerá un nuevo fichero en el listado ``WAVs procesados''.

Los ficheros de audio resultantes de la simulación tienen asociados los parámetros utilizados para la simulación. Estos parámetros pueden desplegarse haciendo click sobre el icono ``+'' que figura junto a cada fichero.

Una vez finalizada la simulación, se puede marcar el fichero y haciendo click en el botón de reproducción (botón verde en la parte inferior) se puede escuchar el resultado de la simulación (la señal sintetizada) a través de la salida de audio del ordenador.

Almacenando los resultados

La señal sintetizada tiene asociado un nombre de fichero que es asignado automáticamente a partir del nombre del fichero de audio origen. Esta señal puede guardarse como fichero ``wav'' haciendo click en el icono ``Guardar'' o bien seleccionando la opción ``Guardar'' o ``Guardar Como'' en la barra de menú ``Archivo''. Las acciones ``Guardar'' y ``Guardar Como'' también se activan con la secuencia de teclas ``Ctrl+S'' y ``Ctrl+Shift+S'', respectivamente.

Si deseamos que alguno de los ficheros de audio desaparezca del listado ``WAVs procesados'' o ``WAVs no porocesados'' se deberá marcar el fichero y a continuación hacer click en el icono ``Cerrar'' o bien en la opción ``Cerrar'' de la barra de menú ``Archivo''. Si no ha sido previamente grabado, aparece un mensaje de advertencia para que no se pierda accidentalmente la señal sintetizada.

Otras características del programa

La ayuda se activa haciendo click sobre el botón de ``Ayuda'', o bien seleccionando ``Contenidos'' en la barra de menú de ``Ayuda'' o pulsando la tecla ``F1''.

Para salir de la aplicación se puede pulsar ``Ctrl+Q'' o seleccionar ``Salir'' en la barra de menú de ``Archivo''.

Función de las distintas opciones

  • Botones:
    • Abrir: Lanza una ventana para selección y lectura de un fichero ``wav'' desde el sistema de ficheros.
    • Guardar: Guarda en el sistema de ficheros el fichero ``wav'' marcado.
    • Cerrar: Cierra el fichero ``wav'' marcado, mostrando un aviso en caso de no haber sido guardado previamente.
    • Configurar: Lanza la ventana de configuración de parámetros de simulación.
    • Ayuda: Abre la ventana de ayuda.
    • Botón verde (reproducir): Reproduce el fichero ``wav'' marcado (ya sea no procesado o procesado) permitiendo que sea escuchado a través de la salida de audio del ordenador.
    • Botón gris (detener grabación): Detiene la grabación tras haber sido activada previamente.
    • Botón rojo (grabar): Comienza la grabación desde el micrófono u otra fuente conectada a la tarjeta de sonido.
    • Empezar simulación: Usando como señal de audio original aquella que esté marcada, sintetiza la señal de audio tal y como sería percibida por el sujeto implantado de acuerdo con los parámetros de configuración establecidos.
  • Menú Archivo:
    • Abrir: Lanza una ventana para selección y lectura de un fichero ``wav'' desde el sistema de ficheros.
    • Guardar: Guarda en el sistema de ficheros el fichero ``wav'' marcado.
    • Guardar Como: Guarda en disco el fichero ``wav'' marcado, permitiendo seleccionar el nombre y la carpeta donde es guardado. Se abre una ventana de diálogo para guardar el fichero.
    • Cerrar: Cierra el fichero ``wav'' marcado. Si no está guardado, el programa pide confirmación.
    • Salir: Finaliza el programa.
  • Menú Preferencias:
    • Configurar Parámetros: Lanza la ventana de configuración de los parámetros de la simulación.
    • Leer Parámetros: Lee un fichero de configuración de parámetros de la simulación.
    • Guardar Parámetros: Guarda en un fichero los parámetros de la simulación.
  • Menú Ayuda:
    • Contenidos: Lanza la ventana de ayuda.
    • Acerca de: Muestra información sobre la realización del software.

Configuración de los parámetros de simulación

Los parámetros de simulación que se pueden modificar y que van a modelar distintas situaciones con respecto a la forma en que el paciente implantado percibe el sonido son:

  • tasa: Tasa de estimulación (en pulsos por segundo) para cada electrodo.
  • fMin: Límite inferior del rango espectral procesado por el sistema de implante coclear, expresado en Hz.
  • fMax: Límite superior del rango espectral procesado por el sistema de implante coclear, expresado en Hz.
  • longitud-ic: Longitud de la guía de electrodos del implante coclear en mm.
  • n-canales-ic: Número de canales del implante coclear.
  • n-insertados-ic: Número de canales que han sido insertados en la cóclea durante la cirugía.
  • n-de-m: Número de electrodos que se activan en cada ciclo de estimulación de los m encendidos.
  • interacción: Coeficiente de interacción entre canales, en mm.
  • frecuencia de corte: En el caso de Estimulación Electro-Acústica (EAS), frecuencia de corte que determina el rango de frecuencias procesadas por el audífono y por el implante coclear.
  • Detección de Envolvente: Procedimiento utilizado para la detección de envolvente en la estrategia de codificación. Se puede seleccionar Hilbert+FIR (banco de filtros con filtros de respuesta impulsiva finita y detección de envolvente basada en transformada de Hilbert) o Rect-LP+IIR (banco de filtros con filtros de respuesta impulsiva infinita y detección de envolvente basada en rectificador y filtro paso-baja).
  • Sincronización: Con este parámetro se modela la capacidad de sincronización de la actividad nerviosa con el estímulo presentado.
  • Estimulación Electro-Acústica: Permite simular la audición de un paciente en el que se combina la estimulación eléctrica a través del implante coclear con la estimulación acústica a través de un audífono.
  • Desplazamiento de Frecuencias: Si se activa esta opción, la síntesis se realiza teniendo en cuenta la frecuencia correspondiente a la posición de cada electrodo del implante de acuerdo con la teoría tonotópica.

Tasa

Este parámetro representa la tasa de estimulación para cada canal del implante coclear, es decir, el número de pulsos por segundo que se presenta en cada electro del implante. Durante el ajuste del procesador, se recomienda fijar este parámetro a un valor superior a 1000 pps (pulsos por segundo), ya que el tiempo de repolarización de las terminaciones nerviosas es del orden de 2 ms y valores de la tasa inferiores a 800 pps producirían una sincronización (indeseable) de la actividad neural con los pulsos de estimulación, en lugar de la sincronización (deseable) de la actividad neural con la señal de audio. El valor asignado a este parámetro influencia fuertemente la resolución temporal con que es percibida la señal de audio y afecta de forma importante la calidad de la señal percibida, particularmente para aquellos pacientes con una buena capacidad de sincronización. En el programa ``Cochlear Implant Simulation'', este parámetro se puede hacer variar entre 10 y 10000 pulsos por segundo.

fMin y fMax

Son los límites inferior y superior del rango espectral procesado por el sistema de implante coclear, expresado en Hz. fMin y fMax son utilizados para construir el banco de filtros. En la simulación (al igual que en un sistema de implante coclear), las componentes de frecuencia inferior a fMin o superiores a fMax no son procesadas. Teniendo en cuenta el rango espectral de la voz, es recomendable que fMin sea inferior a 350 Hz y fMax superior a 4000 Hz. En el programa ``Cochlear Implant Simulation'' fMin puede tomar valores entre 20 Hz y 5000 Hz, mientras que fMax puede estar entre 500 Hz y 10000 Hz, con la restricción de que fMin debe ser inferior a fMax.

Longitud-ic y n-canales-ic

Estos dos parámetros caracterizan la geometría del implante coclear. La longitud del implante coclear, expresada en mm, junto con el número de canales del implante coclear, se utilizan para determinar la distancia entre electrodos consecutivos y la posición de cada electrodo a lo largo de la cóclea. De esta forma se puede modelar el efecto de interacción entre canales (que va a depender de la dispersión del campo de corriente en torno a cada electrodo y de la separación entre electrodos consecutivos). Estos parámetros también permiten modelar el desplazamiento de frecuencias asociado a la estimulación con implante coclear, que va a depender de la diferencia entre la frecuencia central del filtro asociado a cada electrodo y la frecuencia asociada tonotópicamente a la posición en la que dicho electrodo está ubicado.

En el programa ``Cochlear Implant Simulation'' la longitud del implante coclear puede tomar valores entre 1 mm y 30 mm, mientras que el número de canales del implante coclear se puede hacer variar entre 1 y 50.

n-insertados-ic

Este parámetro representa el número de electrodos insertados durante la cirugía. Se supone que el implante coclear va a estar correctamente programado y que este será el número de canales activos en el implante coclear. De este modo, en la práctica, este parámetro es usado para definir el número de bandas de frecuencia en las cuales se va a dividir el rango espectral definido por fMin y fMax. El número de bandas de frecuencia va a condicionar, en principio, la resolución espectral tonotópica, de modo que cuanto mayor es, mejor es la calidad con que es percibido el sonido. Sin embargo, la resolución espectral tonotópica se ve también fuertemente afectada por la interacción entre canales, debido a que la corriente insertada por los electrodos no está confinada y se dispersa en una región relativamente extensa. De este modo, para un número alto de bandas, la resolución espectral tonotópica se verá limitada más por la interacción entre canales que por el número de bandas.

El número de electrodos insertados en el implante coclear es utilizado también para determinar la posición de cada uno de los electrodos a lo largo de la cóclea y determinar así la frecuencia característica del punto en el cual se encuentra cada uno de los electrodos, con objeto de modelar el efecto de desplazamiento de frecuencias. El número de electrodos insertados debe ser menor o igual al número de canales del implante coclear.

n-de-m

Este parámetro es el número de canales que son activados en cada ciclo de estimulación para estrategias de codificación n-de-m. Cuando el procesador utiliza una estrategia de tipo CIS, este parámetro debe hacerse igual al número de electrodos insertados (el valor máximo que permite el programa).

Cuando se aplica una estrategia n-de-m, en cada ciclo de estimulación (de acuerdo con la tasa de estimulación establecida con el parámetro de tasa) se compara la energía de los distintos canales y únicamente los n canales con mayor energía son seleccionados para estimulación mientras que el resto de canales son descartados (la energía de los canales descartados se fija a un valor nulo). Cuando n se hace igual a m (estrategia CIS) todos los canales son seleccionados en cada ciclo de estimulación.

Cuando menor es n frente a m, peor es la calidad de la señal sintetizada, debido a la información que se suprime (por anularse los canales con menor energía). Las estrategias n-de-m se usan para permitir que la tasa de estimulación no se vea excesivamente reducida en los implantes con un elevado número de electrodos.

Interacción

Este parámetro se utiliza para modelar la interacción entre canales. La interacción entre canales es modelada como una transferencia de energía desde un determinado canal en el bloque de análisis hacia los canales adyacentes en el bloque de síntesis. Para un electrodo determinado, ``k'', una parte de la corriente generada en la estimulación va a estimular las terminaciones nerviosas próximas a este electrodo, pero habrá también una estimulación de las terminaciones nerviosas próximas a los electrodos ``k+1'', ``k-1'', ``k+2'', ``k-2'', etc. En la práctica, esto reduce la resolución espectral tonotópica. La interacción entre canales se hace más importante cuanto más próximos están unos electrodos de otros. De este modo, la interacción (o transferencia de corriente) es mayor entre el electrodo ``k'' y el electrodo ``k+1'' que entre el electrodo ``k'' y el ``k+2''.

En este programa se ha asumido que la interacción es función de la distancia entre los electrodos y que sigue una función exponencial caracterizada por un coeficiente de interacción. De este modo, la contribución del electrodo ``A'' a las terminaciones nerviosas asociadas al electrodo ``B'' se calcula como:

Intensidad(A)*exp(-Distancia(A-B)/Coeficiente.Interacción)

La intensidad observada en las terminaciones nerviosas asociadas al electrodo ``B'' será la suma de las contribuciones desde todos los electrodos adyacentes. Cuando la distancia entre electrodos es pequeña frente el coeficiente de interacción, hay una interacción fuerte entre los distintos canales, lo que hace que la discriminación entre el estímulo procedente de dos electrodos adyacentes resulte difícil (y limita la resolución espectral tonotópica). En algunos estudios se ha estimado que un valor razonable para este coeficiente estaría en torno a 2 o 3 mm.

Frecuencia de Corte

Este parámetro sólo tiene aplicación en caso de haber seleccionado Estimulación Electro-Acústica (EAS). La Estimulación Electro-Acústica consiste en la combinación de un audífono y de un implante coclear. La frecuencia de corte determina el rango de frecuencias que es procesado por el audífono (frecuencias inferiores a la frecuencia de corte) y el rango espectral procesado por el implante (desde la frecuencia de corte hasta fMax). En este caso, el banco de filtros para el implante coclear se diseña utilizando este rango espectral. Este parámetro puede tomar valores entre 20 Hz y 5000 Hz.

Detección de Envolvente

En la mayor parte de los sistemas de implante coclear, el banco de filtros utiliza filtros de respuesta impulsiva infinita (IIR) y la detección de envolvente se realiza rectificando y filtrando paso-baja la salida de cada filtro del banco. Para simular esta situación se debe seleccionar Rect-LP+IIR. Otros sistemas de implante coclear utilizan para cada canal una pareja de filtros de respuesta impulsiva finita (FIR) (lo que evita la distorsión de fase de los IIR) y obtienen la envolvente mediante la transformada de Hilbert (lo que proporciona una mejor representación de la evolución temporal de la envolvente). Para simular este caso se debe seleccionar Hilbert+FIR.

Sincronización

Este parámetro sirve para modelar la capacidad de sincronización de la actividad nerviosa con el estímulo presentado. Puede tomar valores comprendidos entre 0.0 y 1.0, correspondiendo 0.0 a una mala capacidad de sincronización y 1.0 a una buena capacidad de sincronización. Seleccionando sincronización buena, se representa una situación en la que la lesión del nervio auditivo no es excesiva y es posible para el paciente extraer información temporal a partir del patrón de estimulación. Seleccionado sincronización mala se representa una situación en la que la lesión del nervio auditivo es más importante, lo que hace que se pierda gran parte de la información temporal. Ambas situaciones se modelan a través del proceso de síntesis usando como señal de excitación para la síntesis un ruido blanco gaussiano (en el caso de mala sincronización) o bien una secuencia de impulsos situados en cada máximo local de la envolvente para cada canal (en el caso de buena sincronización). En esta última situación se puede representar el hecho de que cuando la situación es buena, la mayor parte de las descargas del nervio auditivo se producen cuando la energía alcanza un máximo en la señal de audio. Ambas señales de excitación (ruido blanco gaussiano y tren de pulsos) son combinadas en función del parámetro de sincronización, representando situaciones intermedias entre ``mala sincronización'' y ``buena sincronización''.

Estimulación Electro-Acústica

La Estimulación Electro-Acústica (EAS) combina la estimulación eléctrica (a través del implante coclear) con la estimulación acústica (a través del audífono). Esta técnica es útil en pacientes que mantienen restos auditivos en las frecuencias graves. Cuando se selecciona este parámetro en la simulación, se separa el rango espectral correspondiente a la parte de estimulación acústica (hasta la frecuencia de corte) y la parte de estimulación eléctrica (desde la frecuencia de corte a fMax). La señal sintetizada en este caso es la suma de la parte correspondiente a estimulación acústica y la señal resultante de simular el funcionamiento del implante coclear usando el rango espectral definido por la frecuencia de corte y fMax.

Desplazamiento de Frecuencias

Activando esta opción, el programa utiliza para la síntesis un banco de filtros con frecuencias distintas de las usadas por el procesador. Las frecuencias usadas para síntesis son determinadas de acuerdo con la teoría tonotópica, teniendo en cuenta la posición de cada electrodo a lo largo de la cóclea.


Pagina nueva 1

¿Cómo se ha hecho ``Cochlear Implant Simulation''?

El programa ``Cochlear Implant Simulation'' se ha desarrollado partiendo de un modelo que representa las principales etapas del proceso mediante el cuál un paciente con implante coclear percibe el sonido. En este modelo se consideran aspectos tanto técnicos como fisiológicos que van a condicionar la percepción. Se divide en dos bloques principales: un bloque de análisis y un bloque de síntesis.

Modelo análisis-síntesis.

El bloque de análisis representa el proceso que sigue la señal de audio desde que es adquirida por el micrófono hasta que se transforma en impulsos eléctricos proporcionados por los distintos electrodos del implante, y éstos dan lugar a los potenciales de acción en el nervio auditivo.

La primera parte del bloque considera exclusivamente el procesamiento de señal realizado por el sistema de implante coclear y a través de esta parte es posible representar la pérdida de información asociada a la configuración del implante y la estrategia de codificación. La segunda parte del bloque de análisis representa la interacción entre la guía de electrodos y las terminaciones nerviosas y describe cómo se transforma el patrón de actividad de los electrodos del implante en el patrón de actividad en el nervio auditivo.

El bloque de síntesis proporciona una señal de audio a partir del patrón de actividad del nervio auditivo obtenido en el bloque de análisis. La señal de audio se sintetiza partiendo del patrón de actividad correspondiente a cada banda de frecuencia (asociada a cada región de la cóclea). De este modo, la información perdida debido al proceso de análisis da lugar a una pérdida de calidad en la señal sintetizada. La figura 1 representa el diagrama de bloques considerado para la simulación.

Figura 1: Diagrama de bloques del programa ``Cochlear Implant Simulation''.

Este modelo permite considerar los principales aspectos que condicionan la percepción a través del implante coclear, como son la estrategia de codificación, el diseño del banco de filtros, la tasa de estimulación, el número de canales, las dimensiones del implante coclear, la colocación de la guía de electrodos, la interacción entre los electrodos del implante y las terminaciones nerviosas, etc. Las señales sintetizadas teniendo en cuenta este modelo presentan la pérdida de información propia de la estimulación a través del implante coclear y de este modo permiten a sujetos normo-oyentes oír el sonido tal y como sería percibido por un paciente portador de implante coclear.

Cómo se ha representado cada efecto.

Procesamiento de señal en el implante

La figura 2 muestra el diagrama de bloques de un sistema de implante coclear convencional. La señal es adquirida por el micrófono del procesador y amplificada, pasando a un banco de filtros que la separa en distintas bandas de frecuencia. La salida de cada filtro es pasada a través de un detector de envolvente. De este modo, para cada canal se estima la energía que presenta la señal en cada banda de frecuencia y en cada instante de tiempo. El bloque de adaptación del rango dinámico sirve para transformar el rango dinámico acústico para cada canal, en el rango dinámico eléctrico que requiere cada electrodo del paciente. Esta transformación del rango dinámico es específica del paciente y diferente para cada uno de los electrodos. Finalmente, de acuerdo con la tasa de estimulación, el procesador genera los pulsos de estimulación que representan el nivel de corriente que se debe suministrar en cada electrodo en cada instante de tiempo. En estrategias pulsátiles (como estrategias CIS o n-de-m) los pulsos de estimulación se generan de modo que en cada instante de tiempo únicamente haya un electrodo activo, con objeto de evitar el fenómeno conocido como ``suma de campos''. Una vez establecido el patrón de estimulación en el procesador, éste es transmitido al implante coclear y los pulsos de corriente son generados a través de los electrodos del implante.

Figura 2: Diagrama de bloques de un sistema de implante coclear.

El programa ``Cochlear Implant Simulation'' procesa el sonido reproduciendo el análisis de la señal de audio realizado por el procesador del implante coclear de acuerdo con el conjunto de parámetros de simulación establecidos. Esto proporciona el patrón de actividad en los electrodos del implante coclear que se obtendría cuando se presenta la señal de audio en el micrófono.

A partir del patrón de actividad en los electrodos, y de acuerdo con el modelo de interacción electrodos/terminaciones nerviosas, se determina el patrón de actividad neural para los grupos de terminaciones asociados a cada porción coclear. Finalmente, partiendo de este patrón de actividad neural se sintetiza la señal de audio teniendo en cuenta la capacidad de sincronización de la actividad neuronal y las frecuencias características de las porciones cocleares estimuladas.

La tasa de estimulación

La tasa de estimulación representa el número de pulsos por segundo que se presentan en cada uno de los electrodos del implante coclear. Este parámetro limita la resolución temporal del implante coclear, es decir, la capacidad de apreciar cambios rápidos en las características de la señal de audio. Cuanto menor es la tasa de estimulación, peor es la calidad con que es percibido el sonido.

La resolución temporal del paciente implantado se ve limitada, además de por la tasa de estimulación, por el periodo refractario de las neuronas del nervio auditivo. El tiempo que las neuronas necesitan para repolarizarse tras una descarga se sitúa en torno a 2 ms. Por ello, es conveniente que la tasa de estimulación se sitúe por encima de 1000 pulsos por segundo.

En el programa ``Cochlear Implant Simulation'', la tasa de estimulación se ha representado submuestreando las envolventes a una frecuencia igual a la tasa de estimulación. Debe tenerse en cuenta que existen estrategias de estimulación en las que se utiliza una tasa de actualización de la envolvente inferior a la tasa de estimulación. En tal caso, el valor asignado al parámetro ``tasa'' debería ser la tasa de actualización y no la tasa de estimulación, puesto que este parámetro representa la pérdida de resolución temporal.

Debe tenerse en cuenta que para tasas de estimulación excesivamente bajas (por debajo de 800 o 700 pps) además de la pérdida de resolución temporal va a haber un efecto de sincronización de la actividad neural con los pulsos de estimulación, que va a reducir aun más la calidad de la percepción con el implante coclear. Este efecto no ha sido modelado en el programa ``Cochlear Implant Simulation'' de modo que en el caso de tasas de estimulación excesivamente bajas, en la situación real la calidad de la señal percibida sería peor que la apreciada en la simulación.

El banco de filtros de análisis

El banco de filtros utilizado para el análisis está formado por filtros equiespaciados en una escala logarítmica de frecuencia en el rango definido por fMin y fMax. Los anchos de banda de los filtros son iguales en la escala logarítmica de frecuencia, de modo que los correspondientes a frecuencias más bajas son más estrechos y los correspondientes a frecuencias más altas son más anchos.

Cada canal del implante coclear tiene asignado un filtro paso-banda. El número de canales está determinado por el parámetro ``n-insertados-ic''. Cuanto mayor es el número de canales mayor es la resolución espectral tonotópica. En el caso de estar seleccionada la opción ``Hilbert+FIR'', los filtros están diseñados como filtros de respuesta impulsiva finita (FIR) de 100 coeficientes. En el caso de seleccionarse la opción ``Rect-LP+IIR'' se utilizan filtros de respuesta impulsiva infinita de tipo Butterworth de orden 6. Los filtros FIR presentan el inconveniente de requerir mayor cantidad de cálculo. Los filtros IIR presentan los inconvenientes de ocasionar una distorsión de fase y de poder dar una respuesta inestable, particularmente en el caso de anchos de banda reducidos.

Detección de envolvente

La detección de envolvente se ha realizado mediante rectificación y filtrado paso-baja (opción ``Rect-LP+IIR'') o bien mediante transformada de Hilbert (opción ``Hilbert+FIR''). Esta última opción proporciona una envolvente que representa de forma óptima la evolución temporal de la energía en la banda de frecuencia del filtro, pero tiene el inconveniente de requerir el uso de dos filtros FIR en cuadratura de fase, con el correspondiente incremento en los requerimientos de cálculo.

Estrategias CIS y n-de-m

El parámetro ``n-de-m'' permite seleccionar estrategias CIS (cuando n es igual a m, es decir, al número de canales insertados) o estrategias n-de-m (cuando n es menor que m).

Las estrategias n-de-m funcionan activando en cada ciclo de estimulación únicamente los n canales que presentan más energía de los m disponibles. La finalidad de las estrategias n-de-m es permitir un incremento en la tasa de estimulación gracias a que al reducir el número de canales activados en cada ciclo, la duración total del ciclo de estimulación se reduce. Este incremento de la tasa de estimulación se hace a costa de una reducción de la calidad, ya que la información correspondiente a los canales no seleccionados se pierde.

Para simular el efecto de las estrategias n-de-m, en cada ciclo de estimulación se comparan las envolventes correspondientes a los distintos canales, seleccionando las n de mayor energía y anulando las envolventes para el resto de los canales. De este modo la información correspondiente a canales no seleccionados es eliminada de la señal sintetizada.

Interacción entre canales

La interacción entre canales se ha modelado a través de la interfase electrodos - terminaciones nerviosas. En trabajos previos se ha estimado cual es la distribución de la densidad de corriente en un sistema eléctrico similar a una cóclea estimulada por un implante coclear. Se ha encontrado que la corriente insertada en un electrodo se dispersa en un área relativamente extensa, tanto en el caso de estimulación monopolar como en el caso de estimulación bipolar.

Cuando se estimula en un electrodo, sería deseable que únicamente las fibras nerviosas más próximas al electrodo fueran activadas. Sin embargo, los pulsos presentados en un electrodo activan tanto estas fibras como otras más alejadas. De forma análoga, un grupo de fibras va a ser activado principalmente por el electrodo más próximo, pero también va a activarse cuando se presentan estímulos en electrodos más alejados. Este fenómeno se puede modelar mediante una matriz de mezcla entre los canales del implante y los ``canales del nervio auditivo'' definiendo cada uno de estos canales como el conjunto de neuronas próximos a un electrodo. De este modo, los distintos canales del implante contribuyen a cada ``canal del nervio auditivo'', y la contribución dependerá de la distancia que separa cada electrodo de la porción coclear considerada. En este modelo se ha supuesto que la contribución se reduce de forma exponencial con la distancia, y se ha definido el coeficiente de interacción como la constante de este decaimiento exponencial. Los estudios sobre la distribución del campo de corriente en la cóclea sugieren que un valor apropiado para esta constante estaría en torno a 2 o 3 mm.

Para determinar la matriz de mezcla que da lugar a la interacción entre canales, se tiene en cuenta la separación entre los distintos electrodos del implante. Para ello se consideran las dimensiones del implante y el número de electrodos que tiene. Cuanto más próximos están los electrodos entre sí, o cuanto mayor es el coeficiente de interacción, mayor es la interacción entre canales, lo que tiene como consecuencia una pérdida de resolución espectral tonotópica. En tal caso, la resolución espectral que proporciona el implante no va a estar limitada por el número de electrodos, sino por la interacción entre canales. Puede apreciarse que para valores bajos del coeficiente de interacción, la calidad de la señal sintetizada aumenta a medida que crece el número de electrodos considerados en la simulación. Sin embargo, para valores mayores del coeficiente de interacción, la resolución espectral deja de mejorar cuando la separación entre electrodos adyacentes es inferior al coeficiente de interacción.

Síntesis de la señal

El bloque de síntesis de la señal responde al diagrama mostrado en la figura 3. La síntesis toma como punto de partida el patrón de actividad tras haber modelado la interacción entre canales. La envolvente en cada canal representa la energía que hay en cada instante de tiempo en cada una de las bandas de frecuencia. Por ello, para sintetizar la señal de audio, se toma una señal excitación (en principio con distribución de energía uniforme en frecuencia y en el tiempo). Esta excitación se filtra con un banco de filtros, y la señal filtrada es multiplicada por la envolvente. La salida para cada canal después de estas operaciones es una señal limitada en la banda que define el canal y cuya energía evoluciona en el tiempo de acuerdo con la envolvente considerada. Finalmente se suman las contribuciones procedentes de los distintos canales, obteniendo una señal de audio que incluye las contribuciones de todo el rango espectral procesado.

Figura 3: Diagrama del bloque de síntesis del programa ``Cochlear Implant Simulation''.

La señal excitación considerada puede ser ruido blanco gaussiano, ya que esta excitación presenta espectro plano y distribución de energía uniforme en el tiempo. Sin embargo las señales sintetizadas usando ruido blanco presentan muy mala calidad, debido a que la fase de la señal sintetizada es aleatoria, por serlo la excitación utilizada para cada canal. El resultado es una señal de audio en la que se pierde la estructura temporal, y en particular se pierde el tono fundamental que no puede ser resuelto en el dominio del tiempo. Diversos experimentos ponen de manifiesto que la mayor parte de los pacientes perciben con una calidad mejor que la que se puede conseguir sintetizando de este modo. Por ello se ha propuesto un método alternativo para la síntesis. Éste consiste en usar como señal excitación un conjunto de pulsos. Los pulsos se sitúan en los instantes de tiempo en los que la envolvente presenta un máximo local. Un pulso aislado o un conjunto de pulsos presentan un espectro plano. Para evitar que la energía de la señal sintetizada se vea condicionada por los pulsos (debe depender de las envolventes pero no de las excitaciones del bloque de síntesis) la señal excitación se normaliza para que presente una distribución de energía lo más uniforme posible en el tiempo. Para este método de síntesis, la excitación presentada para cada banda es independiente del resto de bandas y se calcula a partir de los máximos locales de la envolvente considerada en la banda correspondiente.

El uso de una excitación de tipo ruido blanco gaussiano representaría cómo percibe un paciente implantado que debido a la lesión del nervio auditivo, no presenta una buena resolución temporal. Esta situación hace que la actividad neural no se sincronice con el estímulo auditivo y no quede representado en el patrón de actividad neural el tono fundamental. Este forma de percibir se presenta en los pacientes con pérdidas auditivas de mayor duración o cuando el índice de supervivencia neuronal es menor, es decir, cuando las lesiones cocleares son más extensas.

El uso de una excitación de tipo tren de pulsos representaría cómo percibe un paciente implantado con una buena capacidad de sincronización en la actividad neural. En este caso el patrón de actividad del nervio auditivo puede seguir la evolución de la envolvente, produciéndose la mayor parte de las descargas en los instantes en los que la envolvente presenta un pico de energía. De este modo, el tono fundamental puede ser percibido a partir del patron temporal de actividad del nervio auditivo.

En un caso real, cabría esperar que el paciente tuviera una percepción con una calidad intermedia entre ambas situaciones, más próxima a la situación de ``mala sincronización'' cuando las lesiones cocleares son más importantes, más próxima a ``buena sincronización'' cuando el nervio auditivo se conserva en mejor estado. Con objeto de modelar este efecto, el software``Cochlear Implant Simulation'' calcula ambas señales de excitación (ruido blanco gaussiano y tren de pulsos) y las combina en función del parámetro de sincronización.

El banco de filtros de síntesis

El banco de filtros utilizado para la síntesis está constituido por filtros paso-banda de tipo FIR, con objeto de no introducir distorsiones de fase innecesarias en el proceso de síntesis. Si la opción ``Desplazamiento de Frecuencias'' no está activada, las frecuencias centrales y frecuencias de corte de los filtros coinciden con las del banco de filtros utilizados para el bloque de análisis. Si esta opción está activada, las frecuencias y anchos de banda de los filtros de síntesis se determinan teniendo en cuenta la posición de cada electrodo y la frecuencia característica correspondiente a esta posición de acuerdo con la teoría tonotópica. A tal efecto se tienen en cuenta tanto las dimensiones de la guía de electrodos como el número de electrodos y la profundidad de inserción de la guía.

Estimulación Electro-Acústica

Para simular la percepción en el caso de Estimulación Electro-Acústica se separa el espectro en la parte baja (correspondiente a la estimulación acústica) y la parte alta (correspondiente a la estimulación eléctrica). Para separar ambas partes se tiene en cuenta el parámetro ``frecuencia de corte''. La parte de la estimulación acústica se obtiene filtrando paso-baja la señal original con un filtro diseñado con esta frecuencia de corte. La parte de la estimulación eléctrica se obtiene procesando la señal de acuerdo con la configuración del implante coclear, usando como rango de frecuencias el determinado por la frecuencia de corte y por fMax. La señal sintetizada se obtiene sumando la parte de estimulación acústica y la parte de estimulación eléctrica.

Validación del procedimiento

Para validar el procedimiento de simulación implementado en el programa ``Cochlear Implant Simulation'', se han realizado tests presentando frases a varios pacientes portadores de implante coclear. En estos tests se presentaban a cada paciente distintas frases, incluyendo frases sintetizadas y las frases originales. Se pedía al paciente que valorara la calidad con que eran percibidas las frases sintetizadas y las originales.

La hipótesis de partida para realizar la validación es que tanto la simulación como el sistema de implante coclear dan lugar a una pérdida de calidad en la audición. En el test, el paciente implantado va a percibir una frase procesada por el programa de simulación y procesada posteriormente por el propio sistema de implante coclear (en el caso de las frases sintetizadas) o bien una frase procesada únicamente por el sistema de implante coclear (en el caso de la frase original).

Cuando la simulación se realiza con una configuración que proporciona mayor calidad que los parámetros del sistema de implante coclear, la calidad de la frase sintetizada no va a verse condicionada por los parámetros de simulación. En este caso, de acuerdo con la hipótesis de partida, el paciente debería indicar que la calidad de la frase sintetizada es similar a la de la frase original. Cuando la simulación se realiza con una configuración que proporciona peor calidad que los parámetros del sistema de implante coclear, la calidad de la frase sintetizada se verá condicionada por los parámetros de la simulación. En este caso el paciente debería indicar que la frase sintetizada tiene peor calidad que la original.

De este modo, si se fijan todos los parámetros de la simulación a los valores que el paciente tiene para el sistema de implante coclear, salvo uno de ellos, que se hace variar desde un valor bueno (que proporciona mejor calidad) a otro malo (que proporciona peor calidad) y se representa gráficamente la calidad frente a este parámetro, se apreciará una curva, de modo que hacia los valores buenos del parámetro, la calidad tiende a ser buena (similar para las frases original y sintetizada) y hacia los valores malos presenta una rápida caída (la frase sintetizada es percibida como claramente peor que la frase original). Esta curva debería presentar un codo precisamente cuando el valor del parámetro de simulación coincide con el valor del parámetro en su sistema de implante coclear. Si este efecto se verifica, puede concluirse que la simulación modela adecuadamente el efecto de dicho parámetro sobre la calidad de audición.

Método de validación

Se han realizado tests de validación con 7 pacientes portadores de implante coclear. Todos ellos fueron implantados en el servicio de ORL del Hospital La Paz de Madrid, con un dispositivo Combi40+ fabricado por MED-EL. Los tests de validación se han centrado en 3 parámetros de simulación: la tasa de estimulación, el número de canales y el coeficiente de interacción entre canales. Para cada uno de ellos, se han sintetizado frases con distintos valores del parámetro a estudiar y se han presentado al paciente tanto las frases originales como las sintetizadas, pidiéndole que valore la calidad con que se percibe cada una de las frases en una escala entre 0 (calidad pésima) y 10 (calidad óptima).

Para el análisis de resultados, la puntuación que indica la calidad de las frases se ha normalizado dividiéndola por la puntuación asignada a la frase original correspondiente. De este modo, si una frase sintetizada presenta puntuación 1, debe interpretarse como que el paciente la percibe con la misma calidad que la frase original. Para cada parámetro estudiado, se ha representado la puntuación normalizada frente al parámetro considerado. Se ha realizado un ajuste polinómico (de orden 3) por mínimos cuadrados sobre estos datos, obteniendo la función que mejor ajusta los datos y los intervalos de confianza del 95% correspondientes.

Resultados

En la figura 4 se muestran los valores de puntuación de calidad normalizada frente a la tasa de estimulación considerada en la simulación. Se muestra también el ajuste correspondiente de estos datos. Cada punto de la gráfica representa la evaluación por un paciente de una frase sintetizada. Se muestra el ajuste polinómico por mínimos cuadrados y el intervalo de confianza del 95% correspondiente. Puede observarse que para tasas de estimulación muy altas, los pacientes no aprecian pérdida de calidad en la frase sintetizada, y a medida que la tasa es menor, la calidad va disminuyendo, obteniéndose puntuaciones muy bajas para tasas por debajo de 700 pps. Se observa el efecto de codo en la gráfica correspondiente a cada paciente, y se aprecia además que la tasa en la que se produce el codo es diferente para cada paciente, siendo mayor cuando la tasa utilizada en el procesador es mayor. Este resultado valida el procedimiento de simulación con respecto a la tasa de estimulación.

Figura 4: Ajuste de la puntuación de calidad normalizada frente a la tasa de estimulación.

Para verificar la influencia de la tasa de estimulación de la simulación en relación con la que el paciente tiene programada en el procesador, se ha realizado un ajuste usando como variable independiente la tasa de estimulación normalizada, es decir, el cociente entre la tasa de estimulación usada para la simulación y la tasa utilizada en el procesador. Los resultados de este ajuste son mostrados en la figura 5. En este caso se aprecia que el codo se sitúa para un valor de tasa de estimulación normalizada próximo a la unidad, es decir, cuando la tasa de estimulación de la simulación se aproxima a la que tiene el paciente programada en el procesador.

Figura 5: Ajuste de la puntuación de calidad normalizada frente a la tasa de estimulación normalizada.

La figura 6 muestra el ajuste entre puntuación de calidad normalizada y número de canales utilizados en la simulación. Los pacientes disponían de ajustes del procesador con un número de electrodos activos situado entre 9 electrodos y 12 electrodos (2 pacientes con 9 electrodos activos, 1 con 10 electrodos, 1 con 11 electrodos y 3 con 12 electrodos).

En estas gráficas se observa el efecto de codo, siendo la calidad similar a la de la frase original para un número elevado de canales en la simulación y degradándose rápidamente la calidad cuando el número de canales usado en la simulación es inferior a 8. Resulta interesante el hecho de que el codo no está en torno al número de canales que usa cada paciente, sino en torno a 8 canales. Esto pone de manifiesto que la resolución espectral tonotópica que disfrutan estos pacientes no está condicionada por el número de electrodos sino por algún otro fenómeno. La resolución espectral tonotópica con que perciben el sonido es la equivalente a unos 8 canales, a pesar de disponer de un número superior de canales activos en sus respectivos implantes es superior. La causa probable de esta limitación en la resolución espectral tonotópica es la interacción entre canales.

Figura 6: Ajuste de la puntuación de calidad normalizada frente al número de canales.

Para valorar el efecto de la interacción entre canales se han realizado tests modificando en la simulación el coeficiente de interacción entre canales. Los resultados se muestran en la figura 7. Se observa que cuando se sintetiza la señal con un coeficiente de interacción bajo, la calidad de la frase sintetizada es similar a la de la frase original, pero a medida que aumenta este coeficiente de interacción la calidad se degrada de forma significativa. El codo en estas gráficas se sitúa alrededor de 1 o 2 mm, lo que se puede interpretar como que la interacción entre electrodos y terminaciones nerviosas se puede modelar a través del coeficiente de interacción entre canales asignando a este coeficiente un valor próximo a 1 o 2 mm. Este valor es consistente con las observaciones y estudios teóricos previos relativos a la distribución de la densidad de corriente en el sistema eléctrico implante coclear - cóclea.

Figura 7: Ajuste de la puntuación de calidad normalizada frente al coeficiente de interacción.

Agradecimientos

Los autores agradecen la colaboración prestada por el equipo de ORL del Hospital La Paz de Madrid y la prestada por los pacientes que participaron en los tests de validación.


Pagina nueva 1

¿Qué no es ``Cochlear Implant Simulation''?

El objetivo del programa ``Cochlear Implant Simulation'' es simular la percepción de la audición a través del implante coclear. Esta simulación está basada en una serie de consideraciones y modelos. Se puede afirmar que las señales sintetizadas mediante este programa representan adecuadamente la percepción a través del implante coclear en la medida en que los modelos considerados representan adecuadamente a la realidad y los parámetros seleccionados se ajustan a los de la situación que se pretende simular. Los resultados de validación avalan la adecuación de las señales sintetizadas como una aproximación a la percepción con implante coclear. Sin embargo se resulta imposible establecer de forma definitiva e inequívoca que una señal sintetizada representa exactamente la percepción con el implante coclear. En este sentido, los resultados de la simulación deben considerarse con cierta prudencia.

Los aspectos no considerados en la simulación y que pueden influenciar la percepción hacen que las señales sintetizadas no representen de forma exacta la percepción a través del implante. Entre los aspectos no modelados en el programa desarrollado se pueden enumerar los siguientes:

  • La programación del procesador. En la simulación se ha supuesto que el procesador está perfectamente ajustado a los requerimientos del paciente implantado, es decir, que no hay pérdida de información debido a un ajuste incorrecto del procesador.
  • La resolución en intensidad. En la simulación no se modela la resolución en intensidad limitada de las fibras nerviosas, de modo que no queda representada la pérdida de calidad asociada a una resolución en intensidad limitada, particularmente importante en el caso de presentar el paciente un índice de supervivencia neuronal bajo.
  • Variación de los parámetros fisiológicos a lo largo de la cóclea. Un modelo adecuado y preciso de la interacción electrodo - nervio auditivo debería considerar que el coeficiente de interacción puede ser distinto para las distintas particiones cocleares. También debería tener en cuenta el periodo refractario de las neuronas, el índice de supervivencia neuronal y la resolución en intensidad de las neuronas y la variación de estos parámetros a lo largo de la cóclea.
  • Modelado de cócleas no normales, entendiendo por tales los casos de cócleas osificadas y malformaciones cocleares. En la simulación se ha supuesto que el implante se coloca en una cóclea permeable y que los electrodos se sitúan de forma que el primer electrodo de la guía (el más alejado del implante) se aloja en la porción más apical de la cóclea, y el último en la porción más basal, lo que permite determinar la frecuencia característica correspondiente a la posición en que está cada electrodo de acuerdo con la teoría tonotópica. La ubicación de los electrodos en los casos de cócleas osificadas (cuando la trayectoria del implante no sigue la rampa timpánica o cuando se utiliza un modelo de implante con una guía de electrodos bifurcada) o en el caso de malformaciones cocleares (como cavidades comunes), resulta difícil de modelar y no ha sido considerada en el programa desarrollado.

Otro aspecto importante a tener en consideración es que para la simulación se ha estimado cuál sería el patrón de actividad en las terminaciones del nervio auditivo y se ha partido de este patrón de actividad para sintetizar la señal de audio. Sin embargo no se ha modelado cómo se propaga esta actividad a lo largo de las vías auditivas ni cuál es el procesamiento de señal que sufren los potenciales de acción al pasar por el tronco cerebral. Modelar este aspecto resultaría extremadamente complicado debido al limitado conocimiento del papel del tronco cerebral en la audición. Puede suponerse que en el caso de pacientes con experiencia auditiva el procesamiento de la señal en el tronco es ``normal'' (similar al de sujetos normo-oyentes) pero en el caso de ausencia de experiencia auditiva, la falta de maduración de las vías auditivas va a dar lugar a una pérdida de información no considerada en el programa de simulación. El desarrollo de las habilidades auditivas por parte del paciente implantado (o el procesamiento de la señal o de la información a nivel cortical) tampoco resulta fácil de modelar (ni ha sido modelado) y también afecta a la forma de percibir el sonido a través del implante coclear.

Todos estos aspectos deben tenerse en cuenta cuando se afirma que de algún modo las señales sintetizadas representan la percepción del sonido a través del implante coclear. Está previsto que algunos de los efectos y factores descritos anteriormente sean incluidos en versiones futuras del programa ``Cochlear Implant Simulation''.


Historial de versiones

Versión 2.0

  • Mejoras
    • El parámetro de Sincronización se ha modificado de modo que ahora admite valores continuos entre 0.0 (que corresponde a una mala sincronización) y 1.0 (buena sincronización).
    • Se ha modificado el formato del fichero de parámetros para soportar la mejora anterior. Los antiguos ficheros de parámetros se pueden leer con la versión 2.0 (compatibilidad hacia atrás).
    • Se ha revisado y actualizado la documentación del programa.
  • Correcciones
    • Se ha solucionado un bug en la conversión interna de la frecuencia de muestreo de los ficheros de audio. Bajo ciertas circunstancias este bug podía producir un desplazamiento de frecuencia anómalo en la señal sintetizada.
    • Se ha solucionado un bug de gestión de memoria. En la nueva versión se hace un uso óptimo de la memoria.

Versión 1.0

Primera versión publicada del programa "Cochlear Implant Simulation", finalizada el 21 de Junio de 2004.


Los autores

El software ``Cochlear Implant Simulation'' versión 2.0 ha sido desarrollado por un equipo multi-disciplinar integrado por:

  • Ángel de la Torre Vega: Departamento de Electrónica y Tecnología de Computadores de la Universidad de Granada.
  • Marta Bastarrica Martí: Departamento de Electrónica y Tecnología de Computadores de la Universidad de Granada.
  • Rafael de la Torre Vega: Escuela Técnica Superior de Ingeniería Informática de la Universidad de Granada.
  • Manuel Sainz Quevedo: Departamento de Cirugía y sus Especialidades de la Universidad de Granada y jefe del Servicio de ORL del Hospital Universitario S. Cecilio de Granada.

Para el desarrollo de la interfaz gráfica se ha hecho uso de la librería wxWidgets versión 2.4.2 (http://www.wxwidgets.org). Para programar la lectura y escritura de ficheros wav se han utilizado los archivos wave.cpp, wave.h, rifffile.cpp y rifffile.h, cuyo copyright pertenece a Timothy J. Weber (http://www.lightlink.com/tjweber).

La versión 2.0 ha sido concluida en la Universidad de Granada, en Diciembre de 2004.

Copyright:
Ángel de la Torre Vega
Marta Bastarrica Martí
Rafael de la Torre Vega
Manuel Sainz Quevedo
Granada, Diciembre de 2004
Todos los derechos reservados.

Los autores autorizan la distribución, copia y uso sin ánimo de lucro de este programa. Cuando se distribuya o copie el programa, deberá incluirse tanto el fichero ejecutable como el fichero de ayuda. Queda prohibida la alteración del programa o del fichero de ayuda, la distribución de versiones alteradas, y la realización de ingeniería inversa sin la autorización expresa del/os titular/es de los derechos. Los autores distribuyen este programa sin ningún tipo de garantía en tanto que su distribución es gratuita. Los autores no se responsabilizan de ningún daño derivado de su uso.