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Getting Started for Translators 
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Learning Objectives 

SDL Trados Studio 2011 – components and their interaction 

 What is a translation memory, termbase, AutoSuggest dictionary? 

How to… 

 Translate files in SDL Trados Studio making use of the most common 

features 

 Deliver the finished translation 

 Create translation memories and termbases using legacy content (e.g. 

Excel glossaries and already translated documents) 
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Agenda 

Training outline 

SDL Trados Studio 2011 – Technologies overview 

Working with SDL Trados Studio 2011: Workflow overview 

Training presentation 

Questions and answers 



 

 
 

 

Training outline 
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Training outline 

Introduction to SDL Trados Studio Technologies  

 Translation memories (TM)  

 Termbases (TB) 

 AutoSuggest dictionaries (AS) 

 Translation workflow and processes 

 

The SDL Trados Studio 2011 environment 

 Starting the application for the first time 

 User interface overview 

 Setting up the environment 

 



6 

Training outline 

Translating a single file 

 Opening a file for translation  

 Selecting translation memory, termbase, AutoSuggest dictionary  

 Introduction to the translation editing environment  

 Translating and re-using existing translations from translation memory, 

termbase, AutoSuggest dictionary 

 Applying formatting and inserting tags (QuickInsert)  

 Quality assurance: Spell check and Tag verification 

 Previewing files in their original layout 

 Saving your translation 
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Training outline 

Project packages  

 What are project packages?  

 Opening a project package 

 Reading the Analyze Files report 

 Accessing the package files  

 Translating the package files  

 Creating the return package for delivery 

 

Pre-production: creating translation resources from legacy 

documents  

 Leveraging previously translated documents through alignment 

 Creating an auto-suggest dictionary  

 Creating a simple termbase 

 Converting glossaries into a termbase 

 



 

 
 

 

SDL Trados Studio 2011 
Technologies overview 
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Technologies overview: Translation 
providers 

Translation 

 

SDLTM 

Translation Memory (TM) 

• Bilingual database 

• Source + target sentences = translation unit (TU)  

• Additional information 

• Automatic look-up, pre-translation 

• 100% matches, Fuzzy matches, Context matches 

• Matches can be reused or edited 

 

 

BPM 

AutoSuggest dictionary (AS) 

• Bilingual database 

• Source + target sentence fragments (words, expressions) 

• Suggested automatically while typing 

• Context-sensitive, related to current source segment 

• Read-only! 

• Created from a TM (needs AutoSuggest Creator or 

Professional Edition) 

SDLTB 

Termbase (TB) 

• Multilingual database 

• Concept-oriented (all synonyms stored in one entry) 

• Source + target terms 

• Additional information: Status, definition, context, notes… 

 

SDLXLIFF, TTX, ITD 

Bilingual reference files 

• In context matching using paragraphs (Perfect Match = PM) 

• Pre-translation with Perfect Match only available in 

Professional Edition 

 

 Re-use 

 Ensure 

consistency 

 Accelerate 

processes 

 Reduce costs 

 Create assets 
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Technologies overview 

EN: term 

DE: Terminus 
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Target language 

2  
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SDL Trados Studio 2011 

Translation Editor 

SDLTM 

Translation 

Memory (TM) 

Source+target 

sentences 

 

BPM 

AutoSuggest 

dictionary (AS) 

Source+target 

sentence 

fragments 

SDLTB 

Termbase (TB) 

Source+target 

terms 
SDLXLIFF 

1 This is a sentence. 

 

2 This is a new 

sentence. 

3 This is a sentence. 

 

4 This is another 

new sentence. 

5 This sentence 

contains a term. 

6 Terms are added 

to the termbase. 

Dies ist ein Satz. 

Dies ist ein neuer 

Satz. 

Dies ist ein Satz. 

Dies ist ein Satz. 

Dies ist ein we    

neuer Satz. weitere 

weiterer 

weiteres 
 

Dies ist ein weiterer 

neuer Satz. 

Dieser Satz beinhaltet 

einen Terminus.  term  Terminus 

Terminus Termini werden in der 

Termbank gespeichert. 

Alignment of translated files 

 

SDL WinAlign 

 

Terminology extraction 

Glossary conversion 

SDL MultiTerm Extract 

SDL MultiTerm Convert 
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Segment status concept 

Not 
translated 

Draft Translated 

Translation 
approved 

Signed-off 
Sign-off 
rejected 

Translation 
rejected 

Translator 

Reviewer 1 

Reviewer 2 or 

Project manager 
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SDL Trados Studio 2011 – Applications 
overview 

SDL Trados 

Studio 2011 

SDL MultiTerm 

2011 

SDL WinAlign SDL OpenExchange 

Apps 

• Translation 

environment 

‒ Translation editor 

‒ Translation 

memory 

‒ AutoSuggest™ 

‒ Interface to 

termbase 

‒ Project 

management 

‒ QA plug-ins 

• Terminology 

management 

SDL MultiTerm 

‒ Desktop 

‒ Convert 

‒ Extract* 

‒ Widget 

‒ Administrator* 

 

‒ Interface to MS 

Word, SDL 

Trados Studio, 

SDL Passolo 

• Alignment • Extensions 

‒ SDLXLIFF Converter 

for MS Office 

‒ SDL T-Window for 

Clipboard 

‒ SDL Batch Find / 

Replace 

‒ SDL TTX It! 

More apps available  

for download! 
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User Interface overview 

Work pane 

View 

navigation 

buttons 

Navigation 

pane 

Menus and 

toolbars 

Status bar 

Integrated, fully customizable user interface. You can maximize, minimize, move 

windows to a second screen… 

F11 



Training presentation 



 

 
 

 

Supported File Types, Pre-production, Processes 

Additional information 
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Supported File Types 

Office Formats 

 Microsoft Word (2000, XP, 2003, 2007, 2010) 

 Microsoft PowerPoint (XP, 2003, 2007, 2010) 

 Microsoft Excel (2000, XP, 2003, 2007, 2010) 

 OpenOffice 

 

Desktop Publishing Formats 

 Adobe FrameMaker (8, 9, 10 MIF files) 

 Adobe InDesign (CS2, CS3, CS4, CS5 INX & IDML files) 

 Adobe InCopy (CS4, CS5 ICML) 

 QuarkXPress (through SDL Trados 2007) 

 Interleaf / QuickSilver (through SDL Trados 2007) 

 PageMaker (through SDL Trados 2007) 
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Supported File Types 

Software 

 Java Resources 

 DLLs, Executables (through SDL Passolo) 

 Microsoft .NET Resources 

 

Mark-up Formats 

 HTML 

 Custom XML 

 XLIFF 

 OASIS DITA, DocBook, and W3C ITS compliant XML 

 SGML (through SDL Trados 2007) 
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Supported File Types 

Text-only Formats 

 Delimited text files 

 Custom text formats through freely-definable  

regular expressions filter 

 

PDF 

 

Bilingual Formats 

 DOC/X (SDL Trados) 

 TTX (SDL Trados) 

 ITD (SDLX) 

 SDLXLIFF 

 For all file formats various settings are available under: 

Tools > Options > File types 



 

 
 

 

Pre-production Overview 
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Pre-production overview 

Translation 

Memories (TM) 

Termbases 

(TB) 

File preparation 

and testing 

Upgrading TMs from 

SDL Trados 2007 

 

Creation & 

configuration of TMs 

 

TM maintenance 

 

Alignment 

 

Creation & 

configuration of TBs 

 

Upgrading TBs from 

SDL MultiTerm 2007 

or earlier 

 

Converting  

glossaries 

 

Terminology 

extraction 

 

File conversion 

 

Creation & 

configuration of file 

types 

 

Pseudo-translation 

 

Native application 

Trados Studio 2011 

Trados Studio 2011 Trados Studio 2011 

Trados Studio 2011 

WinAlign MultiTerm Extract 2011 

Trados Studio 2011 

MultiTerm Convert 

MultiTerm 2011 

MultiTerm 2011 

AutoSuggest™ 

dictionaries (AS) 

Generation of 

AutoSuggest 

dictionaries 

 Trados Studio 2011 



 

 
 

 

Pre-production 
Detailed view 
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SDLTM 

 

Language 

resources 

(optional) 

• Variable list 

• Abbreviation list 

• Ordinal follower list 

• Segmentation rules 

 

Fields and 

settings 

(optional) 

• Text or List fields 

• Settings 

• Recognize dates 

• Recognize times 

• Recognize numbers 

• Recognize acronyms 

• Recognize variables 

• Recognize 

measurements 

 

Creating Translation Memories 

If product names and proper names are added to the variable list they will be treated 

as placeables during translation. 

The TM needs to be re-indexed if language resources have been added or modified. 

SDL Trados Studio 

General 

information 

• Name, description, 

copyright  

• Languages 

• Character-based 

concordance search 
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TMX 

Export  

• Convert to supported 

file format 

• Check formatting 

• Hide text 

Verify 

alignment 
 

• View statistics 

• Disconnect units 

• Commit units 

• Split/merge units 

• Edit units 

• Re-align 

• Mark as complete 

Align 

project 
 

• Align file pair 

• Align project 

Aligning Translated Documents 

Don’t forget to save the alignment project (PJT). 

The exported TMX file can be imported into a translation memory. 

WinAlign can be started from the Home view via the button Align translated 

documents. 

Create 

alignment 

project 

• Languages 

• File format 

• Project files 

• Parameters 

• Export options 

Source 

language 

Target 

language 

100% 

SDL WinAlign 
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Generate AutoSuggest Dictionaries 

A TM with at least 25,000 translation units is required to generate an AutoSuggest 

dictionary. 

AutoSuggest generation process can run in the background. 

AutoSuggest dictionaries are not updated during translation. 

Generate 

• SDLTM or TMX file 

• Settings 

 

BPM 

SDL Trados Studio 
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SDLTB 

 

Specify 

entry 

structure 

 

• Entry level 

• Index level 

• Term level 

Add  

fields 
 

• Index fields = 

languages 

• Descriptive fields 

• Status, Note, Context, 

Source… 

• Type: Text, Picklist, 

Multimedia 

 

Add 

general 

information 

 

• Name 

• Description 

• Copyright 

Creating Termbases 

Specify 

Termbase 

definition 

• Create new termbase 

definition 

• Use 

• predefined termbase 

template 

• existing termbase 

definition 

• existing termbase 

SDL MultiTerm 

The predefined termbase templates can be adjusted and extended during termbase 

creation. 

What information is 

needed in addition to 

source and target term? 

Add as little fields as 

possible and as many as 

necessary… 

Which field describes the 

concept (entry level)? 

Which field relates to the 

whole language (index 

level) and which one to a 

specific term (term level) 
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SDLTB 

Converting glossaries 

When importing into existing glossaries: Make sure that column headers in the 

glossary to be converted match the field names defined in the MultiTerm termbase. 

CSV, TXT, 

XLS/X, TBX 

Convert 

• Map imported 

information to 

termbase structure 

• Convert 

 

Create 

termbase 

• Based on termbase 

definition (XDT) 

 

Import 

terms 

• Into existing or new 

termbase 

 

SDL MultiTerm Convert SDL MultiTerm 



 

 
 

 

Translation processes 
Detailed view 
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DOC/X, 
PPT/X, 
XLS/X 
… 

Translating Single Files 

Make sure all translations are confirmed before saving the translation! 

• Save Target as 

• Update TM 

• Mark as complete 

• Remove from list 

 
Save 

translation 
Translation  

• Look-up in TM, TB, AS 

• Confirm translations 

• Add comments 

• Preview 

• Spell checking (F7) 

• QA Verification (F8) 

• Terminology verification 

 

 
Open 

document 

• Open document 

• Add TM, TB, AS 

• Save bilingual 

SDLXLIFF 

DOC/X, 

PPT/X, 

XLS/X 

… 

SDLXLIFF SDLXLIFF 
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SDLRPX 

Translating Project Package Files 
(Translator’s Perspective) 

Make sure all translations are confirmed before creating the return package! 

• From Projects view 

• From Files view (partly 

delivery) 

• Send via email or FTP 

 

Create 
return 

package 

Translation  

• Confirm translations 

• Add comments 

• Preview 

• Display filter 

• Spell checking (F7) 

• QA Verification (F8) 

• Terminology verification 

 

 
Open 

package 

• Import local project 

• Verify reports 

• Open files 

SDLPPX 

ZIP! 
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SDLRPX 

Delivering the Translated Project 
Packages (Translator’s Perspective) 

The return package only contains the translated SDLXLIFF files! 

Note: You can also do a partly delivery… 

 

Create 
return 

package 

• From Projects view 

• From Files view 

(partly delivery) 

• Send via email or FTP 

SDLXLIFF 
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Working With Comments 

The display filter can be found under View > Toolbars > Display filter. 

Add conventions for using comments to translation guidelines. 

• Add comments 

• Document 

• Segment 

• Selection 

• Display filter > 

Segments with 

comments 

• Edit comments 

• Delete comments  

 

SDLRPX 
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Batch Tasks > Verify 

Verifying translated documents 

 Review  Translation  

Interactive verification (Ctrl+Enter) 

F7 / F8 

Tools > Options > Verification & Tools > Options > Editor > Spelling 

QA Checker options can be saved in a QA Checker profile 

 

Report 
Error 

Warning 

Note 

Spell checking 

Hunspell 

Microsoft Office 

Segment verification 

with QA Checker 3.0 

Segment verification 

Inconsistencies 

Punctuation 

Numbers 

Word List 

Regular Expressions 

Trademark Check 

Length verification 

Exclude Segments 

Terminology verification 

Check for forbidden terms 

Check for non-usage of target 

term 

Check for terms without 

translation in TB 

Document verification 

Tag verification 
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Dealing with formatting, tags, 
placeables  

You can use the QuickPlace function to insert formatting, tags and placeables. 

Ctrl+, 
Formatting 

 

Tags 

 

Ghost-Tags  

Placeables 
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Review 

Menu View > Toolbars > Display Filter 

Using the Display filter 

Translation 

General 
Segment  

types 

Segment 

review status 

Segment 

review 

Segment 

locking 

Search 

expression 

All segments 

All content 

New translated 

content 

100% matches 

Context matches and 

PerfectMatch 

Fuzzy matches 

Automatically 

translated 

Unconfirmed 

Not translated 

Draft 

Duplicates 

 

Translated 

Translation 

approved 

Translation 

rejected 

Signed off 

Sign off 

rejected 

With 

messages 

With 

comments 

With tracked 

changes 

Locked 

Unlocked 

Source language 

Target language 

Supports regular 

expressions 

Segment 

content 

Number only 

Excluding 

number only 

Restrict the editor to 

show only certain 

segments 

Sign-off 
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Previewing translated files 

 

 

 

 
 

Place on 2nd screen 

See your translation progress segment-by-segment in the native document format. 

Available for DOC/X, PPT/X, RTF, HTML, XML 
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Automating tasks with batch tasks 

Processes performed by SDL Trados Studio 2009 on 

 an individual file / a group of files / the entire project 

Can be combined into a task sequence 

The results of a batch task can be viewed in a report. 

   

    

 

 

Pre-

production 

& file 

preparation 

Project 

creation 

Project 

preparation 
Translation 

Review Sign-off 
Project 

finalization 
Delivery  

 

• Convert to translatable 

format 

• Copy to target 

languages 

• Analyze 

• Pre-translate 

• Create project TM 

• Apply PerfectMatch 

Project 

preparation 

Project 

finalization 

• Update TMs 

• Update TBs 

• Save translated files 

• Export files 

Batch tasks 

Task sequences 



Questions? 

producttraining@sdl.com 

https://support.sdl.com 
 

mailto:producttraining@sdl.com
https://support.sdl.com/


How was your SDL 
Trados Training today? 

Please fill in the online feedback form to 

help us to make our training (even) better: 

http://bit.ly/Studio2011   

http://bit.ly/Studio2011


Thank you very much 

for your attention! 
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